+ Reply
Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 67

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: [RELEASE] WbApp WinterBoard GUI

is a discussion within the

Native iPhone / iPod Touch App Launches

forums, a part of the

3rd Party Apps For iPhone | iPod Touch

section;
Originally Posted by realism Here's a crazy idea... Why not just have this built into the app and put it out as your own modified app. I speak for myself
...
  1. #21
    Retired Moderator CyberGreg's Avatar
    Join Date
    Jul 2007
    Posts
    1,096
    Thanks
    58
    Thanked 207 Times in 138 Posts

    Quote Originally Posted by realism View Post
    Here's a crazy idea... Why not just have this built into the app and put it out as your own modified app. I speak for myself and maybe for a few other when I say "I can do without the extra icon..."

    I don't mean to sound ungrateful. Thanks for taking the time to develop this feature I'm just putting an idea out there.
    I have kept Jay informed of my progress all through my beta's by got no response. I'm sure he's busy and doesn't need my crazy stuff to deal with. Plus with my version you can't select mor than one theme and I know that's the path he's headed.

    Me - I'm headed down the path where I want to add the ability to "build" you own themes from pieces and parts of existing themes.

    White 3G

  2. #22
    Green Apple phoenix.stu's Avatar
    Join Date
    Dec 2007
    Posts
    72
    Thanks
    7
    Thanked 10 Times in 7 Posts

    Quote Originally Posted by CyberGreg View Post
    That is indeed odd, it works on all of my WinterBoard and SummerBoard themes, as shown in the screenshots. There ARE some WinterBoard themes, like Time of Day that DO NOT have any icons, therefor there will be no preview, however those are indeed the exception and not the norm. It could be a permissions problem. When you browse your phone can you get to your WinterBoard themes from /Library/Themes ?




    See attachment, unzip and place the folder inside the Bundles folder in whatever WinterBoard theme you want to use these.


    Thanks a bunch.

  3. #23
    Livin the iPhone Life SundayDuffer's Avatar
    Join Date
    Aug 2007
    Location
    Northern California
    Posts
    1,503
    Thanks
    32
    Thanked 181 Times in 164 Posts

    CyberGreg,

    When I sh postinst.sh (6 or more times, same message)
    Putty keeps on giving me this:

    chown: cannot access 'Documents/Themes' : No such file or directory

    When i checked the Documents folder, i only see DotThemelist.plist and Themelist.plist in there.

    Help needed please....thankyou.

  4. #24
    Retired Moderator CyberGreg's Avatar
    Join Date
    Jul 2007
    Posts
    1,096
    Thanks
    58
    Thanked 207 Times in 138 Posts

    Quote Originally Posted by SundayDuffer View Post
    CyberGreg,

    When I sh postinst.sh (6 or more times, same message)
    Putty keeps on giving me this:

    chown: cannot access 'Documents/Themes' : No such file or directory

    When i checked the Documents folder, i only see DotThemelist.plist and Themelist.plist in there.

    Help needed please....thankyou.
    Yup that would indeed be a problem. It requires both a Documents folder and a Themes sub folder. All you have to do is make the Themes folder and then run the postinst.sh script and it will set the correct permissions.

    Just to be crystal clear:
    /Applications/WbApp.app/Documents <-must be there
    /Applications/WbApp.app/Documents/Themes <-must be there



    and for all those that are as anal as I am here's why:
    I use the Documents folder to store my plist file, this way I can build it with my additional "type" field (Wb vs Smb)
    I use the Themes sub-folder to store the links to the themes for the previews. I store them as symlinks so they do not take up any extra space and are easily removed.
    Last edited by CyberGreg; 08-13-2008 at 12:57 PM. Reason: added more info
    White 3G

  5. #25
    Green Apple
    Join Date
    Oct 2007
    Posts
    84
    Thanks
    0
    Thanked 11 Times in 11 Posts

    everything working fine for me over here.

    winscpd the files over
    775d the permissions
    ran the script with putty "./whatever.sh"

  6. #26
    Retired Moderator CyberGreg's Avatar
    Join Date
    Jul 2007
    Posts
    1,096
    Thanks
    58
    Thanked 207 Times in 138 Posts

    My friend just found a bug - if you select the first three options then Time of Day overwrites the trans text labels. Hand on a sec and I'll get that fixed.
    White 3G

  7. #27
    Livin the iPhone Life SundayDuffer's Avatar
    Join Date
    Aug 2007
    Location
    Northern California
    Posts
    1,503
    Thanks
    32
    Thanked 181 Times in 164 Posts

    Quote Originally Posted by CyberGreg View Post
    Yup that would indeed be a problem. It requires both a Documents folder and a Themes sub folder. All you have to do is make the Themes folder and then run the postinst.sh script and it will set the correct permissions.

    Just to be crystal clear:
    /Applications/WbApp.app/Documents <-must be there
    /Applications/WbApp.app/Documents/Themes <-must be there



    and for all those that are as anal as I am here's why:
    I use the Documents folder to store my plist file, this way I can build it with my additional "type" field (Wb vs Smb)
    I use the Themes sub-folder to store the links to the themes for the previews. I store them as symlinks so they do not take up any extra space and are easily removed.
    Awesome...worked like a charm. Thankyou.
    I do miss iSwitcher.
    Keep us posted with new changes please. thx.

  8. #28
    Retired Moderator stlcaddie's Avatar
    Join Date
    Jul 2007
    Location
    Saint Louis, MO
    Posts
    1,087
    Thanks
    139
    Thanked 128 Times in 90 Posts

    Quote Originally Posted by CyberGreg View Post
    n/p

    Once logged in:
    cd /Applications/WbApp.app
    now press enter
    ./postinst.sh
    now press enter

    You now have to either run an app like Respring or if you're still in Terminal type

    killall SpringBoard
    now press enter

    Once SpringBoard relaunches, run WbApp

    Works perfect now...I can see the previews and all. I thought just setting permissions would to it, but no. I ran ./postinst.sh , and walla. Thanks

  9. The Following User Says Thank You to stlcaddie For This Useful Post:

    CyberGreg (08-13-2008)

  10. #29
    Retired Moderator CyberGreg's Avatar
    Join Date
    Jul 2007
    Posts
    1,096
    Thanks
    58
    Thanked 207 Times in 138 Posts

    Quote Originally Posted by stlcaddie View Post
    Works perfect now...I can see the previews and all. I thought just setting permissions would to it, but no. I ran ./postinst.sh , and walla. Thanks
    SWEET....

    okay first post has been updated with the bug fix on the sequencing so now if you set the three options; Black Nav Bars, Time of Day and Trans Icon Labels, it loads the theme properly.

    Here's the updated link to save you from hitting the first thread again:
    LINKAGE

    For those that already have it installed, all you have to do is replace the app (WbApp).
    White 3G

  11. #30
    iPhone? More like MyPhone t3abags's Avatar
    Join Date
    Dec 2007
    Posts
    104
    Thanks
    8
    Thanked 17 Times in 17 Posts

    Nice App, but you cant apply more than one theme at one time and the app makes a copy of every theme previewed/applied in the WbApp folder...
    8gb 2G iPhone 2.1 (Pwned)


  12. #31
    Retired Moderator CyberGreg's Avatar
    Join Date
    Jul 2007
    Posts
    1,096
    Thanks
    58
    Thanked 207 Times in 138 Posts

    pf is all set to get this guy up on Cydia. I'd just like to get a few more confirmations from users. Especially the update.

    Please post your results, success or not - THANKS!!!


    PS Even though the new zip file say v2 please know that this is like version 26 or something and I have been working on this since WinterBoard was released. Clearly I can't code that fast

    Quote Originally Posted by t3abags View Post
    Nice App, but you cant apply more than one theme at one time and the app makes a copy of every theme previewed/applied in the WbApp folder...
    Correct and INCORRECT

    Only one theme and it uses symlinks and DOES NOT make copies. I realize they may look like copies but they are links and do not take up any extra space.
    Last edited by CyberGreg; 08-13-2008 at 01:58 PM. Reason: Automerged Doublepost
    White 3G

  13. #32
    iPhone? More like MyPhone fletch33's Avatar
    Join Date
    Aug 2007
    Location
    Under a Rug
    Posts
    268
    Thanks
    3
    Thanked 26 Times in 18 Posts

    i am on a mac.

    i followed the instruction. placed it in applications folder and it has the themes and docs folder and set the permission again just to be sure. i was not able to get mobile terminal to run the ./file because it says i dont have permission. however the app ran but i only saw your themes and i had no previews?

    thanks
    "i believe louisiana is the pelican state"

  14. #33
    My iPhone is a Part of Me signori's Avatar
    Join Date
    Oct 2007
    Location
    Toronto
    Posts
    521
    Thanks
    283
    Thanked 315 Times in 180 Posts

    How do you change the permissions using terminal. My wifi is not working so I can't use Winscp to do everything.

  15. #34
    Retired Moderator CyberGreg's Avatar
    Join Date
    Jul 2007
    Posts
    1,096
    Thanks
    58
    Thanked 207 Times in 138 Posts

    Quote Originally Posted by fletch33 View Post
    i am on a mac.

    i followed the instruction. placed it in applications folder and it has the themes and docs folder and set the permission again just to be sure. i was not able to get mobile terminal to run the ./file because it says i dont have permission. however the app ran but i only saw your themes and i had no previews?

    thanks
    That is still due to the permissions on those folders and the app can not properly link the theme images. You need to either manually set the owner or, oops nevermind, you're on a Mac.

    Replace your phone's ip address with 192.168.1.100 in this and run it in Terminal:
    ssh -l root 192.168.1.100
    it will then prompt you for the password (alpine)
    then cd /Applications/WbApp.app
    ./postinst.sh


    Quote Originally Posted by signori View Post
    How do you change the permissions using terminal. My wifi is not working so I can't use Winscp to do everything.
    If it's even possible the commands would still be the same. You change to the app directory (cd /Applications/WbApp.app) then run ./postinst.sh
    Something tells me this is not going to work on the phone though...

    You might want to wait a bit and once we're sure it's working as designed it will be available via Cydia but thank-you for posting.
    Last edited by CyberGreg; 08-13-2008 at 02:37 PM.
    White 3G

  16. #35
    iPhoneaholic
    Join Date
    Sep 2007
    Location
    Milton, Ontario
    Posts
    467
    Thanks
    21
    Thanked 43 Times in 37 Posts

    Quote Originally Posted by CyberGreg View Post
    That is indeed odd, it works on all of my WinterBoard and SummerBoard themes, as shown in the screenshots. There ARE some WinterBoard themes, like Time of Day that DO NOT have any icons, therefor there will be no preview, however those are indeed the exception and not the norm. It could be a permissions problem. When you browse your phone can you get to your WinterBoard themes from /Library/Themes ?




    See attachment, unzip and place the folder inside the Bundles folder in whatever WinterBoard theme you want to use these.
    Cant seem to get this link to the ZIP to work. Any suggestions? Would love to grab those carrier logos.

  17. #36
    Retired Moderator CyberGreg's Avatar
    Join Date
    Jul 2007
    Posts
    1,096
    Thanks
    58
    Thanked 207 Times in 138 Posts

    Quote Originally Posted by Hyperextension View Post
    Cant seem to get this link to the ZIP to work. Any suggestions? Would love to grab those carrier logos.
    Odd, I just downloaded them, anyhow... here are the actual images:
    Attached Images Attached Images   
    White 3G

  18. #37
    Owner / Founder - ModMyi
    aka poetic_folly
    Kyle Matthews's Avatar
    Join Date
    May 2007
    Location
    Tampa, Florida, United States
    Posts
    8,475
    Thanks
    569
    Thanked 4,799 Times in 1,223 Posts

    This is now posted in Cydia.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  19. #38
    What's Jailbreak?
    Join Date
    Mar 2008
    Location
    Seattle, WA, USA
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    you rock... We needed this ... THANK YOU!!!!

  20. #39
    iPhoneaholic
    Join Date
    Mar 2008
    Location
    Dallas, TX
    Posts
    400
    Thanks
    48
    Thanked 47 Times in 43 Posts

    Awesome cant wait to get home to try this!!!! Thanks a million greg looks smooth
    Last edited by Muggz5; 08-13-2008 at 06:08 PM.

  21. #40
    iPhoneaholic
    Join Date
    Jul 2008
    Location
    Winter Park, Florida
    Posts
    494
    Thanks
    64
    Thanked 101 Times in 60 Posts

    So I downloaded the app via cydia and it installed properly. But, when i open it, i see the main screen and then it quits to the home screen. I ssh-ed and changed the permissions but that didn't work either. Any ideas???

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts