Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: BSD subsystem 2

  1. #1
    Default BSD subsystem 2
    So BSD subsystem 2 came out.. installed on my 1.1.2 iPhone...

    but now, terminal doesnt work. it gives me:

    [Process Completed] when I open it..

    so whats going on with that?

    if it matters, my iPhone uses bash in SSH... modded from a tutorial here.

    Solved, for anyone that is having this issue.. just simply redo the BASH mod using WinSCP, or undo it ^^..

    Solved, for anyone that is having this issue.. just simply redo the BASH mod using WinSCP, or undo it ^^..
    Last edited by DarkMindZ; 01-26-2008 at 10:52 PM. Reason: Automerged Doublepost

  2. #2
    I've got an issue with terminal after installing BSD 2.0. Most commands work, but e.g. trying "top" to view cpu usuage fails and displays: "Error opening terminal: network".


    Anyone else experiencing the same problem?

  3. #3
    Yep, I ran across the top problem myself. It runs fine via SSH though, so I suspect the BSD update changed something related to terminal.app.

    I've just placed it on the mobileterminal bug list, we'll see if it can get fixed.

    Edit: Seems the /etc/profile file doesn't have the TERM defined. I added the following lines:

    TERM="vt102"
    export TERM

    and now top works for me. Not 100% sure if I should have used vt100 or vt102 (or what the difference is!), but it works at least.
    Last edited by cazlar; 01-28-2008 at 05:23 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •