Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: ssh2 on iPhone, but ssh?

  1. #1
    Default ssh2 on iPhone, but ssh?
    on my iPhone, in /bin, i have all sorts of ssh and scp and the sftp and all that fun stuff, but theres no "just" 'ssh'... can someone provide that, or is there a reason it wasn't in the binkit sshkit on nate true's site?

    THANK YOU

    ...remember to push for the nes emulator to be worked on
    Last edited by 89.tristan; 08-06-2007 at 10:51 PM.

  2. #2
    You need to rename ssh2 to ssh. Afterwords, it should work :]

  3. #3
    I still get caught in a loop asking for passwords, I'll upload a screenshot later...

  4. #4
    Green Apple dmbaird's Avatar
    Join Date
    Jul 2007
    Location
    Palm Springs, California
    Posts
    55
    Thanks
    4
    Thanked 6 Times in 6 Posts

    Quote Originally Posted by 89.tristan View Post
    I still get caught in a loop asking for passwords, I'll upload a screenshot later...
    yes same here

  5. #5
    Quote Originally Posted by dmbaird View Post
    yes same here
    what program (terminal / WinSCP) are you using to connect to the iPhone with SSH?

    you may be trying to connect with a user other than root - on a mac when you ssh in terminal... the command will be:

    ssh [email protected]

    where x.x.x.x is the ip address of your phone

    hope this helps... maybe not though...

  6. #6
    unfortunately its the latter choice, what we are trying to do is not ssh TO the iPhone, but out of it... ssh'ing to it works perfectly...

  7. #7
    I have found that passwords with certain characters don't work, '#' for me didn't work. When I ssh'ed into a box without a '#' in the password it worked.

  8. #8
    my passwords are hexadecimal.... only numbers and letters

  9. #9
    what i am trying to do works from my mac -> iphone, but not iphone -> mac

    i have tried ssh -l root 192.168.0.2
    i have tried ssh [email protected]
    amongst others...

    i have no need for all the security options, just the connection, as open as it may be,

    i successfully connect to the mac, it says am i sure, yada yada yada, i type yes, then it asks for the pass, then it starts the loop that you see at the bottom.... please help
    Attached Thumbnails Attached Thumbnails -foo_0.png  

  10. #10
    iPhone? More like MyPhone Daerid's Avatar
    Join Date
    Jul 2007
    Location
    Seattle, WA
    Posts
    290
    Thanks
    2
    Thanked 23 Times in 18 Posts

    I have terminal and binkit installed, but I have no ssh or ssh2 option from the iPhones terminal. What am I missing?

  11. #11
    look at where u got the binkit, theres also an ssh kit

    (iphone.natetrue.com or something like that)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •