This might of been answered already sorry but can frash be downloaded on the iPad 3.2.2? I try to and it says Im missing some file?