Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Terminal Issue

  1. #1
    Default Terminal Issue
    VT100 allows me to run TOP, but MobileTerminal never has, and now that I'm running Summerboard TOP give me:

    SummerBoardLoader: SummerBoardService available.
    Error opening terminal: unknown.
    Last edited by darngooddesign; 09-04-2007 at 11:35 PM.
    Various 'Books old and new
    8 Giggity, Giggity, Gigg-it-y.

  2. #2
    I'm having the same issue. Can someone tell me how to run TOP with Mobile Terminal?

  3. #3
    The issue that I'm having with terminal is that there is random text when I open the application on the iphone. Here is a screenshot.





    ls of /bin directory
    screenshot command

    i also get duplicate characters as shown. iphone version 1.02

    my prompt appears as [1m[7m#[m[1m[0m [0m[m[m[J# [K

    Why is this and how do I correct it?
    Last edited by iNfEk; 09-20-2007 at 01:14 PM. Reason: Automerged Doublepost

  4. #4
    Green Apple
    Join Date
    Jun 2007
    Location
    Baltimore
    Posts
    78
    Thanks
    4
    Thanked 3 Times in 2 Posts

    just get term-vt100. it doesn't have the crap problems that MobileTerminal has.

    it's way better than MobileTerminal.. you can tap-drag to get arrow keys, tab, ctrl-c, ctrl-d, escape.. all very important when working in unix.

    MobileTerminal is an awful terminal IMO.

    edit: also change the TERM variable to xterm in your /etc/profile. you'll get a much friendlier environment especially if you use PuTTY or Terminal on OS X to get in a lot.
    Last edited by hillie; 09-21-2007 at 09:30 PM.

  5. #5
    i agree after posting this and trying term-vt100

    thanks though for replying

  6. #6
    Retired Moderator iphonejeff's Avatar
    Join Date
    Jul 2007
    Location
    Los Angeles
    Posts
    1,339
    Thanks
    18
    Thanked 70 Times in 62 Posts

    when i try to do something on term-vt100 it takes me back to the home screen

  7. #7
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Davis, California
    Posts
    674
    Thanks
    21
    Thanked 83 Times in 74 Posts

    Quote Originally Posted by iphonejeff View Post
    when i try to do something on term-vt100 it takes me back to the home screen
    but it actually lets you type the command? Maybe your binaries dont have the correct permissions

  8. #8
    Retired Moderator iphonejeff's Avatar
    Join Date
    Jul 2007
    Location
    Los Angeles
    Posts
    1,339
    Thanks
    18
    Thanked 70 Times in 62 Posts

    i try typing the command and when im half way there it just closes and goes to the home screen..i thought since it was in installer it was iphone ready...

  9. #9
    i was having the same problem with the term crashing as i typed a command in. It was also occuring in an ssh session from my pc (half way through the command the connection dropped). I found the solution to be reinstalling the BSD subsystem. No more problems after that!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •