Page 2 of 2 FirstFirst 12
Results 21 to 28 of 28

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Summerboard themes on 1.1.3 not working

  1. #21
    Thumbs up permanent fix for smb theme issue
    here's what the problem is with smb in 113...

    all themes (atleast all of my fav ones ) get downloaded in the folder /var/root/Library/SummerBoard/Themes and the program looks up the folder /var/mobile/Library/SummerBoard/Themes for themes.

    therefore, all newly downloaded themes dont show up in the list...leading to the cumbersome method of moving the themes from root to mobile after every download

    a simple fix to the above problem is (every step is followed by the code to perform that function)

    1. make sure when you start there no new themes (only the default ones)

    2. remove the themes directory in the root folder
    Code:
    rm -rf /var/root/Library/SummerBoard/Themes
    3. create an alias(symbolic link) in the same place which points to the theme directory in mobile
    Code:
    ln -s /var/root/Library/SummerBoard/Themes /var/mobile/Library/SummerBoard/Themes
    after this, all the new themes downloaded will go in the right folder and will show up in the app

    you can enter these commands from the terminal after sshing into your phone. for mac: terminal can be used, for windows ive head winputty or something like that is great... i personally would suggest to download the termvt-100 app and do is straight on the phone, saves you a little bit of effort

    cheers!
    rohan

    p.s. i claim no responsibility should anything happen to your iphone (though id sure like to know how u managed that )


    update: this is exactly what the smb theme fix by bigboss does. but i also read that all the themes have been updated with the correct paths... i wonder why the issue still persists...?
    Last edited by rohank; 02-20-2008 at 02:41 PM.

  2. #22
    it is still not working. i did every thing but my themes are not showing up! help
    Jail break 1.1.3 and SMB 3.1

  3. #23
    hey i tried changing the permissions to 755 and that seemed to work fine
    well at least the backgrounds of the themes showed up but idk if they had custom icons to begin with...


    if you want to know how to change the permissions, this is how (for a PC):

    go to WinSCP

    find the file

    highlight it and press F9 (preferences)

    check the boxes under W

    check the top box under R

    check the boxes under X

    click ok





    then give it a try...


    (edit) ok i just figured out how to make the icons work too. you have to go into each theme individually, go into the icons folder, select all of the files and change their permissions to 755

    kind of a pain if you have alot of themes like i do

    hope this helps...
    Last edited by DisownedPenny; 02-25-2008 at 10:25 PM.

  4. #24
    Default Resolution ;)
    Quote Originally Posted by rohank View Post
    here's what the problem is with smb in 113...

    all themes (atleast all of my fav ones ) get downloaded in the folder /var/root/Library/SummerBoard/Themes and the program looks up the folder /var/mobile/Library/SummerBoard/Themes for themes.

    therefore, all newly downloaded themes dont show up in the list...leading to the cumbersome method of moving the themes from root to mobile after every download

    a simple fix to the above problem is (every step is followed by the code to perform that function)

    1. make sure when you start there no new themes (only the default ones)

    2. remove the themes directory in the root folder
    Code:
    rm -rf /var/root/Library/SummerBoard/Themes
    3. create an alias(symbolic link) in the same place which points to the theme directory in mobile
    Code:
    ln -s /var/root/Library/SummerBoard/Themes /var/mobile/Library/SummerBoard/Themes
    after this, all the new themes downloaded will go in the right folder and will show up in the app

    you can enter these commands from the terminal after sshing into your phone. for mac: terminal can be used, for windows ive head winputty or something like that is great... i personally would suggest to download the termvt-100 app and do is straight on the phone, saves you a little bit of effort

    cheers!
    rohan

    p.s. i claim no responsibility should anything happen to your iphone (though id sure like to know how u managed that )


    update: this is exactly what the smb theme fix by bigboss does. but i also read that all the themes have been updated with the correct paths... i wonder why the issue still persists...?
    I had the same issue, and thanks to Rohan for pointing out where the folders are.

    To resolve the issue, change #3 in Rohan's post to:

    Code:
    ln -s /var/mobile/Library/SummerBoard/Themes  /var/root/Library/SummerBoard/Themes
    This command will create a link in /var/root/Library/SummerBoard with name Themes, and that points to /var/mobile/Library/SummerBoard/Themes. So each time you install a new theme, the files go to /var/mobile/Library/SummerBoard/Themes.

    Cheers!
    Last edited by mtraballo0321; 02-25-2008 at 10:49 PM.

  5. #25
    Default Smb Themes Fix by Big Boss
    Hey guys, I see in my Installer that there is a 1.1.3 Themes Fix claiming to create the link from /var/root to /var/mobile for summerboard themes. Is this safe to install on my phone? I've been getting the same problem as a lot of people...some themes work while other don't. Also, if I do install this, do I need to uninstall the themes that don't work and then reinstall?

  6. #26
    Quote Originally Posted by mrfurious214 View Post
    Hey guys, I see in my Installer that there is a 1.1.3 Themes Fix claiming to create the link from /var/root to /var/mobile for summerboard themes. Is this safe to install on my phone? I've been getting the same problem as a lot of people...some themes work while other don't. Also, if I do install this, do I need to uninstall the themes that don't work and then reinstall?
    Im pretty sure all the package on Installer does is the exact same thing mentioned, but you dont have to do anything...

  7. #27
    Is there anyone else that can confirm using the 1.1.3 Themes Fix from Installer is okay? I don't want anything gettting screwed up on my phone. Thanks.

  8. #28
    Livin the iPhone Life desepticon's Avatar
    Join Date
    Feb 2008
    Location
    USA
    Posts
    1,004
    Thanks
    27
    Thanked 107 Times in 99 Posts

    there is also a summerboard theme permission fix on installer

Page 2 of 2 FirstFirst 12
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •