+ Reply
Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: cannot switch EDGE off with (Net)Services, iToggle

is a discussion within the

Native iPhone / iPod Touch App Discussion

forums, a part of the

3rd Party Apps For iPhone | iPod Touch

section;
I'm on 1.1.2 and I am unable to really switch EDGE off. Services and NetServices behaviour: turn EDGE switch to OFF, start Safari, EDGE is enabled!, when I look back
...
  1. #1
    Green Apple
    Join Date
    Oct 2007
    Posts
    31
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Question cannot switch EDGE off with (Net)Services, iToggle
    I'm on 1.1.2 and I am unable to really switch EDGE off.

    Services and NetServices behaviour:
    turn EDGE switch to OFF, start Safari, EDGE is enabled!, when I look back in (Net)Services the EDGE switch moved automagically back to ON!

    iToggle 1.0.4 behaviour:
    this one was giving me the option to really switch it off, but it seemed to be a dangerous application as it could cause a crash of the phone. So I upgraded to iToggle 1.0.5.

    iToggle 1.0.5 behaviour:
    nothing basicly: both the EDGE and BLUETOOTH switched are greyed out, so they cannot be operated.


    Regardless of the settings in the EDGE server/username/password field EDGE is "active" on my phone. I tried all kinds of dummy settings there but still my phonebill gets huge because of the fact that EDGE keeps on working.


    * is it possible that iToggle messed up some file now that 1.0.5 shows some greyed out switches? If so, which files and how can I restore them (without restoring the iphone)?

  2. #2
    Green Apple
    Join Date
    Jul 2007
    Posts
    60
    Thanks
    5
    Thanked 1 Time in 1 Post
    Use the Services.app instead it works period..go through the installer

  3. #3
    Green Apple
    Join Date
    Oct 2007
    Posts
    31
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by Bianca View Post
    Use the Services.app instead it works period..go through the installer
    Good that they work for you, but like I said: Services.app AND NetServices.app do NOT work in my case. What these apps do is fill some dummy stuff in the EDGE fields, my EDGE provider is insensitive to those things as it does not look at all at these settings.

    iToggle puts a fake IP-address somewhere, that's what makes it effective.

  4. #4
    Green Apple
    Join Date
    Oct 2007
    Posts
    86
    Thanks
    0
    Thanked 26 Times in 6 Posts

    Ha - thanks for your comments Bianca.. Great help.

    stefimke I am in the same situation, in fact I think there are many who are also. Services.app does not work for some once the initial details have already been entered correctly once.

    As of yet I have found no perfect solution. My temporary fix has been to ask my provider to disable EDGE/GPRS/ Wap all together, but obviously if I ever do need it in a no wifi situation I am buggered..

    I am on 1.0.2 - does 1.1.2 not have a on/off EDGE setting? Or is that just 1.1.1?

  5. #5
    iPhone? More like MyPhone The Punisher's Avatar
    Join Date
    Nov 2007
    Posts
    116
    Thanks
    5
    Thanked 13 Times in 10 Posts

    Quote Originally Posted by stefimke View Post

    iToggle 1.0.5 behaviour:
    nothing basicly: both the EDGE and BLUETOOTH switched are greyed out, so they cannot be operated.
    I have the same problem with my phone on 1.1.2 . The options are greyed out.

  6. #6
    Green Apple
    Join Date
    Oct 2007
    Posts
    39
    Thanks
    14
    Thanked 4 Times in 4 Posts

    i'm use iToggle to disable EDGE and it's working perfect for me to disable edge, i'm use 1.1.1 version on my phone. i think iToggle is perfect service application to disable EDGE.

  7. #7
    Green Apple
    Join Date
    Oct 2007
    Posts
    86
    Thanks
    0
    Thanked 26 Times in 6 Posts

    I remember reading something regarding the greyed out options.

    From what I can remember is it is something to do with having services already installed previously. If you had services already you need to make sure the options are set to on for all (BT, SSH, EDGE etc..) before you uninstall the program. Then you can install and you use iToggle.

  8. #8
    Green Apple
    Join Date
    Oct 2007
    Posts
    39
    Thanks
    14
    Thanked 4 Times in 4 Posts

    Quote Originally Posted by dane.pablecheque View Post
    I remember reading something regarding the greyed out options.

    From what I can remember is it is something to do with having services already installed previously. If you had services already you need to make sure the options are set to on for all (BT, SSH, EDGE etc..) before you uninstall the program. Then you can install and you use iToggle.
    smart idea to use iToggle Functionality.......

  9. #9
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    21
    Thanks
    1
    Thanked 3 Times in 2 Posts

    Not sure if this helps! but, i use iToggle v1.05, with firmware 1.1.2. Previous to the installation/ unistallation of Netservices my EDGE and Bluetooth options were also greyed out!
    So what i'm saying is install Netservices while iToggle is still installed. Play around with Netservices turn things on/off. Unistall and try iToggle.
    Don't know how it happened! but it allows me to toggle everthing now!
    Good Luck

  10. #10
    Green Apple
    Join Date
    Oct 2007
    Posts
    31
    Thanks
    5
    Thanked 0 Times in 0 Posts

    I'm back to NetServices due to great support of the author! The latest version enables me to really toggle the EDGE settings!

    check this thread: http://www.modmyi.com/forums/showthr...t=17699&page=8

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts