+ Reply
Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: installer keeps crashing?!

is a discussion within the

Native iPhone / iPod Touch App Discussion

forums, a part of the

3rd Party Apps For iPhone | iPod Touch

section;
This suddenly happened, it has been working great for days after I upgraded to 1.1.2 but now when I go to install a program on it it downloads fine but
...
  1. #1
    Green Apple j0hnnyw3st's Avatar
    Join Date
    Jul 2007
    Location
    Temecula, CA
    Posts
    69
    Thanks
    10
    Thanked 2 Times in 2 Posts

    Default installer keeps crashing?!
    This suddenly happened, it has been working great for days after I upgraded to 1.1.2
    but now when I go to install a program on it it downloads fine but as soon as it goes to install it crashes to my springboard.

  2. #2
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Same to me too. It happens after trying to install php module (but unsuccessful, and it is the first time that the above situation happens to me). I thought it is installer problem therefore re-install the installer again. But, the same thing happens to the re-installing process. After, when I tried to launch the installer from springboard again, it crashes.

    After a few days of research, can't find a right solution therefore just do a file to file comparison and found that the AppTapp binary file size is different from the original one. Then, just do a file replacement in binary tranfer format. And, it does fix the crash issue with installer but the installing app problem is still the same.

    Therefore, you may not like to re-install the Installer.app if you have the same situation.

    Hope someone has solutions for this. If I found one, will post it here.

    Good Luck and Cheers!

  3. #3
    What's Jailbreak?
    Join Date
    Aug 2007
    Posts
    15
    Thanks
    2
    Thanked 1 Time in 1 Post
    I have had this issue as well. It is very frustrating, because it will work occasionally (very rarely) but otherwise I guess I'm going to have to install apps manually.

  4. #4
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    8
    Thanks
    0
    Thanked 2 Times in 2 Posts

    installer sources arent refreshing for me... It might just be something with installers sources right now... I cant even get to uninstall or anything it hangs right when I open it.

    *Installer works for me now...
    Last edited by mrdonbonjovi; 12-01-2007 at 01:24 PM.

  5. #5
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    10
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Hello!!

    Is there a way I can uninstall the installer.app from the iphone, cuz it doesnt even refresh sources it just crashes. Thanks!

  6. #6
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Recently, I found that for installer.app crashes during the process of "installing" application, this maybe due to write access problem to the system partition. When I tried to SSH and transfer files to the Applications folder, it fails. And, when it works (mean can SSH and transfer files to Applications folder), at the same time, the installer.app has no problem installing applications.

    Now still finding the solution for it. If anyone knows, your help would be greatly appreciated.

    From other forums, they said restore and jailbreak it again will resolve the issue but would appreciate there is other solution without restoring. As I can foreseen it will happens again even redoing the jailbreaking process.

    Updated (for my iPhone 1.1.2):
    Finally, I know why installer.app crashes during the process of "installing" applications as the "300MB system partition" is full. You can check it out by using SSH command "df -h".
    See this thread: http://modmyi.com/forums/showthread....stem+partition

    Just free up the system partition space (uninstalling unwanted apps, etc) will resolve this problem.

    Hope the above helps!
    Cheers!
    Last edited by icebergneo; 12-02-2007 at 08:04 AM. Reason: Problem Resolved.

  7. #7
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    10
    Thanks
    5
    Thanked 2 Times in 2 Posts

    Unhappy /dev/disk0s1 still full
    Hey all, I'm getting the same issue; Installer.app crashes exclusively. I ran df -h:
    Code:
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/disk0s1          300M  300M     0 100% /
    devfs                  18K   18K     0 100% /dev
    /dev/disk0s2          7.3G  6.3G  1.1G  86% /private/var
    I have plenty of space left on /dev/disk0s2 and I've tried to manually delete some unneeded apps from /private/var/root/Media via Finder, but the size of ../disk0s1 still hasn't changed.

    I can't open Installer.app to uninstall anything.

    Any ideas (other than a restore, which is a pain in the *** on 1.1.2).

  8. #8
    Green Apple
    Join Date
    Nov 2007
    Posts
    85
    Thanks
    1
    Thanked 16 Times in 6 Posts

    Quote Originally Posted by citenx View Post
    Hey all, I'm getting the same issue; Installer.app crashes exclusively. I ran df -h:
    Code:
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/disk0s1          300M  300M     0 100% /
    devfs                  18K   18K     0 100% /dev
    /dev/disk0s2          7.3G  6.3G  1.1G  86% /private/var
    I have plenty of space left on /dev/disk0s2 and I've tried to manually delete some unneeded apps from /private/var/root/Media via Finder, but the size of ../disk0s1 still hasn't changed.

    I can't open Installer.app to uninstall anything.

    Any ideas (other than a restore, which is a pain in the *** on 1.1.2).

    If you look closely...you have the 300MB issue...Go to the thread as mentioned above or google the 300MB partition problem for iphones.
    1.1.2FW w/ 4.02.13_G Baseband. Rock Solid!

  9. #9
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    10
    Thanks
    5
    Thanked 2 Times in 2 Posts

    Quote Originally Posted by Sony311 View Post
    If you look closely...you have the 300MB issue...Go to the thread as mentioned above or google the 300MB partition problem for iphones.
    Thanks for the quick reply.

    I actually hacked away at my installed apps with SSH. I have 8.1mb free (with 11 installed apps) in the sys partition. It looks like something is eating up all of my free space. I've had WAY more installed than I do now and never encountered this issue before.

    At any rate, after freeing that space, Installer still crashes upon start. I think I'm going to restore. There seems to be something awry with my phone.

  10. #10
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    1
    Thanks
    0
    Thanked 1 Time in 1 Post
    i had the same problem, and this is the ultimate solution. i went to ibrikr 0.91 and installed PXL on my phone. Then i installed Installer v2.63 it will replace the already existing installer 3.08b and it will leave everything as it was : the uninstall list, the install packages, and the source list. Then i went to the uninstall list and clicked on the installer 3.08b it won't gave you the option to uninstall insted it give u the option to reinstall, click on reinstall and .... voila the problem is solved for me hope it will be for you.

    -The Devil

  11. The Following User Says Thank You to findthedevil For This Useful Post:

    citenx (12-20-2007)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts