+ Reply
Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 4.1 + MyWi 4.8.3 issue work-around

is a discussion within the

MyWi

forums, a part of the

Rock Your Phone Discussion

section;
I have a 3G that I recently upgraded to 4.1 and jailbroke via limera1n . I then installed Cydia and then MyWi 4.8.3. However, I was having many of the
...
  1. #1
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    4
    Thanks
    0
    Thanked 1 Time in 1 Post
    Default 4.1 + MyWi 4.8.3 issue work-around
    I have a 3G that I recently upgraded to 4.1 and jailbroke via limera1n. I then installed Cydia and then MyWi 4.8.3. However, I was having many of the same issues mentioned in these forums.

    But I seem to have found a possible work-around that works for me. Maybe I just got lucky?

    Here's what I did...

    1) I went into MyWi that was already installed, and first tried shortening my network name to "pjwifi". I also made sure WEP Security was turned off. I went to Advanced WiFi and switched to Channel 4 and DHCP network 172.10.20.0. MyWi USB was turned Off. Display > In Use Indicator was set to "Tethering Bar".

    2) I then made sure I wasn't connected to any existing WiFi networks/hotspots - and I also used "forget this network" for my home network, so I wouldn't automatically connect.

    3) I reboot the phone and did not connect to any wifi networks after starting

    4) I went into Cydia then "removed" MyWi

    5) After removal, when prompted to "restart the springboard" - I didn't click the button. I just shut the phone off.

    6) Then I powered on the phone again, and went into Cydia and selected MyWi - and then installed it again. It did detect that I already paid for it.

    7) I went into MyWi and it did remember my above settings. I then turned on WiFi tethering, and whalla - I was connected to the 3G network and my WiFi was enabled.

    8) I then went to my Windows 7 notebook, and disconnected from my home wifi and connected to pjwifi (MyWi). And I was able to surf, and the status bars on the phone were showing correct bytes. Hurray!

    9) I then went to MyWi and turned WiFi Tethering OFF. It seemed to turn off and cleanup MyWi OK. However I noticed that my notebook was still showing connected to pjwifi, even though MyWi showed that WiFi Tethering was turned off. I even refreshed my local network wifi status and it still showed I was connected to pjwifi. However when I attempted to surf to the web on my notebook, I was obviously not connected and the wifi status on my notebook showed I was not connected to the internet (but I was connected to pjwifi).

    10) I tried disconnecting from pjwifi and reconnecting. I was still able to reconnect, even though MyWi Tethering was shut off on MyWi. But I was not able to connect to the Internet on my notebook.

    11) I then tried rebooting the phone. I fully expected not to be able to get online with MyWi Tethering again. But after rebooting and turning on MyWi WiFi Tethering, I was able to connect to pjwifi and get online again via MyWi! Hurrah!

    12) But the above issues persisted. In order to get online on MyWi via WiFi Tethering again, I have to cold start the phone. But at least I'm able to get online!

    Hope this helps someone else. Let me know what happens!

  2. The Following User Says Thank You to darrennj For This Useful Post:

    Brr (11-04-2010)

  3. #2
    Previously known as psuskeels
    Join Date
    Feb 2008
    Posts
    667
    Thanks
    96
    Thanked 239 Times in 113 Posts

    Thanks - this issue on 3G 4.1 has been fixed in 4.9.x (can install for now via adding source in cydia http://intelliborn.com/beta4).
    Send iPhone System Log: Via any Intelliborn App -> Click Help / FAQs/ Support -> Scroll to bottom and click on red text at bottom.
    MyWi 4.0 - WiFi + USB Tethering on 3.x/4.x/5.x + Simple WiFi Router - Connect Laptops, Touches, + more!
    My3G - Facetime over 3G plus HiDef YouTube and more! Trick your iPhone into thinking it's on WiFi
    IntelliScreenX - iOS 5 Notification Center the way Apple wished it was.
    Tlert - View and Reply to SMS message within any app. Get rid of the ugly default alert messages!

  4. #3
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    4
    Thanks
    0
    Thanked 1 Time in 1 Post
    Default 4.9.6 now crashing
    well, I updated to 4.9.6 and now I can't use mywi at all.

    what happens is - I turn on mywi and I see the main mywi screen display. but then without hitting anything on the screen, a couple seconds later the application crashes and I then see the springboard.

    I have tried uninstalling and reinstalling and rebooting after each step. Still same problem.

    I have tried removing intelliborn.com/beta4 as a source and then reinstalling - I was hoping to somehow install the last public version at 4.8.3 but I can't seem to find a way to install an old or former release. It keeps finding 4.9.6.

    During one of the reinstalls it lost my registration and I was told I could start a trial - but then I was able to retrieve my license. But then mywi continues to crash.

    The above is on a 3G with 4.1 jailbroken with I believe with pwnage tool (it's been awhile I don't remember).

    I also have a 3GS 4.1 jailbroken with limera1n and running mywi 4.9.6 and that one seems to be running OK.

    BTW I also just tried resetting network settings and then rebooting, but same result. Crashes back to springboard.

    anyone know how to get a syslog for the developer? do I need to install a syslog program?

    anyone know how to get a syslog from an iphone? do I need to install a syslog program or is syslog already installed with cydia/etc?
    Last edited by darrennj; 11-06-2010 at 09:51 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts