+ Reply
Results 1 to 18 of 18

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: MyWi Not Initialized error

is a discussion within the

MyWi

forums, a part of the

Rock Your Phone Discussion

section;
Whenever I start MyWi, I get the following dialog box: MyWi Not Initialized MyWi requires a Respring. Would you like to respring your iPhone now? If I select 'Respring' then
...
  1. #1
    What's Jailbreak?
    Join Date
    Sep 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default MyWi Not Initialized error
    Whenever I start MyWi, I get the following dialog box:

    MyWi Not Initialized
    MyWi requires a Respring. Would you like to respring your iPhone now?

    If I select 'Respring' then it resprings, and on reloading MyWi it repeats the same message. If I choose 'Later' then I can turn on WiFi Tethering and it creates the Wifi network, but it doesn't come up with the tethering banner at the top of the screen, and it doesn't seem to create the DHCP server as anything that connects to the network doesn't get an IP address.

    Anyone got any suggestions how I fix this? Or where I can find any logfiles?

    I've tried reinstalling MyWi and doing a full restart of my phone. I'm running 3.1.2.

    Cheers!

  2. #2
    What's Jailbreak?
    Join Date
    Apr 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I'm having exactly the same problem as this, I'm using a spirit jailbroken 3GS running 3.1.3 on the O2 network (UK) anyone have any ideas how to solve this? I've looked for ages on google and come up with nothing!

    Thanks in advance,

  3. #3
    My iPhone is a Part of Me
    Join Date
    Nov 2008
    Posts
    510
    Thanks
    68
    Thanked 63 Times in 50 Posts

    Every time I try to turn on the wifi tethering, it says It needs to reboot to try to fix something. then when I try it again it says it needs a restart. WTFO! $10 for nothing! Ive sent 2 emails to intelliborn with no response...

  4. #4
    What's Jailbreak?
    Join Date
    Jul 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have the same promblem... Someone have a solution?
    Thank you

  5. #5
    Previously known as psuskeels
    Join Date
    Feb 2008
    Posts
    667
    Thanks
    96
    Thanked 239 Times in 113 Posts

    Try reinstalling (in case you have disabled some MobileSubstrate Extensions via SBSettings or otherwise). Also - cracked versions will likely have this problem (sorry).

    If the problem continues, please send a syslog to Intelliborn.
    Send iPhone System Log: Via any Intelliborn App -> Click Help / FAQs/ Support -> Scroll to bottom and click on red text at bottom.
    MyWi 4.0 - WiFi + USB Tethering on 3.x/4.x/5.x + Simple WiFi Router - Connect Laptops, Touches, + more!
    My3G - Facetime over 3G plus HiDef YouTube and more! Trick your iPhone into thinking it's on WiFi
    IntelliScreenX - iOS 5 Notification Center the way Apple wished it was.
    Tlert - View and Reply to SMS message within any app. Get rid of the ugly default alert messages!

  6. #6
    What's Jailbreak?
    Join Date
    Sep 2007
    Posts
    10
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Lightbulb MyWI 4 not initialized fix
    This worked for me:
    1. Go to SBSettings
    2. On MobileSubstrate Addons, turn off MyWi
    3. Exit and reboot
    4. Go to SBSettings,MobileSubstrate, turn on MyWi
    5. Exit, reboot and enjoy.

  7. #7
    What's Jailbreak?
    Join Date
    Jun 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    ^I tried that and it still comes up with "respring" problem. Any more ideas?

  8. #8
    Green Apple
    Join Date
    Dec 2008
    Posts
    72
    Thanks
    4
    Thanked 17 Times in 8 Posts

    Was getting this error and now it's gone. Put your phone in safe mode launch MyWi. It will ask you to respring do so. Now go launch app again it will ask you to reboot. Press reboot and it should not reboot on it's own. Reboot manually either sbsettings or by holding the home and sleep/wake button together at the same time and after that launch app and annoying message should be gone.

  9. The Following 4 Users Say Thank You to ealvinito For This Useful Post:

    djsunny (08-25-2010), John22s (11-21-2010), Macdaddy5539 (10-05-2010), rizzyran (08-26-2010)

  10. #9
    What's Jailbreak?
    Join Date
    Aug 2009
    Posts
    2
    Thanks
    2
    Thanked 0 Times in 0 Posts

    @ealvinito thanks boss, worked great!

  11. #10
    What's Jailbreak?
    Join Date
    Mar 2010
    Posts
    1
    Thanks
    3
    Thanked 0 Times in 0 Posts

    @ealvinito thanks dude...took me several attempts but eventually worked!!!

  12. #11
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Still NOT working!!!
    Ive tried all of the above methods and still cannot get it to work! plz help!

    jailbroken/unlocked on t-mobile
    iphone 3g
    3.0 OS

    HELP!

  13. #12
    Previously known as psuskeels
    Join Date
    Feb 2008
    Posts
    667
    Thanks
    96
    Thanked 239 Times in 113 Posts

    grey03svt: Won't work on 3.0 -- need 3.1 or higher (putting this message in next update of MyWi - sorry we missed putting a message for firmwares < 3.1)
    Send iPhone System Log: Via any Intelliborn App -> Click Help / FAQs/ Support -> Scroll to bottom and click on red text at bottom.
    MyWi 4.0 - WiFi + USB Tethering on 3.x/4.x/5.x + Simple WiFi Router - Connect Laptops, Touches, + more!
    My3G - Facetime over 3G plus HiDef YouTube and more! Trick your iPhone into thinking it's on WiFi
    IntelliScreenX - iOS 5 Notification Center the way Apple wished it was.
    Tlert - View and Reply to SMS message within any app. Get rid of the ugly default alert messages!

  14. #13
    What's Jailbreak?
    Join Date
    Jun 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default thanks
    @ealvinito thanks it worked for me

  15. #14
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    6
    Thanks
    2
    Thanked 3 Times in 3 Posts

    Quote Originally Posted by ealvinito View Post
    Was getting this error and now it's gone. Put your phone in safe mode launch MyWi. It will ask you to respring do so. Now go launch app again it will ask you to reboot. Press reboot and it should not reboot on it's own. Reboot manually either sbsettings or by holding the home and sleep/wake button together at the same time and after that launch app and annoying message should be gone.
    Thanks. That works, but I gotta do that every time I want to use MyWi (I only use it like once a week).

  16. #15
    What's Jailbreak?
    Join Date
    Nov 2009
    Location
    Utah
    Posts
    14
    Thanks
    18
    Thanked 3 Times in 3 Posts

    Ok here is what worked for me today I tried all of this plus others last night.
    1 assuming you already get the 3000+ day test delete rock
    2 install rock
    3 now create a new rock account
    4 respiring
    This is how I got rid of the required reboot now mywi works fine.

  17. #16
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    @ealvinito your method worked perfect. Thanks!

  18. #17
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    i just bought mywi 4.0 for 20$ n it doesnt work! did u make it work plz help

  19. #18
    What's Jailbreak?
    Join Date
    Oct 2009
    Posts
    4
    Thanks
    0
    Thanked 3 Times in 2 Posts

    Got this from HackStor

    "If sometimes later you get the MyWi Not Initialized! message. (as shown above)

    The easiest solution is here (do these steps in quick succession)

    1. open miwi 1st time
    2. when it asked to exit or reboot, click on exit 1st time
    3. open mywi 2nd time
    4. when it asked to exit or reboot, click on exit 2nd time
    5. open mywi 3rd time
    6. when it asked to exit or reboot, click on reboot

    Once you have rebooted, now open mywi, and it should work.

    Everytime you run into this problem, just repeat the steps above and it should work everytime ."

    This Method worked for me!!!

  20. The Following 2 Users Say Thank You to teachertwish For This Useful Post:

    John22s (11-23-2010), parishm (02-15-2011)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts