View Poll Results: Is MyWi the best way to tether?

Voters
11. You may not vote on this poll
  • Yes

    9 81.82%
  • No

    2 18.18%
Multiple Choice Poll.
+ Reply
Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: WEP on MyWi w/iPad

is a discussion within the

MyWi

forums, a part of the

Rock Your Phone Discussion

section;
MyWi connects and works well with iPad, however, when WEP is enabled, MyWi doesn't connect. With WEP enabled and a 40 bit key, MyWi wants to soft restart. Soft restart,
...
  1. #1
    Green Apple mactwisted's Avatar
    Join Date
    Sep 2009
    Location
    Texas
    Posts
    73
    Thanks
    5
    Thanked 2 Times in 2 Posts

    Default WEP on MyWi w/iPad
    MyWi connects and works well with iPad, however, when WEP is enabled, MyWi doesn't connect. With WEP enabled and a 40 bit key, MyWi wants to soft restart. Soft restart, hard reboot makes no change. Has anyone else run into this issue?

    - jail broken 3GS iPhone on os 3.12, modem firmware 05.11.07
    - tethering enabled in settings
    - tethering enabled in MyWi
    - bluetooth enabled in MyWi
    - WEP enabled in MyWi
    - 40 bit key used
    - iPhone soft reboot
    - iPhone hard reboot

    Thanks,

  2. #2
    What's Jailbreak?
    Join Date
    Jul 2009
    Posts
    19
    Thanks
    2
    Thanked 1 Time in 1 Post
    It works for me ... I use a 10 character password consisting of all numerics....

  3. The Following User Says Thank You to lazyjj For This Useful Post:

    mactwisted (04-26-2010)

  4. #3
    iPhone? More like MyPhone
    Join Date
    Mar 2010
    Location
    Trolling a fourm near you
    Posts
    205
    Thanks
    20
    Thanked 12 Times in 12 Posts

    One recomendation, If your not using usb or bluetooth tethering, Turn it off, It makes your phone slower,power dead, and bugg.

  5. The Following User Says Thank You to nickkrd For This Useful Post:

    mactwisted (04-26-2010)

  6. #4
    iPhoneaholic iphone8130hak's Avatar
    Join Date
    Feb 2008
    Location
    Washington DC
    Posts
    362
    Thanks
    6
    Thanked 36 Times in 33 Posts

    Yea it will
    Keithsta

  7. The Following User Says Thank You to iphone8130hak For This Useful Post:

    mactwisted (04-26-2010)

  8. #5
    What's Jailbreak?
    Join Date
    Apr 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Have the same problem
    Hi , i made changes to 10bit all number still the same.. The app doesn't want to give me IP address. I can't buy a problem like that does anyone know anything new.

  9. #6
    What's Jailbreak?
    Join Date
    Apr 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I consistently get MyWi to work the first time, but then I don't get an address on my iPad any subsequent time I try to turn on MyWi. If I reboot the phone or if I do the autofix (and it doesn't lock up) I can restart MyWi and it'll work again until I turn it off and back on. This is with a 3G running 3.1.2.

    I guess I should try with my laptop to see if it is specific to the iPad or not.

    ... time passes ...

    A little experimentation later... I see the same behavior with my laptop, so I'd say this is more something to do with the routing tables on the phone not getting reset quite right than anything on the client machine.

    I did have a little luck if I started MyWi, connected the iPad, stopped MyWi, exited the app, restarted the app, turned MyWi back on, then I could continue to surf on the iPad. All those steps were necessary.

    However, if I simulated being gone longer (i.e. I turned off WiFi on the iPad) then when I tried to get back online after stopping MyWi it didn't work. I just got a self-assigned address. My guess is that the first time, the iPad didn't give up its IP address so it didn't matter if it got anything from DHCP.

    ... further time passes ...

    This definitely seems related to WEP being turned on. If I turn off WEP (and do an appropriate amount of forgetting of networks to make the devices realize it is no longer a WEP protected network) then I can turn MyWi on and off as much as I like and the clients (iPad and MacBook Pro) generally reconnect just fine. If I switch back to WEP then once again, they appear to join the network but can't communicate at all and don't get IP addresses.
    Last edited by jhalex; 04-30-2010 at 07:18 PM. Reason: Further info provided

  10. #7
    Green Apple mactwisted's Avatar
    Join Date
    Sep 2009
    Location
    Texas
    Posts
    73
    Thanks
    5
    Thanked 2 Times in 2 Posts

    i was able to work around this issue in a couple of ways. please follow the steps below.

    - turn internet tethering on in settings > general > network > internet tethering
    - turn wep security off in mywi app
    - turn wifi tethering on
    - after your thethering begins, turn wep security on
    - you will see an apply button in the top right corner of the mywi app
    - click apply
    - mywi is now an internet hotspot with wep security enabled

    - if this process fails, reinstall mywi

  11. #8
    What's Jailbreak?
    Join Date
    Sep 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    The wep key on mywi is hexa while the UI on the iPhone or iPad is expecting ASCII.

    In mywi type your 10 or 26 hex weep key

    On the ipad type the same hex code but type 0x in front of it.

    So if your wep key is 1234567890, enter it as 0x1234567890 on the iPad. Simple as that.

    Worms consistently for me and I never have troubles.

  12. #9
    What's Jailbreak?
    Join Date
    Jan 2008
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Worms
    "Worms consistently for me and I never have troubles."

    Its interesting that the hex code worms for you. It doesn't worm for me. I just have to run mywi without WEP in order to connect, which kind of sucks when Im in the classroom with 100 other students. No big deal though. As long as it worms, Im happy.

  13. #10
    apatia z3r01's Avatar
    Join Date
    Jul 2007
    Location
    Brooklyn
    Posts
    5,697
    Thanks
    82
    Thanked 886 Times in 557 Posts

    mywi is actually the only way to wifi tether...
    [IMG]http://img829.imageshack.us/img829/9703/modu.gif[/IMG]

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts