Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Alerts only stay on global

  1. #1
    Default Alerts only stay on global
    Using latest MyProfiles on Iphone 4 (4.2.1). When I create an alert, it will only allow the alert to be global for all profiles. If i switch it off, there is no save button & if i go out & come back in, it is switched back to on. It does the same thing with the override silent toggle. It only allows it to stay in the on position.

    Any solutions?

    actually it will save none of the toggle changes on any alerts
    Last edited by cue180; 01-16-2011 at 02:39 PM. Reason: Automerged Doublepost

  2. #2
    Default Same problem
    any resolution?

  3. #3
    I had the same problem and emailed them this morning, but after I saw that a lot of people online were complaining about not getting responses from them, I decided to poke around myself.

    Without further ado, here's the fix.

    You need to modify one file in the filesystem. To do that, perform the following steps:

    Step 1: Make sure you do NOT have MyProfiles currently open on your device. If you do, return to the springboard or any other program, otherwise the following steps will just end up getting overwritten when you do exit the app.

    Step 2: scp the file to your computer so you can edit it (WinSCP is a great program for that).

    The file in question is basically just an XML file full of preferences, and can be found at:
    /private/var/mobile/Library/Preference/com.intelliborn.myprofiles.plist

    Step 3: Open the file in your text editor.

    Step 4: Locate the section that corresponds to your alert. You can do this by doing a text search for the name of your alert. For example, if it's called "My Special Alert", just search for that string and you should be taken inside of a <dict></dict> recordset which is inside of an <array></array> recordset, which is underneath the <key>allAlerts</key> section.

    Step 5: Now that you are within the XML-formatted settings for your specific alert, just look for the section that says:

    <key>global</key>
    <integer>1</integer>

    ...and change the 1 to a 0, which will "deglobalize" that alert, i.e., remove it from all your profiles.

    Step 6 (optional): If you also want to change the "Override Silent" setting for that alert, just look for the section that says:

    <key>ignoreRingerState</key>
    <integer>1</integer>

    ...and change the 1 to a 0.

    Step 7: Repeat this for any alerts you want to modify. Then, save the file and transfer it back to your device, overwriting the existing file there.

    Step 8: That's it! Now you can open the MyProfiles app again and you'll see that the alerts you changed are no longer global. You can then go into each profile and add them manually to those profiles for which you'd like them to be active.

    Enjoy!
    Last edited by pmarking; 02-23-2011 at 10:04 PM.

  4. #4
    wow will have to try it out! have you figured out a workaround for the ringtones not changing with the different profiles?

  5. #5
    OUTSTANDING!!! I JUST moved from ATT to VZ (iphone 3 to 4) and this was broken. This SAVED me!!! Also, if you notice you can't disable sound, so you must edit it as well in the custom alert!

    NICE - HUGE THANKS!
    Dave

  6. #6
    First post on this site and wanted to say Thank you for posting this, i've only had my Iphone 4 for a week now, but this was a problem I was having and now I've found a way to correct it!

    I do have another question, is there anyway to add a Vibrate Option under the SMS/E-mail System Sounds? I have a profile for work and I need everything on vibrate.

    Thanks!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •