I have a new iPhone 3GS running iOS 4.2.1, Model MC640LL and when I tried to sync it through iTunes the computer said the phone needed iTunes version 10.1 or higher. I am running Mac OS 10.4.11 which doesn't meet the system requirements for the iTunes 10.2.1 version on the Apple site. I couldn't find a safe 10.1 iTunes version download on the web.

So without having to shell out the cash for OS 10.5 and wiping and reloading my computer, is there a way to get the iPhone to talk to the computer using iTunes 9.2.1 (5) ??????

Any help would be much appreciated.

-Bobdigi