Page 1 of 2 12 LastLast
Results 1 to 20 of 30

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: How To Change Carrier Logo on Verizon iPhone

  1. #1
    Arrow How To Change Carrier Logo on Verizon iPhone


    I recommend making a backup of your Zeppelin_US.bundle folder before attempting this, just incase!!

    1. Edit your carrier.plist using iFile.
    Directory (/private/var/mobile/Library/Carrier Bundles/iPhone/Zeppelin_US.bundle)
    (Editing it on your computer does not work, at least it didn't for me.)

    Look for this section of the code
    Code:
    <key>StaticNATType</key>
    	<integer>448</integer>
    Add this starting on the next line:

    Code:
    <key>StatusBarImages</key>
    	<array>
    		<dict>
    			<key>AllowPrefixMatching</key>
    			<false/>
    			<key>CarrierName</key>
    			<string>Verizon</string>
    			<key>DefaultImage</key>
    			<string>Default_CARRIER_Zeppelin_US.png</string>
    			<key>FullScreenOpaqueImage</key>
    			<string>FSO_CARRIER_Zeppelin_US.png</string>
    			<key>StatusBarCarrierName</key>
    			<string>Verizon</string>
    		</dict>
    	</array>
    So it should look something like this:


    2. Select your carrier logo files and name them, [email protected] & [email protected]
    (I have included mine for the sake of getting you started.)



    3. Upload your carrier logos to directory "/private/var/mobile/Library/Carrier Bundles/iPhone/Zeppelin_US.bundle"

    4. Respring and you should be set.

    Warning: If you go into your iPhone Settings>General>About you will get this message... Or when you sync your phone on iTunes



    If you select "Update" it will change your carrier.plist back to default and you will have to start over.

    Please reply if this does or doesn't work for you, it took me several hours of toying around to get it to work so I'm hoping I didn't forget any steps.
    Last edited by HellKatzX; 04-03-2011 at 02:46 PM.

  2. The Following 3 Users Say Thank You to HellKatzX For This Useful Post:

    Abneriel (04-03-2011), exNavy (04-03-2011), shotcolin (04-30-2011)

  3. #2
    Awesome job figuring this out! Works like a charm.

    I didn't receive this carrier update warning message, after respringing or syncing. Perhaps your carrier bundle was out of date before performing this mod? I was already running version 10.1.

    Also, I downloaded the carrier.plist to my computer and used bbedit to edit it and it worked just fine.
    Last edited by exNavy; 04-03-2011 at 03:59 PM.
    Hmm...

  4. #3
    Worked great, thanks!

  5. #4
    Quote Originally Posted by exNavy View Post
    Awesome job figuring this out! Works like a charm.

    I didn't receive this carrier update warning message, after respringing or syncing. Perhaps your carrier bundle was out of date before performing this mod? I was already running version 10.1.

    Also, I downloaded the carrier.plist to my computer and used bbedit to edit it and it worked just fine.
    Interesting, I was updated to 10.1 before I attempted this and I still get that message even after I regrettably selected to apply the update once already.

    Good to know you can edit it on your PC, thanks for your feedback!

  6. #5
    Any cool one's for Vodafone?

    And is there a way to change the text?
    Like a simple way in the code to change the letters?
    Last edited by Nickjudd; 04-04-2011 at 03:59 PM.

  7. #6
    Okay, new problem, my logo disappeared and now I have no 3G access! So I'm searching for a solution, consider yourself warned.

  8. #7
    Quote Originally Posted by Nickjudd View Post
    Any cool one's for Vodafone?

    And is there a way to change the text?
    Like a simple way in the code to change the letters?
    Fake Carrier or Fake Operator.

    Quote Originally Posted by HellKatzX View Post
    Okay, new problem, my logo disappeared and now I have no 3G access! So I'm searching for a solution, consider yourself warned.
    I don't have either of these issues and I'm still running the mod and use my 3G every day.
    Last edited by exNavy; 04-05-2011 at 11:16 PM. Reason: Automerged Doublepost
    Hmm...

  9. The Following User Says Thank You to exNavy For This Useful Post:

    Nickjudd (04-06-2011)

  10. #8
    Livin the iPhone Life eddietah's Avatar
    Join Date
    Apr 2010
    Location
    ````
    Posts
    1,298
    Thanks
    615
    Thanked 319 Times in 222 Posts

    Thanks for sharing

  11. #9
    Quote Originally Posted by HellKatzX View Post
    Okay, new problem, my logo disappeared and now I have no 3G access! So I'm searching for a solution, consider yourself warned.
    this happened to me the first time. just put the backup plist in and reboot.
    i got it to work by making a copy of the the two .png files. the file names should be
    Default_CARRIER_Verizon.png
    [email protected]
    FSO_CARRIER_Verizon.png
    [email protected]

    as for editing the plist i just did it on ifile and the directory mine was in was system/library/carrier bundles/iphone/Zepplin_US.bundle

    the code that you need can be easily copied from the att carrier bundle plist and then pasted into where you need it. it starts at <key>StatusBarImage</key> and ends with the first </dict> then you need to add the closing </array> in the line beneath </dict>. its the same code that the OP posted but is just easier to copy this way. then edit the file names to match your own file names (mine are listed above) and change the "at&amp;t" strings to say verizon.
    respring and you should be good to go. make sure you make a backup of the plist though just in case.

  12. #10
    How's it going guys? Hopefully, it's going better for you than for me..

    For whatever reason, this mod works on my iPhone for - in reality - as long as I don't do ANYTHING ELSE regarding customization. I downloaded a new lockscreen and instantly lost my carrier logo (and, by the way, it doesn't get replaced by 'Verizon'; the space closes up, causing the WiFi and cellular signal indicators to be right next to each other). I've tried everything I can think of, but the truth is that I'm not the most familiar when it comes to the iPhone's internal files. There is definitely something going awry, though - my phone is still able to utilize 3G data, as well as receive and make calls, but when I look within the 'About' subsection in the 'General' section of the settings, my phone states that the network's name is "Not Available."

    If anyone has ANY idea of how I can fix this (whether it's simply zipping up the Zeppelin_US bundle, or it's some absurdly long and drawn out method of stopping global warming so to finally let my newly downloaded Autobot carrier logo live peacefully), PPPLLLEEAAASSSSSEEEE let me know.

  13. #11
    Quote Originally Posted by JeffzMrs View Post
    removed, spam
    wtf m8
    Last edited by Simon; 04-08-2011 at 11:45 AM.

  14. #12
    Just updating that I have had it on now for five days with no issues. I wonder if it is simply a conflict with another modification that I do not have installed?

  15. #13
    Quote Originally Posted by Abneriel View Post
    Just updating that I have had it on now for five days with no issues. I wonder if it is simply a conflict with another modification that I do not have installed?
    Yes that is strange that some of us are having the disappearing logo issue and some are not.

  16. #14
    mine disappeared after i installed alertartist leaving me with no 3g. i just restored the backup plist and everything works now

  17. #15
    Disappears after rebooting. Plist returns to default state.

  18. #16
    My logo disappeared after a few days, I had to restore using iTunes. Not sure why either. Need the help of someone who knows more than me

  19. #17
    Restore..? Yuk!! Just remember if you modify ANYTHING, always make a copy of the original file/folder so you can avoid restoring. Mine did the same thing, but I made a copy of everything first. Then when it disappeared I just copied the originals back. Viola!

    Still not sure why it's reverting back yet.

  20. #18
    has anybody tried editing the original carrier.plist found here:

    /System/Library/Carrier Bundles/iPhone/Zeppelin_US.bundle

    and putting the images in there as well, that is the master directory the other is the symbolic link file, it might prove to be more stable (less likely to disappear)

  21. #19
    I tried this again and it's been working great for about the past 7 days. Now I just rebooted my phone because my app store update wasn't working and now the carrier logo is completely gone again. I did make a backup of Zeppelin_US.bundle however I restored the backup and restarted the phone and I still have no carrier logo, so it looks like I'm going to have to restore again...

  22. #20
    King Kong ain't got nothing on me! King_O_Hill's Avatar
    Join Date
    Apr 2011
    Location
    USA
    Posts
    9,507
    Thanks
    42,116
    Thanked 17,951 Times in 6,529 Posts

    you can go to iTunes and just let it do a "Carrier Settings Update' only. This will restore the Zeppelin_US.bundle to orig status. then you can start over. A lot better than doing a restore.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •