Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Verizon iPhone 5.0.1/5.1 signal issues after jailbreaking

  1. #1
    Default Verizon iPhone 5.0.1/5.1 signal issues after jailbreaking
    Hello everyone, first time poster here.

    I live a little less than an hour from Richmond, VA, in a pretty rural area (hint: it was where last August's east coast earthquake originated). However, Verizon service is pretty good here and I usually have 3-4 bars of signal. I've had an iPhone 4 since March 2011 and enjoy it. I jailbroke it the night I bought it (which came with iOS 4.2.6) and didn't have any issues. Later in the year, around the time iOS 4.2.8/4.2.10 was released, I noticed my signal was starting to constantly fluctuate and lose its 3G connection, switching to o/1x. This would happen when I was wasn't doing anything on the phone, just looking at it, and would be worse when I actually used it. I eventually took it to the Apple Store, explained the issue, and they replaced it (I restored the phone before taking it there). I didn't notice the issue again, jailbroken or stock.

    Fast forward to a little over a month ago, and I'm running iOS 5.0.1. I began to notice the issue again while running the tethered jailbreak. I decided that since I don't talk on the phone much and use Wifi often that I would wait until the untethered jailbreak was released to see if that helped anything. It didn't. I then waited for iOS 5.1 was released to see if that would help, not minding the tethered jailbreak, but it didn't help. Then I noticed a couple times that my phone would randomly pop up with a voicemail, but it didn't ring before that. It's like it didn't detect the incoming calls at all, but received the voicemail. I asked the people who called me if the phone was ringing from their end, and they said yes, then eventually went to voicemail. I thought this was unacceptable as I had 4 bars, so I went back to the Apple Store and they replaced the phone again. I had good service on the way home, then promptly jailbroke again. This is before I began to think the jailbreak was causing the issue. Right after I jailbroke, the issue returned. That's when it finally hit me, it was obvious. So I started experimenting. I did a clean restore again, restoring from backup, and everything was fine, no loss of 3G and switching to 1X, data speeds nice and fast. Then I jailbroke, and the signal issue returned, constantly switching to 1X, and when it did have 3G, it was slow as molasses. I restored again, setting the phone up as new this time, and it was fine. Then I jailbroke again without installing any apps or tweaks, and the issue was back. I repeated this process at least 5 times, and it was the same response each time. So I did some Googling and eventually found out how to put the phone in Field Test mode. I did that while running bone stock iOS 5.1, checked the EVDO section, and noticed that the phone's band class was always locked on the 800MHz band, with Rx AGC0 signal in the -80s dBm. Then I jailbroke, checked again, and while constantly switching between 3G and 1X, the phone's band class was locked to the 1.9GHz PCS band (which I know Sprint uses mainly and Verizon barely uses) and never switched back to the 800MHz band, with the AGC0 signal in the -100s. I restored the phone again, checked, and all was normal again. Jailbroke, problem returned. I turned off voice and data roaming in the Settings app, rebooted, but it made no difference. I've tried jailbreaking with both Redsn0w and Sn0wbreeze.

    I'm more convinced than ever before that jailbreaking the phone somehow reduces the phone's signal. I'm sure most people haven't noticed as they live in good coverage areas, but since I live in pretty average coverage, it's a big drop for me. I called Verizon and they supposedly put in a ticket to have the network in my area checked out, but I haven't heard back from them yet, and I doubt i will.

    I'm sorry for the long-winded post, I just wanted to be as detailed and clear as possible. My questions are: has anyone else noticed this, Verizon or otherwise? And if this isn't the best website to post this issue on, can someone point me to the right site where jailbreak developers can read this and possibly look into it? I'd appreciate any input.

  2. #2
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Omicron Persei Eight
    Thanked 699 Times in 594 Posts

    Huh. After your diagnosis, I'm very tempted to agree with your assessment that the network and your phone's physical connectivity are fine. Rather, the jailbreak seems to be affected and/or blocking 800 MHz CDMA connections. Incredibly strange.

    I'd go onto IRC: #iphone and see if anyone in there has any ideas (I'd recommend doing so at around 1600 GMT tomorrow, when the room is likely more active). Also, if you're a Twitter-oriented person: mention @Musclenerd and @iH8sn0w with this tidbit.

    Good luck!

  3. #3
    Default Technology can really stump you!
    Okay, now my OP might be irrelevant. I ran my phone stock all day yesterday, and everything was fine in the morning during my commute to Richmond and during the day, but about 30 minutes ago the issue returned. So now I guess it's really either the network or some bug in iOS. I just don't know. Thanks for the tips, though!
    Last edited by lquarles; 2012-04-12 at 10:31 AM.

  4. #4
    I think the problem is solved and the issue was indeed the network. Everything was fine Friday, so I jailbroke and it was still fine. I then called Verizon back to check on the ticket status, and they said they did find issues with the towers in my area that they fixed. Things seem smooth now!

  5. #5
    you could always reset your network connection if the problem continues.

    Dial: *228, Option #2, wait for signal "reboot", and then reboot your phone.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts