After reading on another forum that this was compatible with 4.2.1 In installed and got stuck in safe mode crashes.

Guess it's not compatible yet. Just wanted 3 bucks.

Jim