+ Reply
Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Ipod Touch 3G 4.2.1 will not update to IOS 5 or any other firmware

is a discussion within the

iPod Touch Jailbreak / Upgrade / Downgrade / Restore

forums, a part of the

iPod Touch

section;
Ipod Touch 3G 4.2.1 will not update to IOS 5 or any other firmware. Itunes says 4.2.1 is the highest current software version. I downloaded IOS 5 and tried updating
...
  1. #1
    What's Jailbreak?
    Join Date
    Jun 2011
    Location
    Ontario, Canada
    Posts
    9
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Default Ipod Touch 3G 4.2.1 will not update to IOS 5 or any other firmware
    Ipod Touch 3G 4.2.1 will not update to IOS 5 or any other firmware. Itunes says 4.2.1 is the highest current software version. I downloaded IOS 5 and tried updating it manually but it still said the was an error and stuff. I tried restoring my ipod and it still didn't work. Also it was jailbroken before. Please help!

    Thanks .
    Ben

  2. #2
    chi-town fanatic! Paco's Avatar
    Join Date
    Feb 2011
    Location
    Chicago Illinois
    Posts
    1,423
    Thanks
    2
    Thanked 19 Times in 17 Posts

    Wut did the error say?

  3. #3
    What's Jailbreak? Chekz0414's Avatar
    Join Date
    Oct 2011
    Posts
    8
    Thanks
    0
    Thanked 1 Time in 1 Post
    Are you even sure it's a 3G touch if it's 8GB that's a 2G and 4.2.1 is the current version

  4. The Following User Says Thank You to Chekz0414 For This Useful Post:

    imungo (11-19-2011)

  5. #4
    What's Jailbreak?
    Join Date
    Apr 2011
    Posts
    23
    Thanks
    1
    Thanked 1 Time in 1 Post
    2g/3g 8gb: 4.2.1 [8, 16, 32]
    3g: 5.0+ [32, 64]
    4g: 5.0+ [8, 32, 64]

  6. The Following User Says Thank You to joshua144 For This Useful Post:

    imungo (11-19-2011)

  7. #5
    What's Jailbreak?
    Join Date
    Jun 2011
    Location
    Ontario, Canada
    Posts
    9
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Okay so what you guys are saying is that a 8gb 3rd gen ipod is truly a 2 gen and cannot be updated past 4.2.1.

    thanks for the help then, looks like I'll be upgrading!
    Ben

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts