Hi! Can anyone help me? I would like to downgrade my ipod touch 1Generation, from 3.1.3 to 1.1.5. Last year I jailbreacked it from 1.1.5 to 3.1.3 and it runs really slow and the battery runs out quickly. The problem is that I have itunes version 10.5 and I tried installing itunes 9 but the computer wont let me run it because it says that is and old version. Can anyone help me? Is there anyway to downgrade it? I hace a mac os X 10.5.8. Thank you, and sorry for my bad english.