+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Ipod touch 2nd gen wont update past 2.2.1

is a discussion within the

iPod Touch Jailbreak / Upgrade / Downgrade / Restore

forums, a part of the

iPod Touch

section;
Hi, i am having a very strange problem with an ipod touch 2nd gen 32gb it currently has 2.2.1 on it because it wont update/restore past this even though itune
...
  1. #1
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Ipod touch 2nd gen wont update past 2.2.1
    Hi, i am having a very strange problem with an ipod touch 2nd gen 32gb it currently has 2.2.1 on it because it wont update/restore past this even though itune says 4.2.1 is avaiable i have tried in dfu and recovery mode and recieve errors 14 and 1604 i have even tried ios 3 but no joy, tiny umbrella shows model number : mb533bt/a - invalid all firmware updates seem to fail and then i have to restore 2.2.1 before i can use it again, anyone have any ideas?
    many thanks

    tom

  2. #2
    iPhone? More like MyPhone
    Join Date
    Sep 2011
    Location
    Australia
    Posts
    195
    Thanks
    3
    Thanked 4 Times in 4 Posts

    Update iTunes?

  3. #3
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Yes with ITunes, I have the same problem, When the update file is downloaded and try to process the file there is an error window saying that the time waiting for the connection was exceeded..

  4. #4
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have the newest version of itunes, have tried multiple cables, and laptops/pc's running windows xp vista and 7

  5. #5
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Open TinyUmbrella, go to Advanced Options, uncheck the box to "point to cydia on exit" then close TU. Open iTunes (don't have it opened while you do the TU step) and hit upgrade.

  6. #6
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have tried to upgrade it on a laptop that never had itunes on it before and has never had tiny umbrella on it either and i still got the error

  7. #7
    iPhone? More like MyPhone
    Join Date
    Sep 2011
    Location
    Australia
    Posts
    195
    Thanks
    3
    Thanked 4 Times in 4 Posts

    put your iPod in DFU mode instead of Recovery mode...

  8. #8
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Are you using a custom firmware. Or just hitting upgrade in iTunes.

  9. #9
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have tried recovery mode and dfu mode, i am just hitting upgrade, i cant remember wether i have tried cooking a custom 4.2.1 i have tried that many different firmwares iv lost track

  10. #10
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    You should just hit upgrade and not use a custom fw to see what it does

  11. #11
    iPhone? More like MyPhone
    Join Date
    Sep 2011
    Location
    Australia
    Posts
    195
    Thanks
    3
    Thanked 4 Times in 4 Posts

    4.2.1? o.0 you should be ugprading to 4.3.5. Apple's stopped signing 4.2.1-4.3.3 agess ago.

  12. #12
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    2G iPT only goes up to 4.2.1. Apple stills signs 4.2.1 for iPT 2G and iPhone 3G.

  13. #13
    iPhone? More like MyPhone Jabbacks's Avatar
    Join Date
    Apr 2011
    Location
    Tutu Island
    Posts
    200
    Thanks
    27
    Thanked 2 Times in 2 Posts

    Just uploaded 4.2.1 to ipod touch 2g using ipsw from funkyspacemonkey with iTunes "Restore". Put phone in DFU mode, open TinyUmbrella and checked "point to cydia on exit". Open iTunes, shift-restore and select ipsw 4.2.1. All went well. Then jb with redsn0w_win_0.9.6rc8.

    It's ok now. Thing is I cannot install themes. Tried winterboard but it just exits after select!

  14. #14
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Restore and redo the jb.

  15. #15
    iPhone? More like MyPhone Jabbacks's Avatar
    Join Date
    Apr 2011
    Location
    Tutu Island
    Posts
    200
    Thanks
    27
    Thanked 2 Times in 2 Posts

    Quote Originally Posted by i.Annie View Post
    Restore and redo the jb.
    Sorry, you talkin to meh?

  16. #16
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Yup. If you're WB is crashing

  17. #17
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Jabbacks did u already have shsh saved from 4.2.1 before?

    I get error 1604 or error 14 after it has hung on preparing ipod for restore have tried in recovery mode dfu mode and normal mode while it is running on 2.2.1 still get the same errors
    Last edited by Parksy87; 10-08-2011 at 08:30 AM.

  18. #18
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    You don't need SHSHs for 4.2.1 on an iPT 2G, that's the highest fw version for that device so Apple still signs it.

    The issue isn't within whether you're using SHSHs or not.

    Edit: I asked you if you're using a custom fw bc error 14 is a cFW issue where you're not setting your device into pwned dfu. The same goes with error 1600's.

    So consider just upgrading to stock 4.2.1 or at least putting your device into pwned dfu mode before restoring to cFW.

    Also, do the TU steps I told you to before doing this. If it is pointing at Cydia's server and you're trying to get to 4.2.1 which is a currently signed fw for that device, it'll likely error out.
    Last edited by i.Annie; 10-08-2011 at 08:58 AM.

  19. #19
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I am trying to upgrade to stock 4.2.1 i have tried dfu and recovery mode and also while it was running 2.2.1 i have not got the host file edited in any way or tinyumbrella running and i ge error 14 and 1604

  20. #20
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    TinyUmbrella doesn't have to be open or running to point the restore to Cydia's servers. Ensure under Advanced Options that the box to point to Cydia on exit is not checked.

    According iPhone error wiki:

    Error 14
    Custom firmware update fail (PwnageTool until 4.0.1). You have to restore the device with a custom firmware. Update to a custom firmware isn't working. Device isn't bootable. 2
    USB Problem. Check the USB connection and try other direct ports or maybe the USB cable is an older one. Device isn't bootable.
    You're trying to 'update' to a beta firmware instead of performing a restore. Device is still bootable if you kick it out of recovery mode.
    Rebooting your Mac or PC may resolve this issue.


    Error 1604
    Device was not pwned (signature checks were not blocked). Custom firmware can't be restored. Can also happen when there's a problem with the IPSW.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts