helo.
i want to jb my itouch 3.1.2 with jailbreakme.
but when i go there, it give me warning : this version is known to crash. you can try it, but you might have better luck if you upgrade to 4.0 first.
what should i do? i dont want to upgrade my itouch.
thanks