Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Upgrade path from JB 2G 2.2.1

  1. #1
    Default Upgrade path from JB 2G 2.2.1
    I had a jailbroken iPod touch 2G with 2.2.1. I have not upgrade to 3.0 or 3.1.1 (current). I have read the sticky but still confused.

    (1) I believe that I still needs iTunes 8.2 instead of iTunes 9
    (2) I don't think there is anyway for me to upgrade to 3.0 because now on iTunes is 3.1.1
    (3) I have download both 3.0 and 3.1.1 ipsw and put them in User/Library/iTunes/iPod Software Updates
    (4) Can I do a <option> restore to 3.0?
    (5) What happen if I have to update to 3.1.1 as this is the default option right now when I open iTunes?
    (6) Will iTunes ask me for the $5 (?) upgrade charge? I am still on 2.2.1 so I do not know about this upgrade fee, just reading from forums.
    (7) Am I supposed to update to 3.1.1, pay the upgrade fees, then downgrade to 3.0 and then jailbreak?

    I know this all sounds confusing, that's why I try to clear this before doing such an upgrade. Thanks in advance for clearing up this confusion.

  2. #2
    i had the same situation except im using itunes 9. i just downloaded 3.0 and option upgraded to the 3.0 firmware then i put my ipod in recovery mode and recovered to the pwned 3.1.1 firmware but i keep getting an error 1604 so im stuck in recovery mode for now. i guess you can try what i did but you might get the same error, and if you dont then it must be because im using itunes 9. sorry if this doesnt really help, im having problems myself with the 1604 error, i just thought you should know everything i do since were in the same situation :3

  3. #3
    Chaos as far as I know, in order to use the Pwnage Tool 3.1.3, your iPod 2G has to be already Pwned at 3.0 or 3.1. You and mine is only at JB 2.2.1, so I don't think that will work.

    I don't know if we have to upgrade to 3.1.1 (actual version), then do the downgrade to 3.0 and use redsn0w to Pwn 3.0. However in the blog it never said anything about version 3.1.1, only if you are at 3.1.

    This is confusing...

  4. #4
    yeah i upgraded to 3.0 and i couldnt pwn it to 3.1.1 or the redsnow 3.0 pwn so i upgraded it to the normal 3.1.1 and i still couldnt pwn it without getting an error so i guess we both have the same problem now =/ i tried looking all over the internet on how to fix this and ive tried so many things, but it just doesnt work for me either. =/

  5. #5
    Hi Chaos, I actually is on JB 3.1.1 now.
    I did not go to 3.1.1 right away, as my iPod is in JB 2.2.1.
    I just DFU my iPod and <option> restore to 3.0. So it is in pure 3.0 factory mode.
    Then I used redsn0w 0.8 to JB 3.0. This is where you are now "in the path".
    After that I used Pwnage 3.1.3 in expert mode to create a 3.1.1 custom ipsw.
    Then I just put the 2G in recovery mode and <option> restore the custom ipsw. All works fine.

  6. The Following User Says Thank You to birdieman For This Useful Post:

    ChaosPaladin (10-09-2009)

  7. #6
    thank you SO much this method finaly worked when you explained it birdie BUTTT just my luck that literally the SECOND i get 3.1.1 pwned after about 3 weeks of tampering with my ipod they release 3.1.2

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •