+ Reply
Results 1 to 1 of 1

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone network problems

is a discussion within the

iPod Service, Warranties, and Repairs

forums, a part of the

General iPod

section;
A few days ago I dropped my iPhone 2G and the lcd screen broke. Since my warranty was voided and the Apple Store would charge a lot for a repair,
...
  1. #1
    What's Jailbreak?
    Join Date
    Mar 2010
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default iPhone network problems
    A few days ago I dropped my iPhone 2G and the lcd screen broke. Since my warranty was voided and the Apple Store would charge a lot for a repair, I gave my iPhone to a small shop which replaced the screen at a cheaper price. I got it back the next day and the screen was fixed, but I couldn't get any reception. A majority of the time it plainly said 'No service'. I sent it back to the store, explained the problem and they said they would fix it.

    Now my iPhone at the time was jailbroken on 3.1.2 and unlocked, because the iPhone was from the US and I live in the United Arab Emirates. When I got it back a few days later, the store had upgraded it to 3.1.3 and had erased everything. Luckily though, the network problem was fixed and I could call and receive calls normally. The person at the store said he had upgraded the software because the reception problem was caused due to a software error. I didn't enquire further as it was fixed and I didn't see the need, and since I had all my normal apps synced with iTunes and my jailbroken apps saved with Rock I figured restoring it to its original state wouldn't be much of a hassle.

    However I found out that there was no viable method of jailbreaking the 3.1.3 firmware, so I downloaded a 3.1.2 ipsw file and restore my iPhone through iTunes using it. I was successful and my iPhone reverted back to 3.1.2 and I could jailbreak it normally, but the network problem returned and I couldn't get any reception.

    I have tried un-jailbreaking it, upgrading it again to 3.1.3, flashing it several times with Bootneuter, resetting the network setting... but none of them seem to work. Every other aspect of the iPhone works fine and the only problem is that I have 'No service' a lot of the time and very feeble signal the other.

    A little more information: as mentioned before I live in the UAE and my carrier is etisalat. My iPhone was a pre-unlocked version bought from the United States. If you require any more details, please let me know.

    Now, as the store told me it was just a 'software error', I figure I can fix it using my own resources without taking it back to the store where they would charge me extra. Would someone please tell me what's wrong and/or how to fix it?

    EDIT: I'm not entirely sure if this is the right section for this type of thread, so if someone could please move it to the right place it would be appreciated.

    EDIT 2: A message stating 'Waiting for activation. This may take some time.' also pops up from time to time.

    Please help!
    Last edited by Ascaris; 03-19-2010 at 11:40 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts