Results 1 to 1 of 1

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help my 3G become once again what it used to be.

  1. #1
    Here are the specs of my iphone.
    Model No - A1241 (makes it a 3G)
    Version 4.2.1 (8C148)
    Model MB489B ( i read this is an 'old boot rom' ... i have no idea what that means)
    Firmware - 05.15.04

    It is essential for me to use apps such as 'line' and 'imi ha' ... amongst others.
    Today I was using my iphone on the train and the battery ran out. I recharge/restart when i get home. All of a sudden, downloaded apps stop working.
    I decide to delete them and reinstall , which i have done before. ( i dont have back ups as time machine is not set up. )
    But now I cant download them as it says i gotta have ios 4.03 or something.
    My iphone is currently not jailbroken.

    But I want it to be, I want to do what it takes to be able to use the apps I used to. Theres no way i should be a new iphone just because apple stop upgrades for the one i have.

    So, can some one tell me how i would jailbreak this 3G with the above model and firmware , so that i am able to get to 4.03 or above.
    I had looked into it a couple of years ago, but read that my model was specifically difficult to deal with.
    Thanks.

    Sorry i meant 4.30
    Last edited by bigadz_s; 10-15-2012 at 12:22 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •