When is there going to be a source that makes the apple peel compatible with 4.2.1 software, I added the source on cydia that you need and so far it only goes up to 4.1, if it doesn't I can downgrade but anybody got any info.