+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 32

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Apple Seeds iOS 5.1 and Xcode 4.3 to Developers

is a discussion within the

iPhone News

forums, a part of the

General iPhone

section;
iOS 5.1 has officially been seeded to developers by Apple. It wasn't too long ago that we saw the update for iOS 5 dubbed iOS 5.0.1 (Build 9B5117b) which was
...
  1. #1
    MMi Staff Writer Anthony Bouchard's Avatar
    Join Date
    Sep 2011
    Location
    Florida
    Posts
    6,613
    Thanks
    194
    Thanked 958 Times in 701 Posts

    Default Apple Seeds iOS 5.1 and Xcode 4.3 to Developers

    iOS 5.1 has officially been seeded to developers by Apple.

    It wasn't too long ago that we saw the update for iOS 5 dubbed iOS 5.0.1 (Build 9B5117b) which was supposed to fix battery issues. For some, it worked. For many more, it did not. Apple promised to be working on another version which would fix the rest of the issues for the rest of the iOS 5 users. iOS 5.1 is thought to be that final update. Apple also said that they would be adding more Siri features to the iPhone 4S for example, shutting it off and taking photos. Could this be the update that some iPhone 4S users have been waiting for?

    iOS 5.1 is fresh off of the press, and there is very little information out about it right now. We will keep you posted to let you know what is new in it. All that we know right now is that it's an update for the iPhone, the iPod touch, and the iPad.

    Apple also seeded Xcode 4.3 which makes development for iOS 5.1 possible. Xcode is a Mac-only development application that is used in developing things and making applications for iOS, Mac OS, and Safari.

    Since iOS 5.0.1 plugged many possible exploits for an untethered jailbreak for iOS 5, it's no different looking at iOS 5.1. If you want an untethered jailbreak for your iDevice, then stay away from iOS 5.1. There isn't an untethered jailbreak for any devices running iOS 5 yet (except for the old bootrom iPhone 3GS), but when an untethered jailbreak is produced, it will only run on iOS 5.0. So stay away if you want it. If you do not plan to jailbreak your iDevice, then update to iOS 5.1 to your heart's content over either iTunes or OTA update when it comes out. If you're a developer, then head over the developer page on Apple's website and start downloading it.

    If you are already happily jailbroken on iOS 5.0 and are worried that the annoying update badge from the new OTA feature will appear, you can download the free tweak called noOTA Badge by Moeseth. It's a free tweak that will remove the badge from your Settings application when it starts to be released OTA after it is publicly released.

    EDIT: iOS 5.1 has been found to support an iPad on the Sprint network. This could mean that a Sprint iPad is on its way. Additionally, iOS 5.1 will expire January 14, 2012 as tweeted by iH8sn0w.

    Sources: 9to5Mac
    Last edited by Anthony Bouchard; 11-28-2011 at 11:12 PM.

  2. #2
    What's Jailbreak?
    Join Date
    Nov 2011
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts

    dang it! i just jailbreaked my iPhone 4.

  3. #3
    What's Jailbreak?
    Join Date
    Oct 2011
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    So if i have an old Iphone 3gs with the old bootroom exploit will i have an untethered jailbreak when the ios 5.1 is released

  4. #4
    MMi Staff Writer Anthony Bouchard's Avatar
    Join Date
    Sep 2011
    Location
    Florida
    Posts
    6,613
    Thanks
    194
    Thanked 958 Times in 701 Posts

    Quote Originally Posted by Beastista View Post
    So if i have an old Iphone 3gs with the old bootroom exploit will i have an untethered jailbreak when the ios 5.1 is released
    iOS 5, no matter the firmware, from my understanding will always be untethered on the old bootrom iPhone 3GS because the bootrom exploit is a hardware exploit that cannot be patched by Apple with software.

    I could be wrong, but that's my understanding. So I am going to have to answer your question with, "Yes."

  5. #5
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,670
    Thanks
    40
    Thanked 569 Times in 520 Posts

    Quote Originally Posted by Anthony Bouchard View Post
    iOS 5, no matter the firmware, from my understanding will always be untethered on the old bootrom iPhone 3GS because the bootrom exploit is a hardware exploit that cannot be patched by Apple with software.

    I could be wrong, but that's my understanding. So I am going to have to answer your question with, "Yes."
    The answer is a resounding "yes." Old bootrom 3GS phones will always have an untethered jailbreak available to them, regardless of what version of iOS they're on (not always immediately mind you, but it's a fairly easy jump as opposed to developing new exploits).

    --Just looking over the various documents (as reported by other sites)--looks like the changelog for this version is a big cup of "no changes" with a couple minor API tweaks. This version better have impeccable battery life, faster and more capable Siri functionality, the ability to know what I want for lunch before I do, and solve world poverty, hunger, and strife...
    Last edited by Orby; 11-28-2011 at 05:17 PM.

  6. #6
    iPhone? More like MyPhone Raybeast's Avatar
    Join Date
    Jul 2011
    Posts
    257
    Thanks
    9
    Thanked 36 Times in 21 Posts

    Put Siri on the iPad 2 pleeseeeease.

  7. #7
    Green Apple
    Join Date
    May 2010
    Posts
    79
    Thanks
    0
    Thanked 0 Times in 0 Posts

    bollocks!

    i just bought a 4S its already on 5.0.1 so i guess i may as well update it to 5.1 eh?
    not too bothered though cos my 3gs is now a very expensive ipod touch jailbroken on 5.0

  8. #8
    MMi Staff Writer Anthony Bouchard's Avatar
    Join Date
    Sep 2011
    Location
    Florida
    Posts
    6,613
    Thanks
    194
    Thanked 958 Times in 701 Posts

    Quote Originally Posted by c14rlf View Post
    bollocks!

    i just bought a 4S its already on 5.0.1 so i guess i may as well update it to 5.1 eh?
    not too bothered though cos my 3gs is now a very expensive ipod touch jailbroken on 5.0
    Yeah you might as well update. There is no untether coming for iOS 5.0.1 anytime soon.

  9. #9
    What's Jailbreak?
    Join Date
    Oct 2011
    Location
    Jerusalem, Israel, Israel
    Posts
    17
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by Anthony Bouchard View Post
    iOS 5, no matter the firmware, from my understanding will always be untethered on the old bootrom iPhone 3GS because the bootrom exploit is a hardware exploit that cannot be patched by Apple with software.

    I could be wrong, but that's my understanding. So I am going to have to answer your question with, "Yes."
    only if Redsn0w can jailbreak ios 5.1, and probably it will.

    rumors also suggested that ios 5.1 will fix the memory drain that they found in ios 5.
    Last edited by jobran; 11-28-2011 at 05:37 PM.

  10. #10
    Green Apple smooth22's Avatar
    Join Date
    Jul 2009
    Location
    Los Angeles, CA.
    Posts
    95
    Thanks
    2
    Thanked 9 Times in 8 Posts

    I used to think tether jailbreaks sucked until i decided to try it out its not that bad u just got to watchout for your battery life thats about it after u install all the tweaks u want on your device but its nothing major u get used to it. im on ios 5.0.1.

  11. #11
    iPhoneaholic
    Join Date
    Jul 2009
    Location
    Bellevue, WA
    Posts
    438
    Thanks
    43
    Thanked 46 Times in 41 Posts

    Quote Originally Posted by smooth22 View Post
    I used to think tether jailbreaks sucked until i decided to try it out its not that bad u just got to watchout for your battery life thats about it after u install all the tweaks u want on your device but its nothing major u get used to it. im on ios 5.0.1.
    I wish that were the case with my 4S. I have to reboot it at least once or twice a day because I will randomly lose internet even with trying to turn airplane mode on/off.

    Apparently it's a "feature" of the Sprint network.

  12. #12
    Green Apple
    Join Date
    Nov 2011
    Posts
    38
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Paranoid Parrot: What if Apple purposefully released iOS 5.0 with bugs so that once jailbreaks come out they would release a new version that patches the bugs and the jailbreak exploit.

  13. #13
    Green Apple
    Join Date
    May 2010
    Posts
    79
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by TooSlo View Post
    I wish that were the case with my 4S. I have to reboot it at least once or twice a day because I will randomly lose internet even with trying to turn airplane mode on/off.

    Apparently it's a "feature" of the Sprint network.

    That happens with both my and my gf's 3GS with the tethered jb too

  14. #14
    Green Apple
    Join Date
    Jan 2011
    Posts
    78
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Quote Originally Posted by epikarus View Post
    Paranoid Parrot: What if Apple purposefully released iOS 5.0 with bugs so that once jailbreaks come out they would release a new version that patches the bugs and the jailbreak exploit.
    or they purposely released 5.0 to drain our batteries and screw over all those who have JB devices, lol

  15. #15
    Go Wings Zokunei's Avatar
    Join Date
    Jun 2010
    Location
    Michigan
    Posts
    6,384
    Thanks
    144
    Thanked 466 Times in 378 Posts

    What does it mean that the firmware "expires" in January?

  16. #16
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,228
    Thanks
    6,592
    Thanked 14,778 Times in 6,873 Posts

    Quote Originally Posted by Zokunei View Post
    What does it mean that the firmware "expires" in January?
    Means if you install this it will stop working in January.

  17. #17
    Go Wings Zokunei's Avatar
    Join Date
    Jun 2010
    Location
    Michigan
    Posts
    6,384
    Thanks
    144
    Thanked 466 Times in 378 Posts

    Quote Originally Posted by Simon View Post
    Means if you install this it will stop working in January.
    I wasn't aware that Apple forced updates now.

    I better not start getting 1600 errors again.

  18. #18
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,228
    Thanks
    6,592
    Thanked 14,778 Times in 6,873 Posts

    Quote Originally Posted by Zokunei View Post
    I wasn't aware that Apple forced updates now.

    I better not start getting 1600 errors again.
    It's a beta dude . The betas always have expiry dates. Regular firmware doesn't.

  19. #19
    Go Wings Zokunei's Avatar
    Join Date
    Jun 2010
    Location
    Michigan
    Posts
    6,384
    Thanks
    144
    Thanked 466 Times in 378 Posts

    Quote Originally Posted by Simon View Post
    It's a beta dude . The betas always have expiry dates. Regular firmware doesn't.
    Well the time I got stuck with 1600 errors I was on a beta. I don't use betas anymore though, so I'll be safe.

  20. #20
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,228
    Thanks
    6,592
    Thanked 14,778 Times in 6,873 Posts

    Quote Originally Posted by Zokunei View Post
    Well the time I got stuck with 1600 errors I was on a beta. I don't use betas anymore though, so I'll be safe.
    No point to it anyway. I havent heard of much new in 5.1 yet.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts