+ Reply
Page 10 of 12 FirstFirst ... 89101112 LastLast
Results 181 to 200 of 231

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Firmware 2.2 Released

is a discussion within the

iPhone News

forums, a part of the

General iPhone

section;
Originally Posted by Bruce109 Just to make sure, I am using a 3G that's jail broken and also on USA T-Mobile with a turbo sim. I know that if I
...
  1. #181
    Previously Known as A.T MetallicaFan1991's Avatar
    Join Date
    Apr 2008
    Location
    Manchester, UK
    Posts
    1,582
    Thanks
    188
    Thanked 111 Times in 94 Posts

    Quote Originally Posted by Bruce109 View Post
    Just to make sure, I am using a 3G that's jail broken and also on USA T-Mobile with a turbo sim. I know that if I upgrade to 2.2 I wont be able to jail brake it yet but does anyone know for sure if my Phone will still work on T-Mobile with the turbo sim? I'm pretty sure it will but I'd like to make sure before I do it.
    Turbo sims will not work on iPhone 3G's on 2.2.

    MBP 15" 2.66Ghz Core 2 Duo Nvidia 9400M 9600GT 256MB OS X 10.6.4 Windows 7 June 2009
    iPhone 4 August 28th

  2. #182
    iPhoneaholic boe_dye's Avatar
    Join Date
    Jun 2007
    Posts
    394
    Thanks
    34
    Thanked 39 Times in 32 Posts

    Quote Originally Posted by LeeDude View Post
    Lemme see if I can explain this properly. The big difference between the 1.x firmwares and the 2.x firmwares is where all of the files are located. The entire file system was moved around. This meant that all of the previous 1.x firmware programs were unable to work until they optimized for the change. It was a lot of work for some, and in some cases, not worth the time. Apple made this change for the AppStore. I don't believe we will see a big change like that again on the iPhone, and if we do, it won't be for a long while. So right now, I can't imagine any updates would completely render your 3rd party apps useless. And if some don't work here and there, I don't think it would be difficult for the developers to fix them.


    Edit: Re-read your post, not sure if you meant they worked on 2.0 but not 2.1, or what. I just woke up, and I think i'm confusing myself in a heated debate (with myself) to decide how you meant your question. :P
    Thanks for the insight on that!

    It was more of an over all f/w to f/w version question. Thinking back, the what prompted me to ask was when I first got my iPhone and JB, there was a message in Cydia that said something along the lines issues between 2.0 and 2.1.

    I don't specifically remember what it was or said.

    But I did distinctly remember an issue between 1.x and 2.x which you answered quite nicely.

    My main concern is this: Having anything that you use on a daily basis becomes like an old pair of sneakers. Comfortable, useable etc. I like the satisfaction that comes with finally getting something tweaked just the way i like it, then having it be totally ruined when some "new and improved" idea comes around.

    Perfect example is when I updated FF from 2 to 3. Suddenly a whole schlew of themes and addons ceased working because of "compatibility". Things that I used daily and that I like alot.

    Thats another reason why I am leary about updating anything. The fear of sure I might get more stuff that i probably wont use, but how much am I going to lose of things that I really do use?

    Thanks again for the explanation!

    Quote Originally Posted by Dizz View Post
    Probably not. I can't see someone sitting around at the Apple store or AT&T opening every single sealed iPhone that is running 2.1 and update each one of them to 2.2 then sealing them back up to sell. So odds are there's still a bunch of 2.1 software iPhones that need to be sold off before they get and start selling 2.2's.
    unless they would do it during the activation process...

    Quote Originally Posted by buzios View Post
    That is not correct.

    With minor exceptions, from 1.x to 2.x files remained in the same place.
    There are always a few changes in every new firmware but that usually don't break regular apps.

    What caused apps written for 1.x not to work on 2.x were changes to some APIs, a new linkage and signature (not required on 1.x)

    In the 2.x series of firmware, apps written for fw 2.0 using the "official" API should continue to work.
    Apple can not change the existing public API.
    Apple can extend the API but can not change what was released in 2.0.
    okay... that makes sense too...

    Your answer seems a bit more logical.

    Thanks!
    Last edited by boe_dye; 11-22-2008 at 11:55 AM. Reason: Automerged Doublepost
    Herp a derp a derp a doooo!

  3. #183
    Livin the iPhone Life Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,265
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Quote Originally Posted by buzios View Post
    That is not correct.

    With minor exceptions, from 1.x to 2.x files remained in the same place.
    There are always a few changes in every new firmware but that usually don't break regular apps.

    What caused apps written for 1.x not to work on 2.x were changes to some APIs, a new linkage and signature (not required on 1.x)

    In the 2.x series of firmware, apps written for fw 2.0 using the "official" API should continue to work.
    Apple can not change the existing public API.
    Apple can extend the API but can not change what was released in 2.0.
    You need to do a lot more research before making claims like that. The file system tool chain is completely different. In 1.1.4 the apps were stored on the root partition and run as root. The 2.0+ moves the apps to the mobile partition and all apps are run with user (mobile), NOT root permissions. Every single app had to be COMPLETELY re-written for 2.0... not just "minor" changes as you stated.

    For everyone worried about app compatibility from 2.1 to 2.2 99% of all apps should work in their current state since updated from 2.0 > 2.0.1 > 2.0.2 > 2.1 have all been MINOR updates without file structure changes. Hope this helps.
    [SIGPIC][/SIGPIC]

  4. The Following User Says Thank You to Poseidon79 For This Useful Post:

    boe_dye (11-22-2008)

  5. #184
    Banned
    Join Date
    Sep 2008
    Location
    Long Island, NY
    Posts
    469
    Thanks
    55
    Thanked 52 Times in 44 Posts

    ^^ seriously...



    anyone else get the txt message from apple and att saying 2.2 is out and to upgrade?

  6. #185
    iPhoneaholic boe_dye's Avatar
    Join Date
    Jun 2007
    Posts
    394
    Thanks
    34
    Thanked 39 Times in 32 Posts

    Quote Originally Posted by Poseidon79 View Post
    You need to do a lot more research before making claims like that. The file system tool chain is completely different. In 1.1.4 the apps were stored on the root partition and run as root. The 2.0+ moves the apps to the mobile partition and all apps are run with user (mobile), NOT root permissions. Every single app had to be COMPLETELY re-written for 2.0... not just "minor" changes as you stated.

    For everyone worried about app compatibility from 2.1 to 2.2 99% of all apps should work in their current state since updated from 2.0 > 2.0.1 > 2.0.2 > 2.1 have all been MINOR updates without file structure changes. Hope this helps.
    that helps too. I could see how both arguments would pertain to the situation as both instances have occoured in various other systems.

    However i think this answers my question, and thank you for being detailed!

    Quote Originally Posted by Carrbone View Post
    ^^ seriously...



    anyone else get the txt message from apple and att saying 2.2 is out and to upgrade?
    yup at 10 oclock in the am.

    i wonder if they charged me for that message...
    Last edited by boe_dye; 11-22-2008 at 12:55 PM. Reason: Automerged Doublepost
    Herp a derp a derp a doooo!

  7. #186
    Banned
    Join Date
    Mar 2008
    Posts
    153
    Thanks
    13
    Thanked 29 Times in 18 Posts

    Quote Originally Posted by boe_dye View Post

    i wonder if they charged me for that message...
    LMFAO!! No ***** huh!

  8. #187
    iPhone? More like MyPhone Andy51081's Avatar
    Join Date
    Aug 2008
    Posts
    136
    Thanks
    8
    Thanked 12 Times in 12 Posts

    iPhone 3G
    With o2 in uk
    Had jailbroken on 2.1 and upgraded to 2.2, but, the apps that were hidden with poof in boss prefs are still hidden it would seem. I also still have the numeric battery and the mim operator txt still edited to my personal preference.

    Now before everyone says I should have waited, I don't care about the unlock. But what I'm asking is will I be able to bring these back after the new jailbreak when it arrives?

  9. #188
    What's Jailbreak?
    Join Date
    Aug 2007
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Stuck in DFU
    I really hope one of you can help me out here. I attempted to upgrade to 2.2 from a previous version that had been pawned and am now stuck in DFU mode. I get an error, 1016, I think and iTunes tells me it cannot be restored. I have tried all older versions of firmware that are on my drive with the same end result but occasionally receive a different error code. I even tried booting into xp to restore with the same result.

    I'm running:
    Macbook
    iPhone 3G
    I don't remember the firmware that was on it most recently but am thinking it was most likely the release just prior to this one.
    iTunes is updated and current.

    Please, help if you can.

    Many thanks,

    J5

  10. #189
    Green Apple
    Join Date
    Mar 2008
    Posts
    30
    Thanks
    0
    Thanked 1 Time in 1 Post
    i already see people coming in to my store asking about unlocking or jailbreaking 2.2, people never learn~xd

  11. #190
    iPhoneaholic boe_dye's Avatar
    Join Date
    Jun 2007
    Posts
    394
    Thanks
    34
    Thanked 39 Times in 32 Posts

    you know, i really dont think that the majority of people get the whole jailbreaking or unlocking appeal. They are mostly doing it cause it sounds cool and makes them feel like hackers.

  12. #191
    Green Apple
    Join Date
    Sep 2007
    Posts
    57
    Thanks
    2
    Thanked 1 Time in 1 Post
    EVERYBODY WHO IS SAYING IT IS FASTER IS JUST USED TO THE SLOWNESS OF YOUR JB DEVICE! Obviously if you do a clean restore/update you would think that it would run faster...

  13. #192
    Green Apple
    Join Date
    Oct 2007
    Posts
    55
    Thanks
    3
    Thanked 3 Times in 3 Posts

    I've got a quick question.

    I used winpwn to jb my 1st gen iphone and I'm now on 2.0.1. What should I use to jb my phone now since winpwn hasnt been updated in forever. I'm on a PC by the way. Will these other programs screw-up my iphone since I already pwned my itunes and phone?

  14. #193
    iPhone? More like MyPhone wgm214's Avatar
    Join Date
    Aug 2008
    Posts
    286
    Thanks
    20
    Thanked 11 Times in 10 Posts

    pwnagetool and quick pwn is out
    blog.iphone-dev.org
    Wanna-be coder/iphone user since '08

  15. The Following 2 Users Say Thank You to wgm214 For This Useful Post:

    aayman_farzand (11-22-2008), gameviper (11-22-2008)

  16. #194
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Location
    TX
    Posts
    278
    Thanks
    12
    Thanked 26 Times in 24 Posts

    Quote Originally Posted by wgm214 View Post
    pwnagetool and quick pwn is out
    blog.iphone-dev.org
    indeed it is....

  17. #195
    iPhone? More like MyPhone
    Join Date
    Aug 2008
    Posts
    123
    Thanks
    11
    Thanked 4 Times in 4 Posts

    Alright! Downloading now..

  18. #196
    iPhone? More like MyPhone
    Join Date
    Apr 2008
    Posts
    212
    Thanks
    19
    Thanked 9 Times in 9 Posts

    Now that the tools are out there, can anyone please share a custom 2.2 firmware for the iphone 1st gen

    Thanks in advance

  19. #197
    Green Apple
    Join Date
    Nov 2008
    Posts
    61
    Thanks
    9
    Thanked 2 Times in 2 Posts

    OK, I have an AT&T iPhone 3g, do not care about unlocking to be able to use on another carrier, just so I can install apps via Cydia and Installer. i.e. use Winterboard, etc. Am I reading correctly that it is ok in my situation to use the latest release of Quickpwn? or ????

  20. #198
    Green Apple aries_green_monkey's Avatar
    Join Date
    Aug 2008
    Location
    California
    Posts
    74
    Thanks
    3
    Thanked 4 Times in 4 Posts

    ALL i wanted was emoji icons...

    why would somebody make this up??

  21. #199
    plain jane vanilla (post count restored to FULL AWESOMENESS) cpjr's Avatar
    Join Date
    Jul 2007
    Location
    ATL
    Posts
    11,686
    Thanks
    181
    Thanked 1,461 Times in 1,264 Posts

    Quote Originally Posted by helitx View Post
    OK, I have an AT&T iPhone 3g, do not care about unlocking to be able to use on another carrier, just so I can install apps via Cydia and Installer. i.e. use Winterboard, etc. Am I reading correctly that it is ok in my situation to use the latest release of Quickpwn? or ????
    Backup.....update (dont sync)....quickpwn....sync.....your good to go.

  22. #200
    iPhone? More like MyPhone bubonicbryan's Avatar
    Join Date
    Dec 2007
    Posts
    152
    Thanks
    4
    Thanked 22 Times in 11 Posts

    Okay. I'm utterly confused.
    I have 16gb first gen iphone that is unlocked and jailbroke.
    Do I click "update" in itunes (wont this get rid of my unlock?!?!), then use the new quickpwn for mac to re-jailrbeak and redownload all my cydia apps?

    I'm worried I'm going to brick my iphone.
    iPhizzle

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts