+ Reply
Page 1 of 6 123 ... LastLast
Results 1 to 20 of 117

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: New Installer 4.0b8!

is a discussion within the

iPhone News

forums, a part of the

General iPhone

section;
RipDev has released the Installer 4.0b8 publically! This is the last update since the 4.0b6 which removed quite a few bugs . The reason they mention for the late release
...
  1. #1
    Former MMi Staff Writer sayam's Avatar
    Join Date
    Jul 2008
    Location
    Ludhiana, Punjab, India
    Posts
    804
    Thanks
    34
    Thanked 464 Times in 104 Posts

    Exclamation New Installer 4.0b8!


    RipDev has released the Installer 4.0b8 publically! This is the last update since the 4.0b6 which removed quite a few bugs. The reason they mention for the late release being swamped with work.

    This new version switches to libcurl from the stock Foundation URL loading classes, which means more lightweight CPU and memory footprint and, more importantly, resumable file transfers. They also mention that there will be some more bug fixes.

    Another great thing is that they have changed the functioning of the feature page. Now the featured page has featured stuff in it's true sense. I mean to say that now it displays the most popular (number of installations) packages on the featured page. Though there will be a few sponsored package too (for obvious reasons ) but they will be easily distinguishable and will be less in number (<3).

    Another improvement done is that the community sources ae updated to reflect the change in name of ModMyiF0ne (intentionally mispelled) to ModMyi. It also removes some useless and outdated sources.

    Also, now they are willing to host some packages from devs and will do everything (including scripting) themselves for your convenience for free. Just contact them.

    P.S. It's already included in the last Pwnage Tool

    [RipDev Blog]
    Last edited by sayam; 09-25-2008 at 01:54 PM.

  2. The Following User Says Thank You to sayam For This Useful Post:

    LUISCHIMELIS (03-06-2009)

  3. #2
    Green Apple
    Join Date
    Jul 2008
    Posts
    30
    Thanks
    3
    Thanked 3 Times in 2 Posts

    too bad barely anyone uses installer anymore...

  4. #3
    Green Apple mixer911's Avatar
    Join Date
    Feb 2008
    Location
    Freeport TX
    Posts
    43
    Thanks
    3
    Thanked 2 Times in 2 Posts

    Quote Originally Posted by corizzle View Post
    too bad barely anyone uses installer anymore...
    true, i have installer 4 installed but i hide it with poof cuz i have no use for it

  5. #4
    What's Jailbreak?
    Join Date
    Feb 2008
    Location
    Canada
    Posts
    14
    Thanks
    1
    Thanked 2 Times in 2 Posts

    hmmm i used the windows quickpwn 2.1 from here and it came with installer version 4.0b6-5. any idea how to update to 4.0b8? is there an internal updater in installer?

  6. The Following User Says Thank You to dave8125 For This Useful Post:

    Stanmans9 (10-05-2008)

  7. #5
    iPhone? More like MyPhone wgm214's Avatar
    Join Date
    Aug 2008
    Posts
    286
    Thanks
    20
    Thanked 11 Times in 10 Posts

    so whats in installer thats not in cydia??

  8. #6
    iPhone? More like MyPhone chbearsrock's Avatar
    Join Date
    Jun 2008
    Location
    Chicago
    Posts
    114
    Thanks
    7
    Thanked 11 Times in 6 Posts

    Quote Originally Posted by wgm214 View Post
    so whats in installer thats not in cydia??
    Bugs, mostly.

  9. The Following 5 Users Say Thank You to chbearsrock For This Useful Post:

    Dizz (09-27-2008), sgt sm00th (09-26-2008), UiK (09-26-2008), vinodis (09-26-2008), WillyDavidK (09-27-2008)

  10. #7
    Green Apple
    Join Date
    Mar 2008
    Location
    Downunder
    Posts
    98
    Thanks
    5
    Thanked 9 Times in 7 Posts

    Default who even uses installer any more
    installer has had its day
    Cydia is my installer of choice
    has no bugs works like a charm and in my mind a far better option
    still good to see things being worked on

  11. #8
    My iPhone is a Part of Me Chefanim's Avatar
    Join Date
    Jul 2008
    Location
    Panama City, FL
    Posts
    894
    Thanks
    42
    Thanked 153 Times in 132 Posts

    I opened up installer to get the update, updated it and the community sources. Then Exited installer. That was followed by a 5 minute spinning wheel, followed by a failed restart.

    Apple screen of death

    Thank god I can SSH in and get it started again.

    Thats the last straw for me and Installer
    So long, and thanks for all the fish

  12. #9
    iPhone? More like MyPhone wgm214's Avatar
    Join Date
    Aug 2008
    Posts
    286
    Thanks
    20
    Thanked 11 Times in 10 Posts

    i just installed installer from hackmyifone thinking it was th eupdate and now my installed shows 2 installers. it wont let me uninstall the hackmyifone one

  13. #10
    Green Apple mooritexxx's Avatar
    Join Date
    Jan 2008
    Posts
    60
    Thanks
    10
    Thanked 1 Time in 1 Post
    where can we get it from?

  14. #11
    What's Jailbreak?
    Join Date
    Mar 2008
    Posts
    5
    Thanks
    0
    Thanked 1 Time in 1 Post
    Just open installer on your phone and it should have a pop up alert and you can update right there. If not go into updated on the Installer category list

  15. The Following User Says Thank You to rx7girltk For This Useful Post:

    Stanmans9 (10-05-2008)

  16. #12
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 1 Post
    Quote Originally Posted by Chefanim View Post
    I opened up installer to get the update, updated it and the community sources. Then Exited installer. That was followed by a 5 minute spinning wheel, followed by a failed restart.

    Apple screen of death

    Thank god I can SSH in and get it started again.

    Thats the last straw for me and Installer
    Unbelievable. I got this too, exact same problem, updated, then community sources, then SWOD, then ALOD.

    Had to SSH in and kill the mobilewatchdog, reboot and enable the watchdog again and it worked. Basically pre-2.1 workaround...

    Unbelievable! Apple fixed the ALOD for too many apps remapping and it worked well even with Cydia, and now Installer manages to break it again??

    Chefanim, after getting it to run again, you experienced any further problems with Installer apps?

  17. #13
    Green Apple
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    55
    Thanks
    2
    Thanked 3 Times in 2 Posts

    Happened to me too (can't get out of the black screen with the PWNAGE icon, keeps rebooting) . Can you tell me the steps to SSH in and kill mobilewatchdog? I know I had SSH on before this, not sure how to do what you said in your post. Thanks in advance.
    Last edited by jimmie geddes; 09-25-2008 at 07:17 PM.
    Jimmie Geddes, Editor

  18. #14
    Green Apple mikdiamon's Avatar
    Join Date
    Jan 2008
    Location
    El Mirage, AZ
    Posts
    70
    Thanks
    32
    Thanked 3 Times in 2 Posts

    Quote Originally Posted by phi6 View Post
    Unbelievable. I got this too, exact same problem, updated, then community sources, then SWOD, then ALOD.

    Had to SSH in and kill the mobilewatchdog, reboot and enable the watchdog again and it worked. Basically pre-2.1 workaround...

    Unbelievable! Apple fixed the ALOD for too many apps remapping and it worked well even with Cydia, and now Installer manages to break it again??

    Chefanim, after getting it to run again, you experienced any further problems with Installer apps?
    can someone please post a link or give more detailed instructions (for dummies) I have limited experience with ssh, I can login, ect but i have no idea the commands to do this.

    TIA

  19. #15
    Banned
    Join Date
    Aug 2007
    Posts
    23
    Thanks
    0
    Thanked 9 Times in 5 Posts

    just download the iphone kit which has iphonebrowser..hook it up..wait for it to load..then go private..var..mobile..Applications and change Applications to Application2...wait a few seconds and it should start..then change Application2 back to Applications and reboot..just did that like 5 min ago......after i used the new installer

  20. The Following User Says Thank You to 05VIII For This Useful Post:

    mikdiamon (09-25-2008)

  21. #16
    Green Apple
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    55
    Thanks
    2
    Thanked 3 Times in 2 Posts

    I used Winscp to ssh into my iphone. Went to the mv /System/Library/SystemConfiguration/mobilewatchdog.bundle/, copied that to my desktop, then deleted it from my iPhone. Rebooted iPhone. After reboot iPhone came back to home secreen.

    ssh'ed back in, copied the mobilewatchdog.bundle folder back to the same directory I deleted it from. Rebooted iPhone.

    It's working fine now, so far..
    Jimmie Geddes, Editor

  22. #17
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    Posts
    269
    Thanks
    22
    Thanked 16 Times in 16 Posts

    Quote Originally Posted by Chefanim View Post
    I opened up installer to get the update, updated it and the community sources. Then Exited installer. That was followed by a 5 minute spinning wheel, followed by a failed restart.

    Apple screen of death

    Thank god I can SSH in and get it started again.

    Thats the last straw for me and Installer
    In my case, it automatically updated itself, I noticed number 2 in red in 'tasks' as soon as I opened Installer, and now in 'installed packages' it says I have the 4.08b (or whatever) last version. Everything is fine here. Sorry to hear about your problems. But, you are right, why bother, Cydia works fine and I never use Installer anyway
    iPhone 2G Pwned 3.1.2
    MBP OSX 10.6.3

  23. #18
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 1 Post
    Quote Originally Posted by 05VIII View Post
    just download the iphone kit which has iphonebrowser..hook it up..wait for it to load..then go private..var..mobile..Applications and change Applications to Application2...wait a few seconds and it should start..then change Application2 back to Applications and reboot..just did that like 5 min ago......after i used the new installer
    Actually DO NOT do this as it will make some of your apps disappear (they are technically still there but they will need a resync).

    Follow these detailed instructions. They will work, and you will retain all your apps.

    If you don't have SSH already installed, then theres no hope for you I'm afraid, though iPhoneBrowser may work, I've not tried this.

    iPhone ALoD: MAJOR design flaw!! - Mac Forums

  24. The Following 2 Users Say Thank You to phi6 For This Useful Post:

    Chefanim (09-25-2008), mikdiamon (09-25-2008)

  25. #19
    Green Apple
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    55
    Thanks
    2
    Thanked 3 Times in 2 Posts

    Quote Originally Posted by phi6 View Post
    Actually DO NOT do this as it will make some of your apps disappear (they are technically still there but they will need a resync).

    Follow these detailed instructions. They will work, and you will retain all your apps.

    If you don't have SSH already installed, then theres no hope for you I'm afraid, though iPhoneBrowser may work, I've not tried this.

    iPhone ALoD: MAJOR design flaw!! - Mac Forums
    That's where I got the instructions I used, sorry I didn't post the link. They work if you have SSH installed. Thanks for posting the link for everyone.
    Jimmie Geddes, Editor

  26. #20
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 1 Post
    I guess the next step is to find out if the problem re-occurs after 1. AppStore app install, 2. Cydia app install and 3. Installer app install. I assume it will occur after Installer, since it did with community sources.

+ Reply
Page 1 of 6 123 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts