Page 4 of 4 FirstFirst ... 234
Results 61 to 70 of 70

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: How to create Installer 4.0 repository

  1. #61
    I am trying to host a repo using the following.

    OS: Windows Vista
    WebServer: Apache 2


    Repo is working like it should. I can extraxt the sample packages and reZip them without making any changes/edits. After extracting and reziping the package it installs fine on my iphone. However if I extract the files and edit the Install.plist before reziping it gives me a "com.apptapp.install error 3" when trying to install the package.

    any idea? I have tried with many editors with the same results. I have also tried it under Ubuntu with the same result.

  2. #62
    Quote Originally Posted by MikesTooLz View Post
    I am trying to host a repo using the following.

    OS: Windows Vista
    WebServer: Apache 2


    Repo is working like it should. I can extraxt the sample packages and reZip them without making any changes/edits. After extracting and reziping the package it installs fine on my iphone. However if I extract the files and edit the Install.plist before reziping it gives me a "com.apptapp.install error 3" when trying to install the package.

    any idea? I have tried with many editors with the same results. I have also tried it under Ubuntu with the same result.
    Sounds like the file path make sure you have the exact path for install and also for remove
    check out my website for touchscreen computers http://touchswipe.com

  3. #63
    Quote Originally Posted by hiphonepro View Post
    Great! Glad you got it we need to stick together and help each other to get this up and going together.
    I'm ready to help with all information i have and through my own experience

    i'm thinking to make a step by step guide to clarify how to set up the repo on windows environment

    when i'm done i'll post it here

    cheers

  4. #64
    Quote Originally Posted by hiphonepro View Post
    Sounds like the file path make sure you have the exact path for install and also for remove
    only thing I changed was description

  5. #65
    Do the names of the file match?
    check out my website for touchscreen computers http://touchswipe.com

  6. #66
    I found out why installer crashes it's bigbosses source!!!
    Remove bigboss source and installer4 works great!!!
    check out my website for touchscreen computers http://touchswipe.com

  7. #67
    Isn’t there someone in here who could supply us with a working demo template for themes?

    I tried now for 3 days and still can’t get it to work, whether with the new or old build from ripdev. :[

    Of course I studied their own Tutorial (and several others), now I actually have a valid source but
    my package won’t show up - structure:

    packages/Themes/VendingMachine.zip (contains Install.plist, Install.png, Vending Machine™.theme)

    My packages don't show up!
    First of all, make sure that you have placed the packages in the correct folder. The proper location is packages//package.zip. Many of you put the zip file right into the packages/ directory - this won't work as it has to know the category for it, too. So make sure your, for example, wallpaper, is in packages/Wallpapers/MyGreatWallpaper.zip.


    I get "cannot extract Install.plist" error when running regenerate.php!
    Make sure you have compressed your package in a way that all files are contained at the root of the zip archive, and not in a subfolder. This is easily done (on a Mac) by selecting all the individual files that go into package and choosing Compress from the contextual menu, instead of compressing the folder containing your files. This can be checked in Terminal.app by running zipinfo : if you see something like MyPackage/Install.plist in the listing instead of just Install.plist - your package is not compressed correctly.


    Errors with DOMDocument->load() not defined.
    Currently investigating why this may be happening. If you have an idea, let me know.
    Last edited by pattulus; 01-16-2009 at 09:34 AM.

  8. #68
    Come on… some of you guys must have done it several times.
    What about a lousy theme template to have a look on?

  9. #69
    I'm in 2010 and this tutorial also works with Installer4 on firmware 4.0!!!!

    My repo's adress : http://philippe97.comyr.com/installer4/

    Download Installer4 from my Cydia repository : Philippe97's Repository - MyRepoSpace.com

  10. #70
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,789
    Thanks
    7,002
    Thanked 15,561 Times in 7,112 Posts

    Not to knock on you, but what would be the point of installer 4 now?

Page 4 of 4 FirstFirst ... 234
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •