Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 70

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: How to create Installer 4.0 repository

  1. #21
    I'm getting the Install.plist error, either there is a special way to zip the package or there is something wrong with the Install.plist in the demo/template

  2. #22
    Any reason why I cannot download the file?

    can u upload to rapidshare or something?
    Last edited by BennyLava; 08-24-2008 at 01:07 PM. Reason: Automerged Doublepost

  3. #23
    I got everything working and a wallpaper to install and uninstall but anything else gives me a bad url error i tried a ringtone and an app I guees install.plist templates would be great to have for everykind of install also I have custom icons for my packs but not for my repo anyone know that secret?

    By the way I fixed the unable to decode error with me the issue was in the
    config.inc.php when I added paths to info and packages I did not include repo/......com/packages I only had .....com/packages for example as soon as I added the repository root folder to the path it works great now if I can just get these install.plists to work I will start making apps for it

    heres my repo anyway
    Installer 4.0 Repository

    P.S. I get this when trying to download the .zip in the first post:

    hiphonepro, you do not have permission to access this page. This could be due to one of several reasons:

    Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
    If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.

    heres some youtube tuts [ame="http://www.youtube.com/watch?v=NRHTBzDZsjo&feature=related"]YouTube - How to Make a Installer 4 Repo. Part 1[/ame]

    [ame="http://www.youtube.com/watch?v=FC4U3PLrnIk&feature=related"]YouTube - How to make a Installer 4 Repo. Part 2[/ame]

    [ame="http://www.youtube.com/watch?v=lKguxWHAHBc&feature=related"]YouTube - How to make a Installer 4 Repo. Part 3[/ame]
    Last edited by hiphonepro; 08-24-2008 at 04:58 PM. Reason: Automerged Doublepost
    check out my website for touchscreen computers http://touchswipe.com

  4. #24
    My iPhone is a Part of Me
    Join Date
    Sep 2007
    Location
    Texas
    Posts
    526
    Thanks
    15
    Thanked 124 Times in 73 Posts

    Yess how to add custom icon!?
    Last edited by jayc7176; 08-24-2008 at 06:11 PM.

  5. #25
    I can't get past the regenerate url. I never get it to index anything.


    Generating index for firmware 2.0.


    Warning: domdocument() [http://modmyi.com/function.domdocument]: Start tag expected, '<' not found
    in /home/grrr/public_html/info/regenerate.php on line 160



    Fatal error: Call to undefined method: domdocument->load() in /home/grrr/public_html/info/regenerate.php on line 161
    Hmm...

  6. #26
    I now have 3 custom apps in my repo the error bad url was because I needed to set the permisions on my packages to 777 now they work great so far I have a financial app/boomark, the iphone commercial ringtone and a wallpaper from my website

    AND AGAIN HOW DO WE MAKE THE MAIN CUSTOM ICON THAT COMES UP WHEN ADDING YOUR SOURCE?? PLEASE ANYBODY??

    Also does anyone know the file path to videos or movies in ipod I want to add some videos to my source
    Last edited by hiphonepro; 08-24-2008 at 07:58 PM.
    check out my website for touchscreen computers http://touchswipe.com

  7. #27
    My iPhone is a Part of Me
    Join Date
    Sep 2007
    Location
    Texas
    Posts
    526
    Thanks
    15
    Thanked 124 Times in 73 Posts

    Hey what am i doing wrong? i keep getting this seeems to never go past this step...

    this is when doing the -- /regenerate.php?secret=blahblah

    any help .?



    Generating index for firmware 2.0.
    Scanning category 'Demo Category'...
    Category 'Demo Category' scanned, 1 packages added, 0 packages skipped.

    Generating index for firmware 2.0.1.
    Scanning category 'Demo Category'...
    Category 'Demo Category' scanned, 1 packages added, 0 packages skipped.


    Pinging search server...


    Warning: fopen() expects at least 2 parameters, 1 given in /home/rockit/public_html/repo/regenerate.php on line 84



    Warning: fread(): supplied argument is not a valid stream resource in /home/rockit/public_html/repo/regenerate.php on line 85



    Warning: fclose(): supplied argument is not a valid stream resource in /home/rockit/public_html/repo/regenerate.php on line 86

    All done, thank you!


    ================================================== ===================

    To Add cust Repo Icon - add another Key in Info.Plist

    Add this to info.plist : & location of your .PNG icon


    PHP Code:
                <key>icon</key>
            <
    string>http://example.com/images/repoicon.png</string>


    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <
    plist version="1.0">
    <
    dict>
        <
    key>info</key>
        <
    dict>
            <
    key>icon</key>
            <
    string>http://example.com/images/repoicon.png</string>
            
    <key>name</key>
            <
    string>My Test Repository</string>
            <
    key>maintainer</key>
            <
    string>John Doe</string>
            <
    key>contact</key>
            <
    string>jojo@gmail.com</string>
            <
    key>url</key>
            <
    string>http://hothothotiphone.com</string>
            
    <key>category</key>
            <
    string>Test</string>
            <
    key>description</key>
            <
    string>This is a test repo lets see if it works</string>
        </
    dict>
    </
    dict>
    </
    plist
    Last edited by jayc7176; 08-24-2008 at 09:42 PM. Reason: Corrected code

  8. #28
    Quote Originally Posted by hiphonepro View Post
    I now have 3 custom apps in my repo the error bad url was because I needed to set the permisions on my packages to 777 now they work great so far I have a financial app/boomark, the iphone commercial ringtone and a wallpaper from my website

    AND AGAIN HOW DO WE MAKE THE MAIN CUSTOM ICON THAT COMES UP WHEN ADDING YOUR SOURCE?? PLEASE ANYBODY??

    Also does anyone know the file path to videos or movies in ipod I want to add some videos to my source
    I remember the Install.plist and Install.png image were in the package folder.
    Last edited by bklynjava; 08-24-2008 at 09:14 PM.

  9. #29
    Quote Originally Posted by bklynjava View Post
    I remember the Install.plist and Install.png image were in the package folder.
    i'd love to have the whole package please, need a nubi link though i guess

    Quote Originally Posted by jayc7176 View Post
    Hey what am i doing wrong? i keep getting this seeems to never go past this step...

    this is when doing the -- /regenerate.php?secret=blahblah

    any help .?



    Generating index for firmware 2.0.
    Scanning category 'Demo Category'...
    Category 'Demo Category' scanned, 1 packages added, 0 packages skipped.

    Generating index for firmware 2.0.1.
    Scanning category 'Demo Category'...
    Category 'Demo Category' scanned, 1 packages added, 0 packages skipped.


    Pinging search server...


    Warning: fopen() expects at least 2 parameters, 1 given in /home/rockit/public_html/repo/regenerate.php on line 84



    Warning: fread(): supplied argument is not a valid stream resource in /home/rockit/public_html/repo/regenerate.php on line 85



    Warning: fclose(): supplied argument is not a valid stream resource in /home/rockit/public_html/repo/regenerate.php on line 86

    All done, thank you!


    ================================================== ===================

    To Add cust Repo Icon - add another Key in Info.Plist

    Add this to info.plist : & location of your .PNG icon


    PHP Code:
                <key>icon</key>
            <
    string>www.example.com/images/repoicon.png</string>


    <!
    DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <
    plist version="1.0">
    <
    dict>
        <
    key>info</key>
        <
    dict>
            <
    key>icon</key>
            <
    string>www.example.com/images/repoicon.png</string>
            <
    key>name</key>
            <
    string>My Test Repository</string>
            <
    key>maintainer</key>
            <
    string>John Doe</string>
            <
    key>contact</key>
            <
    string>jojo@gmail.com</string>
            <
    key>url</key>
            <
    string>http://hothothotiphone.com</string>
            
    <key>category</key>
            <
    string>Test</string>
            <
    key>description</key>
            <
    string>This is a test repo lets see if it works</string>
        </
    dict>
    </
    dict>
    </
    plist
    Thanks but now its saying error unsupported url??
    check out my website for touchscreen computers http://touchswipe.com

  10. #30
    My iPhone is a Part of Me
    Join Date
    Sep 2007
    Location
    Texas
    Posts
    526
    Thanks
    15
    Thanked 124 Times in 73 Posts

    Oh by bad

    not www.

    http://

    according to ripdev read me .. thats what is suggested.?

    lets see if it wrks?




    Edit:: k more understanding of the code::

    it looks like the -- config.inc will also need to have the icon define as well



    This is what rip dev says -- Edit Info.plist so it describes your repository (if you want, you can add an icon key to it to supply a repository icon png
    URL).
    Last edited by jayc7176; 08-24-2008 at 09:58 PM.

  11. #31
    OK so I got the repo working, but how do I package real apps and not just wallpaper?

    I zipped up my app just like on other repo's but when i try to install it says (com.apptapp.installer error 3)

    Anyone know why?

  12. #32
    Quote Originally Posted by BennyLava View Post
    OK so I got the repo working, but how do I package real apps and not just wallpaper?

    I zipped up my app just like on other repo's but when i try to install it says (com.apptapp.installer error 3)

    Anyone know why?
    I think you need to change the permisions on the packages in your repo to 777

    and...... still no luck on repo icon
    check out my website for touchscreen computers http://touchswipe.com

  13. #33
    Quote Originally Posted by hiphonepro View Post
    i'd love to have the whole package please, need a nubi link though i guess


    Thanks but now its saying error unsupported url??
    Sample packages
    Seems I'm stuck at this again...

    Generating index for firmware 2.0.


    Warning: domdocument() [http://modmyi.com/function.domdocument]: Start tag expected, '<' not found
    in /home/ithemeit/public_html/repo/regenerate.php on line 160



    Fatal error: Call to undefined function: load() in /home/ithemeit/public_html/repo/regenerate.php on line 161

    Attached Files Attached Files
    Last edited by bklynjava; 08-24-2008 at 10:27 PM.

  14. #34
    Cannot run external command unzip. Try editing ZIP_CMDLINE_PATH in config.inc.php.

  15. #35
    Quote Originally Posted by contra_plus View Post
    Cannot run external command unzip. Try editing ZIP_CMDLINE_PATH in config.inc.php.
    Thanks but it gets the same error.

  16. #36
    Can someone go to my repo hiphonerepo.com/repo and download irates and let me know if it is working I had it working and then it just stopped it loads into my iphone files now but i cant see it on springboard i went into the file (it's a .webclip) and it looks like they denied the permisions???

    please help me to know if it is working for others
    Thank you

    and has anyone figured out the icon? for the repo not packages?
    Last edited by hiphonepro; 08-25-2008 at 02:02 PM.
    check out my website for touchscreen computers http://touchswipe.com

  17. #37
    Quote Originally Posted by hiphonepro View Post
    I think you need to change the permisions on the packages in your repo to 777

    and...... still no luck on repo icon
    The permissions are set correctly, it's something in the package zip.
    I am lost... com.apptapp.installer error 3.

  18. #38
    i creat my source .but when I enter url http://xxx.xxx.xxx/regenerate.php?secret=test

    will screen "Cannot run external command unzip. Try editing ZIP_CMDLINE_PATH in config.inc.php."

  19. #39
    Quote Originally Posted by BennyLava View Post
    The permissions are set correctly, it's something in the package zip.
    I am lost... com.apptapp.installer error 3.
    then it's 1 of 2 things... You either need to change your .com/whatever/whatever in your install.plist or you need to zip your package in unix not dos you can check by right click the zip package then go to properties then click the second tab top of page if it's not unix you may need to convert it using zipzip earlier in this thread let us know the solution that worked once you find out

    I have an app called irates and it never shows on springboard it has a 700 permision when go in into ssh so i set it to 755 (in winscp) and it shows up is there a way to have it in the repo so that it has 755 permision automaticaly? and just shows up when someone downloads it it is my app not cracked?? and the package in the repo has permisions set at 777???
    Last edited by hiphonepro; 08-26-2008 at 08:55 AM. Reason: Automerged Doublepost
    check out my website for touchscreen computers http://touchswipe.com

  20. #40
    Quote Originally Posted by hiphonepro View Post
    then it's 1 of 2 things... You either need to change your .com/whatever/whatever in your install.plist or you need to zip your package in unix not dos you can check by right click the zip package then go to properties then click the second tab top of page if it's not unix you may need to convert it using zipzip earlier in this thread let us know the solution that worked once you find out
    Yea i got past the error 3 thing... but now its "failed script command on line 1: CopyPath" I installed unbuntu in a virtualbox to create the zips.

    Can u explain the changes I "may" need in the plist file? I am desperate at this point.

    Quote Originally Posted by hiphonepro View Post
    I have an app called irates and it never shows on springboard it has a 700 permision when go in into ssh so i set it to 755 (in winscp) and it shows up is there a way to have it in the repo so that it has 755 permision automaticaly? and just shows up when someone downloads it it is my app not cracked?? and the package in the repo has permisions set at 777???
    I'd like to know this answer too...

Page 2 of 4 FirstFirst 1234 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •