Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: How will the ModMyi repo handle 64 bit apps when the iPhone 5s is jailbroken?

  1. #1
    Default How will the ModMyi repo handle 64 bit apps when the iPhone 5s is jailbroken?
    How will the ModMyi repo handle 64 bit apps? Will developers such as myself have to submit the 64-bit build as a separate app? Or will it be set up so developers can submit both as one app? How is apple handling this on the official app store? I only ask because I now have a 64-bit build of my app and I want iPhone 5S users to be able to use it once the 5S is jailbroken.
    Try my Web Browser, Brandsonic Web! Download today from the ModMyi repo! Also available for Mac, Windows, and Android!

  2. #2
    Good question! Sorry that I don't have an answer, but I'm very interested in it too!

    Check out WW2 for iOS 8 - Widget-Weather 2.0

  3. #3
    Owner / Founder - ModMyi
    aka poetic_folly
    Kyle Matthews's Avatar
    Join Date
    May 2007
    Location
    Tampa, Florida, United States
    Posts
    8,484
    Thanks
    570
    Thanked 4,809 Times in 1,229 Posts

    Good question indeed. It's easy enough for us to maintain two packages which conflict with the respected devices. I'm checking with saurik to see if Cydia will have a better way to manage this.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  4. The Following 4 Users Say Thank You to Kyle Matthews For This Useful Post:

    2k1 (10-17-2013), blkcadi (10-17-2013), King_O_Hill (10-17-2013), sega dude (10-17-2013)

  5. #4
    Super Duper Moderator blkcadi's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    31,210
    Thanks
    3,930
    Thanked 10,206 Times in 6,212 Posts

    ^Thanks buddy.

  6. #5
    Thanks Kyle!

    Check out WW2 for iOS 8 - Widget-Weather 2.0

  7. #6
    Owner / Founder - ModMyi
    aka poetic_folly
    Kyle Matthews's Avatar
    Join Date
    May 2007
    Location
    Tampa, Florida, United States
    Posts
    8,484
    Thanks
    570
    Thanked 4,809 Times in 1,229 Posts

    Most 64bit packages should be backwards compatible. There will be some exceptions, but that's still being looked at.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  8. #7
    Sug Luv Super Moderator 2k1's Avatar
    Join Date
    Jan 2011
    Location
    Hammond Louisiana
    Posts
    34,059
    Thanks
    1,815
    Thanked 7,065 Times in 4,206 Posts

    Kyle I know it's off topic but iOS 7 seems to mess up the app alot with banning spam and all do you know this?

  9. #8
    Super Duper Moderator blkcadi's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    31,210
    Thanks
    3,930
    Thanked 10,206 Times in 6,212 Posts

    ^ Yeah, I should have mentioned that to him also when I emailed him today about this thread.

  10. #9
    I duplicated my target and made the new target 64-bit. I didn't make my original target 64-bit because, as of now, you can only have a deployment target of iOS 7.0 when you add the arm64 architecture and I want to maintain my current compatibility. According to this page on the Apple Developer website, a future version of Xcode will support 32 bit runtime on iOS6 and 64 bit on iOS 7.
    Last edited by sega dude; 10-17-2013 at 04:16 PM.
    Try my Web Browser, Brandsonic Web! Download today from the ModMyi repo! Also available for Mac, Windows, and Android!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •