+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iphone 3.0 camera roll all black thumbnails.

is a discussion within the

iPhone / iPod Touch SDK | Development Discussion

forums, a part of the

3rd Party Apps For iPhone | iPod Touch

section;
Well i have one tiny problem with iphone 3.0 beta 1 and 2. whenever i back up my phone with any backup the camera roll thumbnails are all black but
...
  1. #1
    iPhone? More like MyPhone matt.superman's Avatar
    Join Date
    Oct 2007
    Location
    SL,UT
    Posts
    167
    Thanks
    6
    Thanked 15 Times in 10 Posts

    Exclamation iphone 3.0 camera roll all black thumbnails.
    Well i have one tiny problem with iphone 3.0 beta 1 and 2. whenever i back up my phone with any backup the camera roll thumbnails are all black but it only happens the the camera roll. i have tried utunephoto and that seems to have no effect at resolving the solution. any help with this or does any one else have this problem? thanks in advance for the help.
    Last edited by matt.superman; 04-07-2009 at 09:59 PM. Reason: update w/pic
    You must submit to testing before I can assist you.

  2. #2
    Green Apple mook2420's Avatar
    Join Date
    Apr 2008
    Location
    NOVA
    Posts
    68
    Thanks
    2
    Thanked 4 Times in 2 Posts

    did you ever sort this out? I recently have acquired 3.0 beta 5 and also am having this strange black thumbnail problem. The images are there it is just in the preview screen that they are missing / black. I tried resetting permissions, etc... making sure they were chown mobile:mobile... nothing... should the images/thm files be 644 or 775 or 777? I have tried most combinations and no luck.

  3. #3
    iPhone? More like MyPhone matt.superman's Avatar
    Join Date
    Oct 2007
    Location
    SL,UT
    Posts
    167
    Thanks
    6
    Thanked 15 Times in 10 Posts

    i tried every which way and gave up. I just saved them and uploaded them using itunes and made a folder and moved on. it saved camera roll loading time and its all there. i would recommend jus moving on.
    You must submit to testing before I can assist you.

  4. #4
    Green Apple mook2420's Avatar
    Join Date
    Apr 2008
    Location
    NOVA
    Posts
    68
    Thanks
    2
    Thanked 4 Times in 2 Posts

    Quote Originally Posted by matt.superman View Post
    i tried every which way and gave up. I just saved them and uploaded them using itunes and made a folder and moved on. it saved camera roll loading time and its all there. i would recommend jus moving on.
    Yeah, I ended up doing the same unfortunately... they changed the way the images and thumbs are saved with 3.0

  5. #5
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Help!!!
    i too have this problem, all my camera roll pictures i took with my iphone pre-3.0 show up black. however screenshots ive taken on my iphone show up. and also if i take a new picture is shows up as the new thumbnail for the camera roll but when i go into camera roll it isnt there, not even selectable as a black thumbnail like the old ones are. I also tried syncing to iphoto to view the new photos i have taken and it doesnt show up there either. This is really annoying as it is disabling my camera function all together which also makes mms partly useless. please help!!! thanks

  6. #6
    What's Jailbreak?
    Join Date
    Nov 2008
    Posts
    1
    Thanks
    0
    Thanked 1 Time in 1 Post
    I noticed this, too when I moved my entire photo collection back to my iPhone after updating to 3.0 after a restore. I used DiskAid and noticed that when I took a new picture the way the new 3.0 OS stores the photos and thumbnails is different.

    Before the .JPG and .THM files were stored in the 100APPLE directory. When I took a new picture, it stored the .JPG file in the 100APPLE directory. There is a .MISC directory in the 100APPLE directory that now stores the .THM and a new .BTH file. I simply moved all of my .THM files to this .MISC directory and all my thumbnails show up fine when viewing my old photos on my iPhone.
    Attached Thumbnails Attached Thumbnails iphone 3.0 camera roll all black thumbnails.-window.png  
    Last edited by natrlhy; 06-18-2009 at 11:45 AM.

  7. The Following User Says Thank You to natrlhy For This Useful Post:

    discostar (08-01-2009)

  8. #7
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I looked at DCIM folder i dont dont have a sub directory named .MISC i tried to create one but it said i was unable to create a folder starting with . i am still having the trouble of not being able to locate new photos i take, i cant find them anywhere in DCIM either

  9. #8
    Green Apple mook2420's Avatar
    Join Date
    Apr 2008
    Location
    NOVA
    Posts
    68
    Thanks
    2
    Thanked 4 Times in 2 Posts

    You have a permission issue srodda, are you jailbroken? If so then use the reset permissions in more of Bosspref or SBSettings. Usually even if you have no DCIM folder you can take a photo with the default camera app and it will make a new one. For the problem with the no thumbnails I ended up taking all the JPG files, putting them in a folder and using DiskAid to transfer them, then use FileAid on the phone, or ifile to view/modify/delete them. Starting a new camera roll is all I could end up doing.

  10. #9
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts

    this is still driving me nuts! I'm restoring now to see if that fixes it..... Anybody have any other ideas?

  11. #10
    What's Jailbreak?
    Join Date
    Nov 2008
    Posts
    13
    Thanks
    10
    Thanked 0 Times in 0 Posts

    i just updated {restore so i could jailbreak} and i have black thumbs and no new pics show up in the cam roll. Any fixes for this please?


    Also i cannot delete any photos?????
    Last edited by RockStar199; 06-29-2009 at 10:50 AM.

  12. #11
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    4
    Thanks
    0
    Thanked 3 Times in 2 Posts

    Default Partial Solution
    After creating a .MISC folder inside /private/var/mobile/Media/DCIM/100APPLE/ folder, and moving all the .THM files into it, i can now see all the thumbnails of my previously taken photos.

    Unfortunately, i still can't take any new photos. Every new picture i take shows up as a black picture, and doesn't get added up to the camera roll library. I tried fixing my user permissions using Sbsettings, but still no luck.

    Any ideas anyone ?

    Solved !

    A. Using WINSCP, create a .MISC folder inside /private/var/mobile/Media/DCIM/100APPLE/

    B. Move all .THM files from /private/var/mobile/Media/DCIM/100APPLE/ to the new /private/var/mobile/Media/DCIM/100APPLE/.MISC folder

    C. Set user permissions on folder /private/var/mobile/Media/DCIM to 755, while selecting the option "Set group, owner and permissions recursively" (so the permissions will be set for all folders under DCIM)

    D. Party on like it's 1999.
    Last edited by theNrg; 06-29-2009 at 04:30 PM. Reason: Automerged Doublepost

  13. The Following 2 Users Say Thank You to theNrg For This Useful Post:

    Deinera (06-29-2009), RockStar199 (07-02-2009)

  14. #12
    What's Jailbreak?
    Join Date
    Sep 2008
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by theNrg View Post
    After creating a .MISC folder inside /private/var/mobile/Media/DCIM/100APPLE/ folder, and moving all the .THM files into it, i can now see all the thumbnails of my previously taken photos.

    Unfortunately, i still can't take any new photos. Every new picture i take shows up as a black picture, and doesn't get added up to the camera roll library. I tried fixing my user permissions using Sbsettings, but still no luck.

    Any ideas anyone ?

    Solved !

    A. Using WINSCP, create a .MISC folder inside /private/var/mobile/Media/DCIM/100APPLE/

    B. Move all .THM files from /private/var/mobile/Media/DCIM/100APPLE/ to the new /private/var/mobile/Media/DCIM/100APPLE/.MISC folder

    C. Set user permissions on folder /private/var/mobile/Media/DCIM to 755, while selecting the option "Set group, owner and permissions recursively" (so the permissions will be set for all folders under DCIM)

    D. Party on like it's 1999.
    So this solves the thumbnail problem brilliantly. However, new photos are still missing. *sigh* Wish I knew where to find those.

    Edit: Seem the only way for me to get things working correctly was to save all of the photos onto my computer's hard drive. Delete them all (but I left the .MISC folder I created) and taking a photo with the default camera (I also have Snapture).

    This seems to have reset everything to working, and even Snapture works correctly too. Not necessarily a fix, but at least there's a way to get it working.
    Last edited by Deinera; 06-29-2009 at 07:02 PM.

  15. #13
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    4
    Thanks
    0
    Thanked 3 Times in 2 Posts

    did u try to reset the user permissions on DCIM ? that solved my camera issue, and i can now retake pictures with it

  16. The Following User Says Thank You to theNrg For This Useful Post:

    RockStar199 (07-02-2009)

  17. #14
    What's Jailbreak?
    Join Date
    Feb 2009
    Posts
    8
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Thanks folks however none of this worked for me, had to restore and setup as new iphone. Tedious but problem solved.

  18. #15
    What's Jailbreak?
    Join Date
    Nov 2008
    Posts
    13
    Thanks
    10
    Thanked 0 Times in 0 Posts

    AHHH yes thank you very much for the fix!!! and you were thanked on forums

  19. #16
    What's Jailbreak?
    Join Date
    Dec 2008
    Posts
    5
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Found out that new version of uTunePhoto that support iphone3.0 has been released. It will fix your cameraroll black icon just only 1-2 clicks. Below is the download link.
    http://www.mangaware.com/Download/uT...hotosSetup.zip

  20. The Following User Says Thank You to se13311 For This Useful Post:

    Keyana (04-03-2011)

  21. #17
    What's Jailbreak?
    Join Date
    Nov 2008
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Lightbulb another solution
    Quote Originally Posted by theNrg View Post
    After creating a .MISC folder inside /private/var/mobile/Media/DCIM/100APPLE/ folder, and moving all the .THM files into it, i can now see all the thumbnails of my previously taken photos.

    Unfortunately, i still can't take any new photos. Every new picture i take shows up as a black picture, and doesn't get added up to the camera roll library. I tried fixing my user permissions using Sbsettings, but still no luck.

    Any ideas anyone ?

    Solved !

    A. Using WINSCP, create a .MISC folder inside /private/var/mobile/Media/DCIM/100APPLE/

    B. Move all .THM files from /private/var/mobile/Media/DCIM/100APPLE/ to the new /private/var/mobile/Media/DCIM/100APPLE/.MISC folder

    C. Set user permissions on folder /private/var/mobile/Media/DCIM to 755, while selecting the option "Set group, owner and permissions recursively" (so the permissions will be set for all folders under DCIM)

    D. Party on like it's 1999.
    This was what I did
    pretty simple but it seems to be working

    A. Using WINSCP, create a .MISC folder inside /private/var/mobile/Media/DCIM/100APPLE/

    B. Move all .THM files from /private/var/mobile/Media/DCIM/100APPLE/ to the new /private/var/mobile/Media/DCIM/100APPLE/.MISC folder

    C. Rename all the extensions .THM to .BTH (always back up the originals, just in case something goes wrong)

    D. Move all .BTH files to the new /private/var/mobile/Media/DCIM/100APPLE/.MISC folder (you going to have both .THM and .BTH in the same folder)

    E. Move all .jpg files from /private/var/mobile/Media/DCIM/100APPLE/ to the new /private/var/mobile/Media/DCIM/100APPLE/

    F. If some pictures doesn't show up try counting them and then open the file Info.plist located in the new /private/var/mobile/Media/DCIM/.MISC

    The file looks like this:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>LastFileGroupNumber-100</key>

    <integer>5</integer>
    </dict>
    </plist>

    and then change the number in between the integer (in this case 5) for the number of your photos plus one (if you going to put 5 pics then change it to 6, if you going to do 10 pics then change it to 11 etc.) always is batter to have that number a little higher than the number of your pics because if is less some pics doesn't show up

    this has been working for me, I hope works for all of you

  22. #18
    What's Jailbreak?
    Join Date
    Nov 2009
    Posts
    2
    Thanks
    0
    Thanked 1 Time in 1 Post
    Default Listing of new solutions!
    I must have spent 2x 8 hour nights on this. It was not quite the solutions found at
    - Apple Forums & iPhone Forums, Mods, Hacks, News, Themes, Downloads, and more! | ModMyi.com
    - iphone 3.0 camera roll all black thumbnails.

    It ended up being that the following dir hierarchy and files are needed:
    Code:
    - /DCIM
      - /.MISC
        - Info.plist
      - /100APPLE
        - /.MISC
          - .BTH and .THM thumbnail files for each photo
        - .JPG files
    Just as important, and not spelt out anywher:
    ALL FILES AND FOLDERS NEED TO BE OWNED BY 'mobile' USER

    Ex:
    Code:
    Nicks-iPhone:~/Media/DCIM mobile$ ls -la
    total 0
    drwxr-xr-x  4 mobile mobile  136 Aug 27 02:35 ./
    drwxr-xr-x 11 mobile mobile  476 Oct 30 18:40 ../
    drwxr-xr-x  2 mobile mobile  170 Nov 12 00:36 .MISC/
    drwxr-xr-x  3 mobile mobile 6018 Nov 12 00:41 100APPLE/
    
    Nicks-iPhone:~/Media/DCIM/100APPLE mobile$ ls -la
    total 77892
    drwxr-xr-x 3 mobile mobile    6018 Nov 12 00:41 ./
    drwxr-xr-x 4 mobile mobile     136 Aug 27 02:35 ../
    drwxr-xr-x 2 mobile mobile   11900 Nov 12 00:41 .MISC/
    -rw-r--r-- 1 mobile mobile   72622 Mar 13  2009 IMG_0001.JPG
    -rw-r--r-- 1 mobile mobile 2400229 Mar 15  2009 IMG_0002.JPG
    -rw-r--r-- 1 mobile mobile  119552 Mar 19  2009 IMG_0003.JPG
    Use chown as root user, to fix if they are wrong:
    Code:
    chown -v mobile 100APPLE/
    chown -v mobile *

    Also, you have to verify that the Info.plist file has the correct # in the XML. If your jpg files goes up to IMG_0103.JPG, you need to reflect this as so in that file:
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
            <key>LastFileGroupNumber-100</key>
            <integer>103</integer>
    </dict>
    </plist>

    The jpg files that had the root ownerships, were during a certain date range. I think it coincided with my use of the jailbroke-only picture program "Snapture". Maybe the combo of snapture and 3.0 upgrade does it?


    Some Erroneous advice from prior posts

    Seriously great work on here guys. Couldnt have done without u. Some things I noticed that were wrong:

    Quote Originally Posted by theNrg View Post
    C. Set user permissions on folder /private/var/mobile/Media/DCIM to 755, while selecting the option "Set group, owner and permissions recursively" (so the permissions will be set for all folders under DCIM)
    Not the best way to do this. See below listing of my solutions.
    644 are the normal permissions that seem to be (read write for owner, read for group, read for everyone).

    Wrong permissions are 755 (read write execute for owner, read execute for group, read execute for everyone), which opens up security holes. Something can now write and run a virus executable to those directories. Though doubtful, its not safe.
    Be careful of security settings you dont know what they mean.


    Quote Originally Posted by alquse View Post
    F. If some pictures doesn't show up try counting them and then open the file Info.plist located in the new /private/var/mobile/Media/DCIM/.MISC

    The file looks like this:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>LastFileGroupNumber-100</key>

    <integer>5</integer>
    </dict>
    </plist>

    and then change the number in between the integer (in this case 5) for the number of your photos plus one (if you going to put 5 pics then change it to 6, if you going to do 10 pics then change it to 11 etc.) always is batter to have that number a little higher than the number of your pics because if is less some pics doesn't show up
    WRONG, please see listing of solutions below. You do not count the number of files. You use the last file name-number.


    -Nick Yeates-
    Homepage [Nick Yeates -dot- com]
    Last edited by nyeates1; 11-11-2009 at 11:41 PM. Reason: Re-arranged my double-posting to look better

  23. #19
    iPhone? More like MyPhone ARCHA1C's Avatar
    Join Date
    Jan 2008
    Posts
    118
    Thanks
    8
    Thanked 13 Times in 8 Posts

    Default Black thumbnails, no new photos
    I was having the "black thumbnail" issue on my camera roll. I was also having issues with new photos not showing in my camera roll.

    Ultimately, the fix was VERY simple...

    First, I connected my iPhone to my laptop and copied all of the photos off.

    Using the iFile app (downloaded via Cydia)
    I navigated to var/Mobile/Medua
    Click "Edit" and select the "DCIM" directory.
    DELETE the DCIM folder (use the default trash can icon at the bottom)

    Now exit iFile, and launch the camera app.
    It may crash a couple of times. That's because it is constructing a new DCIM directory with all of the default files and settings.

    Your camera and camera roll should be operating normally now.

  24. #20
    What's Jailbreak?
    Join Date
    Apr 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    PROBLEM SOLVE IN MY IPHONE :
    IN SIMPLE STEPS:
    1. USE WINSSH AND GO TO /Var/mobile/Media/DCIM/100APPLE/ and rename folder .MISC to *.MISC
    2. CREATE NEW FOLDER .MISC at /Var/mobile/Media/DCIM/100APPLE/ and copy all files from *.MISC TO NEW .MISC
    3. THATS ALL....

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts