+ Reply
Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Making apps 1.1.3 compatible

is a discussion within the

iPhone / iPod Touch SDK | Development Discussion

forums, a part of the

3rd Party Apps For iPhone | iPod Touch

section;
Does anyone know what is making many of the apps allegedly incompatible with the new firmware? I know that apps that use the root dir will need to use the
...
  1. #1
    JLA
    JLA is offline
    Developer
    Join Date
    Oct 2007
    Posts
    224
    Thanks
    1
    Thanked 31 Times in 24 Posts

    Default Making apps 1.1.3 compatible
    Does anyone know what is making many of the apps allegedly incompatible with the new firmware? I know that apps that use the root dir will need to use the mobile dir instead, but what else will need to be changed? I haven't yet upgraded, and I'd like to make sure Garf and Funiculus work.
    JLA

  2. #2
    iPhone? More like MyPhone ToxicFTW's Avatar
    Join Date
    Aug 2007
    Location
    OKC, OK
    Posts
    128
    Thanks
    19
    Thanked 21 Times in 13 Posts

    Garf works on 1.1.3. I didn't try Funiculus.

    32GB iPod Touch 2nd Gen

  3. #3
    Developer
    Join Date
    Jan 2008
    Posts
    16
    Thanks
    1
    Thanked 2 Times in 1 Post
    And of course, I guess all those apps using /.../LaunchDaemons will stop working. Moreover, apps using the IOKit (see my posting regarding waking the iPhone from sleep) won't work. Not sure what workarounds would be necessary.

  4. #4
    Livin the iPhone Life sziklassy's Avatar
    Join Date
    Jan 2008
    Location
    Iowa (ISU for Vet School!)
    Posts
    3,920
    Thanks
    69
    Thanked 310 Times in 264 Posts

    I am not a developer, but most apps that are not working have to do with the folders they are in I believe. I could be way off, but from what I read this seems to be the case. As for stuff running in the background (daemons) there may not be any easy fix if Apple just straight up blocked them. I suspect that most apps were not disabled necessarily on purpose by apple, it was just the nature of the update and getting ready for the SDK.
    ------------------------------------------------------------------------------------------------------------------------------------------------------------------
    I once prayed to God for an iPhone, but quickly found out He didn't work that way...so I stole an iPhone and prayed for His forgiveness.

    A dog is the only thing on earth that loves you more than you love yourself. - Josh Billings

  5. #5
    JLA
    JLA is offline
    Developer
    Join Date
    Oct 2007
    Posts
    224
    Thanks
    1
    Thanked 31 Times in 24 Posts

    Does anyone know if there is now a sudo command? Would a 3rd party have to add that manually?

    Also, how will some apps have the ability to access IOKit and some not? I'm not too familiar with the whole Unix permissions system...is there a file in which this is specified? Could the permissions on the frameworks be changed?
    JLA

  6. #6
    Moderator Nicholas Knight's Avatar
    Join Date
    Dec 2007
    Location
    Virginia Beach, Va
    Posts
    1,243
    Thanks
    79
    Thanked 310 Times in 170 Posts

    could you just change them using WinSCP?

  7. #7
    iPhone? More like MyPhone screamo's Avatar
    Join Date
    Jan 2008
    Location
    Vegas
    Posts
    117
    Thanks
    12
    Thanked 10 Times in 7 Posts

    i just tried using WINSCP and it seems that mobile is only a shortcut to root. I'm trying to get customize and summerboard onto my ipod but i'm not a developer and i have no clue what i'm doing. I did read somewhere that someone got summerboard working on 1.1.3. by just tricking your touch by changing the .plist file somewhere where it says its 1.1.3. to 1.1.2. but i have not tried this yet and this guy sounded fishy and all over the place.

    Also, off topic kind of but when i used the new brickr to upgrade my touch, it went perfectly but my ipod searches for a network/service and fails. Can i stop this in any way?

  8. #8
    Retired Moderator CyberGreg's Avatar
    Join Date
    Jul 2007
    Posts
    1,096
    Thanks
    58
    Thanked 207 Times in 138 Posts

    Issue the chmod +s to your app and it will run with "root" permissions instead of with "mobile" permissions.
    White 3G

  9. #9
    What's Jailbreak? drpeppir's Avatar
    Join Date
    Aug 2007
    Posts
    19
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Quote Originally Posted by CyberGreg View Post
    Issue the chmod +s to your app and it will run with "root" permissions instead of with "mobile" permissions.
    can you giv an example of how to type this in for say nes.app

    chmod +s nes.app ? in term

  10. #10
    Retired Moderator CyberGreg's Avatar
    Join Date
    Jul 2007
    Posts
    1,096
    Thanks
    58
    Thanked 207 Times in 138 Posts

    Quote Originally Posted by drpeppir View Post
    can you giv an example of how to type this in for say nes.app

    chmod +s nes.app ? in term
    From the NES.app folder;

    chmod +s NES

    From /

    chmod +s /Applications/NES.app/NES

    I would guess that you might have to revise / update the ROMs folder as well.
    White 3G

  11. #11
    Green Apple silverzz28's Avatar
    Join Date
    Nov 2007
    Posts
    61
    Thanks
    2
    Thanked 1 Time in 1 Post
    I'm on 1.1.3 and used the installer app alot. It's very frustrating that you have to download each app to see if they work.

    I really miss (send a song) lets you send the songs to your ringtones
    swirly mms
    iradio
    callD
    SMS Notifier
    iSMS or SMSD

    Anyone have any luck with this. I took the Dev teams advice and used their way to upgrade to 1.1.3. From reading it looks like NATEs allows more working apps

  12. #12
    Green Apple
    Join Date
    Jan 2008
    Posts
    53
    Thanks
    1
    Thanked 0 Times in 0 Posts

    I upgraded to 1.1.3 some times it sucks but its ok every works minus send song which was a good program , need that back or something close to it , but other than that the only thing that doesn't work is you tube

  13. #13
    What's Jailbreak?
    Join Date
    Dec 2007
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    nes app is looking for roms and the i put the roms in the folder
    what should i do to get nes to work in 1.1.3

  14. #14
    JLA
    JLA is offline
    Developer
    Join Date
    Oct 2007
    Posts
    224
    Thanks
    1
    Thanked 31 Times in 24 Posts

    I used the NateTrue method, and the only problem I had was with the backspace thing, but it was a simple fix.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts