Page 582 of 875 FirstFirst ... 82 482 532 572580581582583584 592 632 682 ... LastLast
Results 11,621 to 11,640 of 17493

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: UniAW6.0 for iph4 & iph5

  1. #11621
    Quote Originally Posted by signori View Post
    Hey Marty. I am using your WidgetWeather UniAW6.4 that can change between yahoo and accuweather. I was wonder if you every found out why sometimes accuweather goes blank in some areas. For example When I am in stouffville the yahoo weather works but when I switch to accuweather it goes blank and undefined. Is there any fix. Thanks.
    Yep. We live close. I was having the same problem in King City. WW reports city as "King" but Accuweather needs "King City".

    Unfortunately it's an Accuweather issue not knowing what city name WW is throwing at it. It happens with any WW theme that also has an Accuweather URL call (ie: for UV Index perhaps). Default is extraLocCity. I'm trying to alter the code so it tries extraLocNeighborhood if extraLocCity comes up blank. But for the life of me, I just can't get it. The only other way to do it that I can think of, is to add a button to the touch menu that will trigger back and fourth. It's an ongoing project for me trying to make it work so I will certainly keep you and everyone else in the thread posted as to the progress

    POST EDITED - Sorry everyone

    Here is a link to the Sudbury XML file: widgetweather

    If anyone is using a WW theme with UV index, try using this file as your XML and it will kill your widget.

    In the XML file, You can see that 'city' & 'extraLocNeighborhood' are both "Sudbury" which works great! But the script is written to use extraLocCity which in this case is "Greater Sudbury" which will not work and kills the widget! That's the process I want to automate. Try one, if nothing, try another, etc...

  2. The Following 3 Users Say Thank You to Marty McFly For This Useful Post:

    Bacardi85 (11-15-2013), King_O_Hill (11-15-2013), The_Durben (11-15-2013)

  3. #11622
    Quote Originally Posted by Marty McFly View Post
    Yep. We live close. I was having the same problem in King City. WW reports city as "King" but Accuweather needs "King City".

    Unfortunately it's an Accuweather issue not knowing what city name WW is throwing at it. It happens with any WW theme that also has an Accuweather URL call (ie: for UV Index perhaps). Default is extraLocCity. I'm trying to alter the code so it tries extraLocNeighborhood if extraLocCity comes up blank. But for the life of me, I just can't get it. The only other way to do it that I can think of, is to add a button to the touch menu that will trigger back and fourth. It's an ongoing project for me trying to make it work so I will certainly keep you and everyone else in the thread posted as to the progress

    POST EDITED - Sorry everyone

    Here is a link to the Sudbury XML file: widgetweather

    If anyone is using a WW theme with UV index, try using this file as your XML and it will kill your widget.

    In the XML file, You can see that 'city' & 'extraLocNeighborhood' are both "Sudbury" which works great! But the script is written to use extraLocCity which in this case is "Greater Sudbury" which will not work and kills the widget! That's the process I want to automate. Try one, if nothing, try another, etc...
    You know this challenge is right up my alley, Marty.. As I'm tweaking with location stuff daily in my widget.. The only variable I don't use is Accuwearher.. Can you PM me the problem version and I'll take a crack at it this weekend.
    Here to help if I can. If I can't I know someone who can!

  4. The Following User Says Thank You to NewdestinyX For This Useful Post:

    Marty McFly (11-15-2013)

  5. #11623
    Quote Originally Posted by NewdestinyX View Post
    You know this challenge is right up my alley, Marty.. As I'm tweaking with location stuff daily in my widget.. The only variable I don't use is Accuwearher.. Can you PM me the problem version and I'll take a crack at it this weekend.
    Hi Grant, you can download "UniAW6.4_LS WW" from page #1 of this thread and use the XML file I posted above and you will see what I mean. Thanks.

  6. #11624
    Quote Originally Posted by Marty McFly View Post
    Hi Grant, you can download "UniAW6.4_LS (WW).theme.zip" from page #1 of the Widget Weather thread (towards the bottom of post #1) and use the XML file I posted above and you will see what I mean. Thanks.
    My first question is - why are you using extraLocCity as your main city anyway..? Or for the Accuweather side? Same question.. Always wondered why Dacal coded the Accuweather side of the widget with extraLocCity. Never shows right city for me.. Always shows my township.
    Here to help if I can. If I can't I know someone who can!

  7. #11625
    Quote Originally Posted by NewdestinyX View Post
    My first question is - why are you using extraLocCity as your main city anyway..? Or for the Accuweather side? Same question.. Always wondered why Dacal coded the Accuweather side of the widget with extraLocCity. Never shows right city for me.. Always shows my township.
    I don't know why extraLocCity is being used in the Accuweather call - that's the way UniAW6.4 was released. I don't think it really matters why though as that's what I'm looking to change. To be specific, here is the code we're dealing with:

    var url = "http://apple.accuweather.com/adcbin/apple/Apple_find_city.asp?location="+escape(obj.extraLoc City)+","+obj.extraLocCountryCode;
    $.get(url, function(data) {
    var us = $(data).find('CityList').attr('us')*1;
    var intl = $(data).find('CityList').attr('intl')*1;
    var extra_cities = $(data).find('CityList').attr('extra_cities')*1;
    var exist = intl + us + extra_cities;
    What I'm looking for.....
    If exist = 0, stop the script, go back up and make the URL call again using extraLocNeighborhood or just obj.city.

  8. #11626
    Quote Originally Posted by Marty McFly View Post
    I don't know why extraLocCity is being used in the Accuweather call - that's the way UniAW6.4 was released. I don't think it really matters why though as that's what I'm looking to change. To be specific, here is the code we're dealing with:



    What I'm looking for.....
    If exist = 0, stop the script, go back up and make the URL call again using extraLocNeighborhood or just obj.city.

    EDIT: I guess UniAW6.4_LS (WW) was changed. I just downloaded the version from page #1 of the WW thread and it no longer has an Accuweather call for UV Index.
    Got it. I think I know the code strand to get done what you want to get done based on your explanation. Good explanation, Marty! But "restarting" the the JSON call won't really be possible, but getting more data from it on the first pass and then doing your comparisons from there might work.

    Remember too that this code was written originally for myLocation which had to do a series of calls to get any city data at all. Why don't we just get the city name data we need from the XML using WW code in the AccuWeather.JS file? We really don't need to get city data from any weather service JSON call at all since it's provided to us by Widget Weather's tweak engine.
    Here to help if I can. If I can't I know someone who can!

  9. #11627
    Quote Originally Posted by NewdestinyX View Post
    Got it. I think I know the code strand to get done what you want to get done based on your explanation. Good explanation, Marty! But "restarting" the the JSON call won't really be possible, but getting more data from it on the first pass and then doing your comparisons from there might work.

    Remember too that this code was written originally for myLocation which had to do a series of calls to get any city data at all. Why don't we just get the city name data we need from the XML using WW code in the AccuWeather.JS file? We really don't need to get city data from any weather service JSON call at all since it's provided to us by Widget Weather's tweak engine.
    Sorry, previous posts edited. It's the "UniAW6.4_LS WW" available on page #1 of this thread that has the Accuweather call. That's the one to download to test with the XML file I posted earlier.

    Not sure you're on the right track but that's ok . I appreciate you trying Grant.
    Accuweather.js file? Not sure what you're talking about here. That exists in the myLocation version of 6.4. For this version Accuweather already makes the call using city data from WW.

  10. #11628
    Quote Originally Posted by Marty McFly View Post
    Sorry, previous posts edited. It's the "UniAW6.4_LS WW" available on page #1 of this thread that has the Accuweather call. That's the one to download to test with the XML file I posted earlier.

    Not sure you're on the right track but that's ok . I appreciate you trying Grant.
    Accuweather.js file? Not sure what you're talking about here. That exists in the myLocation version of 6.4. For this version Accuweather already makes the call using city data from WW.
    Yes I was wrong in referring to the separate location.JS files for AccuWeather and Yahoo. The lock screen you're referring to does indeed use WW to get city data from the XML. What I don't understand in the AccuWeather portion of the code is why it needs to get that "list of cities" from AccuWeather when the city name itself is right in the XML already. I'm sure it has something to do with getting all of the weather data but then I don't understand why that would hamper The widget from displaying the proper city. All city name display should be coming directly from the XML and not go through AccuWeather or Yahoo at all. You only should need the JSON call to AccuWeather for the weather data. Why are we trying to get a city name from AccuWeather in the first place?
    Here to help if I can. If I can't I know someone who can!

  11. #11629
    Quote Originally Posted by NewdestinyX View Post
    Yes I was wrong in referring to the separate location.JS files for AccuWeather and Yahoo. The lock screen you're referring to does indeed use WW to get city data from the XML. What I don't understand in the AccuWeather portion of the code is why it needs to get that "list of cities" from AccuWeather when the city name itself is right in the XML already. I'm sure it has something to do with getting all of the weather data but then I don't understand why that would hamper The widget from displaying the proper city. All city name display should be coming directly from the XML and not go through AccuWeather or Yahoo at all. You only should need the JSON call to AccuWeather for the weather data. Why are we trying to get a city name from AccuWeather in the first place?
    I was going to say let's continue this in PM but other's may find this useful.

    Because Accuweather is weird with city names and we need to make sure it's providing weather info for the right place. My home town is "Barrie" and that is indeed what WW reports in the XML but if we look that up in Accuweather, we get multiple results. How do we know which "Postal" to use:

    http://apple.accuweather.com/adcbin/...ocation=barrie

    Because the script then goes to match state and country code in the given results with your current location to choose the correct "postal" to use. Once a postal has been chosen, the 2nd call for the weather is made:

    http://apple.accuweather.com/adcbin/...ARRIE&metric=0

  12. #11630
    Quote Originally Posted by Marty McFly View Post
    I was going to say let's continue this in PM but other's may find this useful.

    Because Accuweather is weird with city names and we need to make sure it's providing weather info for the right place. My home town is "Barrie" and that is indeed what WW reports in the XML but if we look that up in Accuweather, we get multiple results. How do we know which "Postal" to use:

    http://apple.accuweather.com/adcbin/...ocation=barrie

    Because the script then goes to match state and country code in the given results with your current location to choose the correct "postal" to use. Once a postal has been chosen, the 2nd call for the weather is made:

    http://apple.accuweather.com/adcbin/...ARRIE&metric=0
    Okay - great.. That explains WHY Accuweather needs to go through extra calls to get the right 'weather info' - but it doesn't answer my question as to 'why then' would we rely on <extraLocCity> to be the main city that displays for our main - documentGetElementById that we want to display in the widget? Why can't we simply, for both Yahoo and Accuweather sides of the widget, just access <name> or <city> for the screen displayed city?

    EDITED: Okay - read back through all posts. Our problem isn't in what the widget displays as city.. Right? The problem is WHICH city name is sent to Accuweather. The wrong name - will KILL the widget? Right? Do we know if it's just the presence of the word 'city' in "King City" that's the problem? Or is the presence of 'King' ONLY that's the problem? (the latter will be very much more hard to solve)....

    From what I gather - Accuweather's "list of cities" doesn't include Greater Sudbury or King - and can't find a postal code for those. But it CAN find Sudbury and King City (or whatever).. So as you said - we need to find a way to do another call to Accuweather's List of Cities (this time using <city> from the XML) IF it finds NO postal code match the first time. Codewise - This will require a second JSON call to Accuweather's list of cities as you can't restart a JSON call from my study. Am I on the right track now?

    We should still also change the documentGetElementByID display line in the widget to show <city> and not <extraLocCity>. That's always bugged me about the Accuweather side of the widget.
    Last edited by NewdestinyX; 11-15-2013 at 11:16 AM.
    Here to help if I can. If I can't I know someone who can!

  13. #11631
    Quote Originally Posted by NewdestinyX View Post
    Okay - great.. That explains WHY Accuweather needs to go through extra calls to get the right 'weather info' - but it doesn't answer my question as to 'why then' would we rely on <extraLocCity> to be the main city that displays for our main - documentGetElementById that we want to display in the widget? Why can't we simply, for both Yahoo and Accuweather sides of the widget, just access <name> or <city> for the screen displayed city?
    I'm not sure the connection here. You are talking about something different. You can set the widget to display whatever variable you want. That doesn't have anything to do with the Accuweather call. The Accuweather call needs something to start with - in this case it's using extraLocCity. Doesn't matter if it's using name, city or neighbourhood. I want it to try something else if it comes back blank.

    For example, sometimes 'city' is blank and 'neighbourhood' works. Sometimes 'extraLocCity' has a different variation of the name that Accuweather doesn't like and 'city' works. Sometimes 'neighbourhood' and 'city' are both blank and 'extraLocCity' works. etc, etc. 99% of the time 1 of the 3 variables will work with Accuweather hense the reason I am looking for this functionality.

  14. #11632
    Quote Originally Posted by Marty McFly View Post
    I'm not sure the connection here. You are talking about something different. You can set the widget to display whatever variable you want. That doesn't have anything to do with the Accuweather call. The Accuweather call needs something to start with - in this case it's using extraLocCity. Doesn't matter if it's using name, city or neighbourhood. I want it to try something else if it comes back blank.

    For example, sometimes 'city' is blank and 'neighbourhood' works. Sometimes 'extraLocCity' has a different variation of the name that Accuweather doesn't like and 'city' works. Sometimes 'neighbourhood' and 'city' are both blank and 'extraLocCity' works. etc, etc. 99% of the time 1 of the 3 variables will work with Accuweather hense the reason I am looking for this functionality.
    Reread my post. MUCH edited that you didn't see when you responded here..
    Here to help if I can. If I can't I know someone who can!

  15. #11633
    Quote Originally Posted by NewdestinyX View Post
    Reread my post. MUCH edited that you didn't see when you responded here..
    You are on the right track now in that you completely understand the problem. Yes, if the city name used in the Accuweather call is one that Accuweather does not understand, it will indeed kill the widget. I am looking to have it change the URL variable used to make the call based on another variable WITHIN the call (the 'exist' variable). It blows my mind just thinking about it - lol.

    I'm not sure a second URL call is the way to go. I spoke to Dacal briefly about it (busy guy with a new little member of the family!) He suggested possibly the use of nested for/while loops. I gave it a go but I think it's a bit out of my realm. Maybe we should switch to PM or email now?

    Quote Originally Posted by signori View Post
    Hey Marty. I am using your WidgetWeather UniAW6.4 that can change between yahoo and accuweather. I was wonder if you every found out why sometimes accuweather goes blank in some areas. For example When I am in stouffville the yahoo weather works but when I switch to accuweather it goes blank and undefined. Is there any fix. Thanks.
    Hey Signori. I'm curious to see your XML file from when you are in a place where this happens. Accuweather recognizes "Stouffville" no problem but extraLocCity is probably sending a different name. I'd love to confirm that it is indeed this same problem. If you are at all able to send me a copy of your XML file that would be amazing!

  16. #11634
    Quote Originally Posted by Marty McFly View Post
    You are on the right track now in that you completely understand the problem. Yes, if the city name used in the Accuweather call is one that Accuweather does not understand, it will indeed kill the widget. I am looking to have it change the URL variable used to make the call based on another variable WITHIN the call (the 'exist' variable). It blows my mind just thinking about it - lol.
    I'm not sure a second URL call is the way to go. I spoke to Dacal briefly about it (busy guy with a new little member of the family!) He suggested possibly the use of nested for/while loops. I gave it a go but I think it's a bit out of my realm. Maybe we should switch to PM or email now?
    For/While loops are the newest thing I've begun to tackle - but they are indeed 'pretty deep'. Yes, Dacal - is pretty busy.. hasn't been able to answer a couple of my PM's easier.. but he's done a Herculean task for us all and we just need to leave him alone for a spell. That means - we're on our own, bro!.. LOL!!

    A 2nd and 3rd call will indeed work - though more resource intensive. It's just a matter of how 'lean' you want to make the widget. I will keep reading about FOR/WHILE - but in the mean time will use code that I'm familiar with - even if it requires more resources.

    I'll be in touch in email from here on out, Marty.. All good..

    Grant
    Here to help if I can. If I can't I know someone who can!

  17. #11635
    Love this, thanks Nate!

    Last edited by kai312; 11-15-2013 at 04:03 PM.

  18. The Following 5 Users Say Thank You to kai312 For This Useful Post:

    Bulldog5278 (11-15-2013), Fattone66 (11-15-2013), meth357 (11-21-2013), nateD (11-15-2013), T76 (11-21-2013)

  19. #11636
    Quote Originally Posted by kai312 View Post
    Love this, thanks Nate!

    This looks sweet bro.👍

  20. #11637
    Quote Originally Posted by Fattone66 View Post
    This looks sweet bro.��
    yeah Tone, really liking this!

  21. The Following User Says Thank You to kai312 For This Useful Post:

    Fattone66 (11-15-2013)

  22. #11638
    Quote Originally Posted by kai312 View Post
    yeah Tone, really liking this!
    Great looking as a LS and SB.

  23. #11639
    I'm using both of this, Nate's original LS and this SB Gotta say Nate's mod is one of the best Uniaw mod!

  24. The Following 3 Users Say Thank You to kai312 For This Useful Post:

    Fattone66 (11-15-2013), NewdestinyX (11-15-2013), T76 (05-16-2014)

  25. #11640
    Sorry to go off topic in here Ian but thought some may be interested in supporting one of our own forum members and great guy in the iCommunity with his start up

    CordArmor: Never Replace a Broken iPhone Cable Again! | Indiegogo





    This is from -> View Profile: H3ATEDSS - Apple, iPhone and iPad Forums | ModMyi.com

    I think it's a brilliant idea myself.

  26. The Following 4 Users Say Thank You to The_Durben For This Useful Post:

    Bacardi85 (11-15-2013), Bulldog5278 (11-15-2013), Ian Nicoll (11-15-2013), NewdestinyX (11-15-2013)

Page 582 of 875 FirstFirst ... 82 482 532 572580581582583584 592 632 682 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •