+ Reply
Page 166 of 350 FirstFirst ... 66 116 156164165166167168 176 216 266 ... LastLast
Results 3,301 to 3,320 of 6999

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: [Tweak] iWidgets

is a discussion within the

iPhone 4|4S New Skins / Themes Launches

forums, a part of the

New Skins / Themes Launches

section;
I'm not trying to start anything here, but Grant has expressed here and before that he wants to have "a phone that works consistent with the functionality of a non
...
  1. #3301
    King Kong ain't got nothing on me! King_O_Hill's Avatar
    Join Date
    Apr 2011
    Location
    USA
    Posts
    9,101
    Thanks
    40,321
    Thanked 16,971 Times in 6,196 Posts

    I'm not trying to start anything here, but Grant has expressed here and before that he wants to have "a phone that works consistent with the functionality of a non jailbroken phone". I have tried to explain to him, that this is really not possible, well anything is possible its just not at all realistic, because of the nature of the jailbreak itself. He does not agree with me on this point as he has said on several occasions that software comes down to ones and zeros. While this is ultimately true, as long as humans are writing it, you just can't account for all scenarios, or a jailbreak would be impossible.

    You want you're cake, I know. I get it. Just not possible. Sorry bro, no hard feelings.
    Widget-Weather App Now Available! Also with MyLocation Support!
    Check out the thread here - Widget-Weather
    To install the Widget-Weather app, just go to Cydia and install. This will also remove MyLocation, as it is built in!
    Want to protect your JailBreak! Add this repo http://cydia.myrepospace.com/iLEXiNFO/ & Install "iLEX R.A.T."
    It will allow you to bring your phone back to a fresh jailbroken state!

  2. The Following 4 Users Say Thank You to King_O_Hill For This Useful Post:

    Best01 (03-17-2013), joshlogic (03-17-2013), Simon (03-18-2013), Sk37cH (03-18-2013)

  3. #3302
    What's Jailbreak?
    Join Date
    Feb 2013
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by The.Drifter View Post
    Made a little iWidget for myself and thought I would share it with the community

    I wanted something simple and unobtrusive to display Basic Weather Info and Calendar/Location below the status bar.

    Here is what I came up with.

    Defaults to Weather Display:



    Then touch it to Display Date and Current Location:



    Added a few simple options for the Weather:



    Download here: Drifters Touch Status Date-Weather.zip
    Hey, I changed the city weather code in the options but the weather will not change to my city. Do I need to do anything else other than that inside the files or anything? I'm comfortable editing files so any instructions would be welcomed. Thanks and I really like this a lot!

  4. #3303
    Etch A Sketch Sk37cH's Avatar
    Join Date
    May 2011
    Location
    Oz maaaaaate ;)
    Posts
    1,841
    Thanks
    4,366
    Thanked 6,735 Times in 1,566 Posts

    Not that it's really important to me, but I just tested this several times, through holding home and sleep, also just a standard power off, and cmc.city.temp.city iWidget is updating when I unlock. I tried several scenarios to recreate what is being experienced by some users, and I guess I'm either missing something, or I'm just content with the fact that my phone doesn't look stock. New destiny mentioned something about being limited by not running iconoclasm, or a particular tweak. Limitations are only in the mind of the creator....talented creators will find a way of making the most out of any given situation. I have limited bandwidth, so I can't go around downloading every vector pack, just to find the right glyph, so I draw them myself... Limit breached, and avoided I understand that the focus here is to isolate the problem, but like king said, there's just too many variables, and at this early stage of iOS6 development, there's more important issues than this. Thank you.

  5. The Following 2 Users Say Thank You to Sk37cH For This Useful Post:

    Krima (03-18-2013), meth357 (11-23-2013)

  6. #3304
    Developer eldwin's Avatar
    Join Date
    May 2012
    Location
    Singapore
    Posts
    75
    Thanks
    344
    Thanked 565 Times in 73 Posts

    Given that the tweak doesn't know the network access pattern of each widget, here's a suggestion. For the first 30 seconds of initialization, you could perhaps try to load the data every 2 - 5 seconds and stop when a result is received instead of timeouts. After which you use the normal refresh interval.

  7. The Following 6 Users Say Thank You to eldwin For This Useful Post:

    King_O_Hill (03-18-2013), NewdestinyX (03-18-2013), Simon (03-18-2013), Sk37cH (03-18-2013), The.Drifter (03-18-2013), The_Durben (03-18-2013)

  8. #3305
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in Philippines.
    Posts
    4,906
    Thanks
    7,514
    Thanked 19,013 Times in 3,871 Posts

    Please excuse my ignorance, I haven't read too far back these pages and this is the 1st time visiting here for a while now.

    Sorry if this question has been answered but.. are all the people with the "hard re-boot" problem running iconoclasm or does this issue exist without having iconoclasm, I only ask because I have come to hate that tweak, it's always given me issues but others report it's all good!

    I have tried to replicate this "hard re-boot" issue with the my (and Drifters) flipclock iWidget but it loads fine every time, furthermore, if it's a weather widget and it has problems connecting then why wouldn't the widget load but just show no weather info?

    Grant, try with this iWidget, (attached at the end of this post) if it doesn't load then ditch iconoclasm and try again.

    Attached Thumbnails Attached Thumbnails [Tweak] iWidgets-img_0027.png  
    Attached Files Attached Files

    "If it's not broken, I'll fix it till it is"

  9. The Following 3 Users Say Thank You to Ian Nicoll For This Useful Post:

    King_O_Hill (03-18-2013), The.Drifter (03-18-2013), The_Durben (03-18-2013)

  10. #3306
    iPhone? More like MyPhone SHARON1O's Avatar
    Join Date
    Oct 2012
    Location
    ESPAÑA
    Posts
    581
    Thanks
    2,146
    Thanked 460 Times in 262 Posts

    Quote Originally Posted by Simon View Post
    How about bright green?
    possible color purple for me??? lol

    " ​Quiereme cuando menos lo merezca , y sera cuando mas lo necesite " X X X ....

  11. #3307
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,367
    Thanks
    6,732
    Thanked 15,081 Times in 6,936 Posts

    Quote Originally Posted by King_O_Hill View Post
    I'm not trying to start anything here, but Grant has expressed here and before that he wants to have "a phone that works consistent with the functionality of a non jailbroken phone". I have tried to explain to him, that this is really not possible, well anything is possible its just not at all realistic, because of the nature of the jailbreak itself. He does not agree with me on this point as he has said on several occasions that software comes down to ones and zeros. While this is ultimately true, as long as humans are writing it, you just can't account for all scenarios, or a jailbreak would be impossible.

    You want you're cake, I know. I get it. Just not possible. Sorry bro, no hard feelings.
    Exactly

    Quote Originally Posted by SHARON1O View Post
    possible color purple for me??? lol
    Unfortunately name color is set by what usergroup you are in, we don't have a purple usergroup sorry. I can change your title to purple though, and your name to green

  12. The Following 2 Users Say Thank You to Simon For This Useful Post:

    King_O_Hill (03-18-2013), SHARON1O (03-18-2013)

  13. #3308
    iPhone? More like MyPhone SHARON1O's Avatar
    Join Date
    Oct 2012
    Location
    ESPAÑA
    Posts
    581
    Thanks
    2,146
    Thanked 460 Times in 262 Posts

    Quote Originally Posted by Simon View Post
    Exactly



    Unfortunately name color is set by what usergroup you are in, we don't have a purple usergroup sorry. I can change your title to purple though, and your name to green
    ok green lol :Grinny:

    Thank you, very nice jajajajaa me happy
    Last edited by SHARON1O; 03-18-2013 at 05:18 AM.

    " ​Quiereme cuando menos lo merezca , y sera cuando mas lo necesite " X X X ....

  14. The Following User Says Thank You to SHARON1O For This Useful Post:

    Simon (03-18-2013)

  15. #3309
    The BatGirl MamaJaay's Avatar
    Join Date
    Mar 2012
    Location
    @TheMamaJaay
    Posts
    5,176
    Thanks
    4,216
    Thanked 16,676 Times in 4,002 Posts

    Quote Originally Posted by Simon View Post
    Ok. Let me get this straight. The situation is turn wifi off. Reboot. Widgets don't bring up weather, even after signal is obtained. Correct? Yes, I tried it and this happened to me. No, it has never happened to me before because I have never felt the need to turn my wifi off then reboot my phone. There is no need to. Was I able to fix it? Ya, I resprung and weather loaded just fine. Are we really to the point that we complain about some odd instance of events that lead to simply having to respring to fix it? Boy times have changed. These jailbreaks are just too easy these days. Makes us just keep wanting more and more things to just work perfectly without having to put a little work in.
    You wouldn't have liked the 1.X days Grant. Things were rough back then. I remember having to install something called oktoprep on 1.1. Then update to 1.1.2 and run some jailbreak program on my computer that used this to jailbreak again. All to just find out my phone app crashed continuously because apple hadn't quite figured out how to handle phone number formats for non-official carriers, I couldn't blame apple though, they didn't need to since they weren't sold unlocked so I was doing something the phone wasn't supposed to be doing. That was a serious pain to fix. Don't get me started on the virginizing process I had to do to my baseband because of a potential brick inducing IMEI bug apple "caused" with an update to phones that used anysim to unlock. That was some intense stuff doing that, brick back then actually did mean just that. No amount of DFU restores could help.
    Here we are now complaining about the need to have to respring if we happened to turn wifi off and reboot. Jeesh lol.
    Agree... For those of you that weren't around for this... Here is the ORIGINAL 74 step jailbreak.

    http://forums.macrumors.com/showthread.php?t=367115

    NOW take a minute and thank the dev teams. (Just sayin')

  16. The Following 3 Users Say Thank You to MamaJaay For This Useful Post:

    SHARON1O (03-18-2013), Simon (03-18-2013), The.Drifter (03-18-2013)

  17. #3310
    Full Moon Krima's Avatar
    Join Date
    Jul 2011
    Location
    Nashville, Tn
    Posts
    3,071
    Thanks
    3,910
    Thanked 7,615 Times in 2,397 Posts

    Ok now onto a real problem. When I turn on my phone it almost immediately lights up with the Apple logo. On my 4s running 5.1.1 I remember it taking a few more seconds for the Apple logo to show up. Why did Apple change this or is it another "bug" the jailbreak caused? Lets all put our heads together to solve this crucial bug that's afflicting 99.786436% of us on i5.

    I'm gonna test drifters new Iwidget to see if it updates my location. Driving me crazy that some are working while others aren't. Report back soon. I hope everyone has a great Monday. Amen.

  18. The Following 3 Users Say Thank You to Krima For This Useful Post:

    King_O_Hill (03-18-2013), Simon (03-18-2013), Sk37cH (03-18-2013)

  19. #3311
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in Philippines.
    Posts
    4,906
    Thanks
    7,514
    Thanked 19,013 Times in 3,871 Posts

    Oh I don't know, if there is a problem with some users and not with others then I can't blame the guy for trying to find out why, if it were happening to me (which it isn't) and not to some other users, then I wouldn't accept someone telling me just to re-spring, I would have to keep investigating till I found out why, and if Grant is serious about finding out why then start with a fresh JB with nothing installed but iWidgets and take it from their.
    Sorry to disagree with you all but this is just the way I am.

    "If it's not broken, I'll fix it till it is"

  20. The Following 5 Users Say Thank You to Ian Nicoll For This Useful Post:

    King_O_Hill (03-18-2013), NewdestinyX (03-18-2013), SHARON1O (03-18-2013), Simon (03-18-2013), The_Durben (03-18-2013)

  21. #3312
    King Kong ain't got nothing on me! King_O_Hill's Avatar
    Join Date
    Apr 2011
    Location
    USA
    Posts
    9,101
    Thanks
    40,321
    Thanked 16,971 Times in 6,196 Posts

    Quote Originally Posted by Ian Nicoll View Post
    Oh I don't know, if there is a problem with some users and not with others then I can't blame the guy for trying to find out why, if it were happening to me (which it isn't) and not to some other users, then I wouldn't accept someone telling me just to re-spring, I would have to keep investigating till I found out why, and if Grant is serious about finding out why then start with a fresh JB with nothing installed but iWidgets and take it from their.
    Sorry to disagree with you all but this is just the way I am.
    Ian, the problem is with a soft boot (or std power down then power on), not a hard boot. Just throwing that out there if you feel like checking again. Also the widgets are there, just not able to receive any data. So on the one that I use most, I get the overlay, but its just blank, no information of any kind.





    Although, I did notice that the springboard widget is functioning just fine. I typically don't run them, but I have been testing/playing with a new theme and I loaded it up to try it out. Weird.
    Last edited by King_O_Hill; 03-18-2013 at 08:13 AM.
    Widget-Weather App Now Available! Also with MyLocation Support!
    Check out the thread here - Widget-Weather
    To install the Widget-Weather app, just go to Cydia and install. This will also remove MyLocation, as it is built in!
    Want to protect your JailBreak! Add this repo http://cydia.myrepospace.com/iLEXiNFO/ & Install "iLEX R.A.T."
    It will allow you to bring your phone back to a fresh jailbroken state!

  22. The Following 3 Users Say Thank You to King_O_Hill For This Useful Post:

    Ian Nicoll (03-18-2013), NewdestinyX (03-18-2013), SHARON1O (03-18-2013)

  23. #3313
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,615
    Thanks
    3,991
    Thanked 8,815 Times in 4,431 Posts

    Quote Originally Posted by Ian Nicoll View Post
    Oh I don't know, if there is a problem with some users and not with others then I can't blame the guy for trying to find out why, if it were happening to me (which it isn't) and not to some other users, then I wouldn't accept someone telling me just to re-spring, I would have to keep investigating till I found out why, and if Grant is serious about finding out why then start with a fresh JB with nothing installed but iWidgets and take it from their.
    Sorry to disagree with you all but this is just the way I am.
    Thank you, Ian! Someone who "gets it". But the issue presents with "cold" (soft) boot, Ian, not hard.

    But everyone else's point about 'level of severity' of this 'bug' I can see their points too. I was not around in the 74 step jailbreak days. :-) The only reason I kept going with this particular one was that, unlike some of my other "unique to me" issues, this particular weirdness is common to more people than it is not. And many people don't keep Wi-Fi on on their phones all day for battery drain issues. And many of us also turn our phones off at night after charging.

    Please remember, some are getting confused, this only occurs after a cold reboot (phone all the way off using power off slider - then back on). Some started talking about hard reboot and hard reset. The widgets all work after a hard reset - that is not the issue that's being spoken about here.

    I am happy to do my simple respring if necessary. But please don't call this a "Grants problem ". That's the "easy way out" that a lot of people around here like to take sometimes. As of now 15 people have said it happens to them every time from a coldboot (they haven't told us whether their Wi-Fi is on or off, for me it happens whether Wi-Fi is on or not) and only 5 of you have said the widgets load immediately. This is not "NewdestinyX issue". It's a bug, gang.
    Last edited by NewdestinyX; 03-18-2013 at 08:10 AM.
    Here to help if I can. If I can't I know someone who can!

  24. #3314
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,367
    Thanks
    6,732
    Thanked 15,081 Times in 6,936 Posts

    Quote Originally Posted by Ian Nicoll View Post
    Oh I don't know, if there is a problem with some users and not with others then I can't blame the guy for trying to find out why, if it were happening to me (which it isn't) and not to some other users, then I wouldn't accept someone telling me just to re-spring, I would have to keep investigating till I found out why, and if Grant is serious about finding out why then start with a fresh JB with nothing installed but iWidgets and take it from their.
    Sorry to disagree with you all but this is just the way I am.
    No apologies necessary for disagreeing. I can certainly understand the need to figure something out and try and fix it. I just think in this case the reason has been explained and a simple work around is available. Was trying to say back in the early days of jailbreaking we would have killed for such an easy "fix" lol

    Quote Originally Posted by NewdestinyX View Post
    Thank you, Ian! Someone who "gets it". But the issue presents with "cold" (soft) boot, Ian, not hard.

    But everyone else's point about 'level of severity' of this 'bug' I can see their points too. I was not around in the 74 step jailbreak days. :-) The only reason I kept going with this particular one was that, unlike some of my other "unique to me" issues, this particular weirdness is common to more people than it is not. And many people don't keep Wi-Fi on on their phones all day for battery drain issues. And many of us also turn our phones off at night after charging.

    Please remember, some are getting confused, this only occurs after a cold reboot (phone all the way off using power off slider - then back on). Some started talking about hard reboot and hard reset. The widgets all work after a hard reset - that is not the issue that's being spoken about here.

    I am happy to do my simple respring if necessary. But please don't call this a "Grants problem ". That's the "easy way out" that a lot of people around here like to take sometimes. As of now 15 people have said it happens to them every time from a coldboot (they haven't told us whether their Wi-Fi is on or off, for me it happens whether Wi-Fi is on or not) and only 5 of you have said the widgets load immediately. This is not "NewdestinyX issue". It's a bug, gang.
    Nope, not a "Grant problem". Definitely real, happened to me. Was just trying to add some "perspective" to the situation.

  25. The Following 3 Users Say Thank You to Simon For This Useful Post:

    Ian Nicoll (03-18-2013), King_O_Hill (03-18-2013), meth357 (11-23-2013)

  26. #3315
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,615
    Thanks
    3,991
    Thanked 8,815 Times in 4,431 Posts

    Quote Originally Posted by Simon View Post
    No apologies necessary for disagreeing. I can certainly understand the need to figure something out and try and fix it. I just think in this case the reason has been explained and a simple work around is available. Was trying to say back in the early days of jailbreaking we would have killed for such an easy "fix" lol
    Quote Originally Posted by Simon View Post
    Nope, not a "Grant problem". Definitely real, happened to me. Was just trying to add some "perspective" to the situation.
    Your points are well taken, Simon. Thanks. But it's getting to a point around here where a guy will get jumped on (told to "deal with it") when just asking a question about a bug he's experiencing and finding out it's more than just him experiencing it... .. Jes' ..... sayin'.......
    I don't need lectures on the 'bad ole days'. Help - or don't reply, people.
    Last edited by NewdestinyX; 03-18-2013 at 08:18 AM.
    Here to help if I can. If I can't I know someone who can!

  27. #3316
    King Kong ain't got nothing on me! King_O_Hill's Avatar
    Join Date
    Apr 2011
    Location
    USA
    Posts
    9,101
    Thanks
    40,321
    Thanked 16,971 Times in 6,196 Posts

    Quote Originally Posted by eldwin View Post
    Given that the tweak doesn't know the network access pattern of each widget, here's a suggestion. For the first 30 seconds of initialization, you could perhaps try to load the data every 2 - 5 seconds and stop when a result is received instead of timeouts. After which you use the normal refresh interval.
    Not a bad idea for a fail safe fix bro!
    Widget-Weather App Now Available! Also with MyLocation Support!
    Check out the thread here - Widget-Weather
    To install the Widget-Weather app, just go to Cydia and install. This will also remove MyLocation, as it is built in!
    Want to protect your JailBreak! Add this repo http://cydia.myrepospace.com/iLEXiNFO/ & Install "iLEX R.A.T."
    It will allow you to bring your phone back to a fresh jailbroken state!

  28. The Following User Says Thank You to King_O_Hill For This Useful Post:

    Ian Nicoll (03-18-2013)

  29. #3317
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,367
    Thanks
    6,732
    Thanked 15,081 Times in 6,936 Posts

    Quote Originally Posted by NewdestinyX View Post
    Your points are well taken, Simon. Thanks. But it's getting to a point around here where a guy will get jumped on (told to "deal with it") when just asking a question about a bug he's experiencing and finding out it's more than just him experiencing it... .. Jes' ..... sayin'.......
    I don't need lectures on the 'bad ole days'. Help - or don't reply, people.
    You were helped. MJ explained the reasoning behind it pretty well I would say. If you, her or anyone else wants to pursue it further to find a better solution then a respring by all means go for it. I won't stop sharing my opinion and my past experiences though just because you think I am lecturing you. I am entitled to my opinion just as much as you are yours.

  30. The Following 4 Users Say Thank You to Simon For This Useful Post:

    GUNNY29 (03-18-2013), Ian Nicoll (03-18-2013), King_O_Hill (03-18-2013), SHARON1O (03-18-2013)

  31. #3318
    ----NewD 2.0---- NewdestinyX's Avatar
    Join Date
    Jan 2012
    Posts
    9,615
    Thanks
    3,991
    Thanked 8,815 Times in 4,431 Posts

    Quote Originally Posted by eldwin View Post
    Given that the tweak doesn't know the network access pattern of each widget, here's a suggestion. For the first 30 seconds of initialization, you could perhaps try to load the data every 2 - 5 seconds and stop when a result is received instead of timeouts. After which you use the normal refresh interval.
    Thanks, Eldwin, for the "productive" input. Wish I were coder to try it out. Drifter? King?

    Quote Originally Posted by Simon View Post
    You were helped. MJ explained the reasoning behind it pretty well I would say. If you, her or anyone else wants to pursue it further to find a better solution then a respring by all means go for it. I won't stop sharing my opinion and my past experiences though just because you think I am lecturing you. I am entitled to my opinion just as much as you are yours.
    I wasn't referring to you Simon. You are always helpful - as was MJ in her post. Now Ian and Eldwin. But how many other posts were essentially saying - Grant, deal with it. It's just a friggin respring..
    Last edited by NewdestinyX; 03-18-2013 at 08:26 AM.
    Here to help if I can. If I can't I know someone who can!

  32. #3319
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,367
    Thanks
    6,732
    Thanked 15,081 Times in 6,936 Posts

    Quote Originally Posted by NewdestinyX View Post
    Thanks, Eldwin, for the "productive" input. Wish I were coder to try it out. Drifter? King?

    I wasn't referring to you Simon. You are always helpful - as was MJ in her post. Now Ian and Eldwin. But how many other posts were essentially saying - Grant, deal with it. It's just a friggin respring..
    Could have sworn "I don't need lectures on the 'bad ole days'." was referring to me. But ok, if you say so

    Btw, I wouldn't call them "bad" ol days. That virginizing baseband thing was one of the more intense and scary things I have ever done with a iPhone. Was tons of FUN

  33. The Following 2 Users Say Thank You to Simon For This Useful Post:

    King_O_Hill (03-18-2013), NewdestinyX (03-18-2013)

  34. #3320
    iPhone? More like MyPhone SHARON1O's Avatar
    Join Date
    Oct 2012
    Location
    ESPAÑA
    Posts
    581
    Thanks
    2,146
    Thanked 460 Times in 262 Posts

    Be calm guys relax and enjoy the day kisses

    " ​Quiereme cuando menos lo merezca , y sera cuando mas lo necesite " X X X ....

  35. The Following 5 Users Say Thank You to SHARON1O For This Useful Post:

    Ian Nicoll (03-18-2013), King_O_Hill (03-18-2013), NewdestinyX (03-18-2013), Simon (03-18-2013), The.Drifter (03-18-2013)


Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts