+ Reply
Page 58 of 136 FirstFirst ... 8 485657585960 68 108 ... LastLast
Results 1,141 to 1,160 of 2706

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: GPS Based HTML Lockscreen Weather Theme

is a discussion within the

iPhone 4|4S New Skins / Themes Launches

forums, a part of the

New Skins / Themes Launches

section;
Originally Posted by King_O_Hill Try this to change your date format Open "Date Time. js " change this line: var dateMonth = monthname[monthnum] + " " + this_date; to this:
...
  1. #1141
    Troll Ramses2's Avatar
    Join Date
    May 2008
    Location
    Nancy, France
    Posts
    2,030
    Thanks
    1,845
    Thanked 1,440 Times in 707 Posts

    Quote Originally Posted by King_O_Hill View Post
    Try this to change your date format

    Open "Date Time.js"
    change this line:
    var dateMonth = monthname[monthnum] + " " + this_date;

    to this:
    var dateMonth = this_date + " " + monthname[monthnum];

    not sure about the sunrise/sunset or the am/pm
    Thank's for the date format.

    But in my config.js, var ampm = false; and i have the time in ampm format ??

  2. #1142
    CHG128 和平與愛 chg128's Avatar
    Join Date
    Jan 2008
    Location
    KL-UK
    Posts
    1,872
    Thanks
    4,324
    Thanked 4,679 Times in 1,212 Posts

    Quote Originally Posted by Ramses2 View Post
    Thank's for the date format.

    But in my config.js, var ampm = false; and i have the time in ampm format ??
    because dont have 24h blackflipclock image ! i think this is the answer ...........

  3. #1143
    Troll Ramses2's Avatar
    Join Date
    May 2008
    Location
    Nancy, France
    Posts
    2,030
    Thanks
    1,845
    Thanked 1,440 Times in 707 Posts

    Quote Originally Posted by chg128 View Post
    because dont have 24h blackflipclock image ! i think this is the answer ...........
    So I can not have the 24h ?

  4. #1144
    My iPhone is a Part of Me idle0095's Avatar
    Join Date
    Apr 2008
    Posts
    513
    Thanks
    25
    Thanked 136 Times in 98 Posts

    What would cause the gps widgets to not work right? Mine isn't updating anymore while driving. It's only updating during the poll I have set for 60 mins. Using flip clock widgets and uniaw gps widget.

  5. #1145
    King Kong ain't got nothing on me! King_O_Hill's Avatar
    Join Date
    Apr 2011
    Location
    USA
    Posts
    9,167
    Thanks
    40,544
    Thanked 17,112 Times in 6,253 Posts

    Quote Originally Posted by idle0095 View Post
    What would cause the gps widgets to not work right? Mine isn't updating anymore while driving. It's only updating during the poll I have set for 60 mins. Using flip clock widgets and uniaw gps widget.
    if you have it set to update every 60 mins, why would you expect it to update sooner?

  6. #1146
    Theme Creator-Animation Coder Coop2009's Avatar
    Join Date
    Mar 2009
    Location
    Ross-on-Wye UK
    Posts
    2,190
    Thanks
    4,432
    Thanked 4,852 Times in 1,572 Posts

    must say this looks very interesting good work will check it out thanks for the share bit late to the party but hey been out for a while :P

  7. The Following 4 Users Say Thank You to Coop2009 For This Useful Post:

    chg128 (04-03-2012), Dacal (04-01-2012), Ian Nicoll (04-01-2012), The_Durben (04-02-2012)

  8. #1147
    My iPhone is a Part of Me idle0095's Avatar
    Join Date
    Apr 2008
    Posts
    513
    Thanks
    25
    Thanked 136 Times in 98 Posts

    Quote Originally Posted by King_O_Hill View Post
    if you have it set to update every 60 mins, why would you expect it to update sooner?
    The widget should update as I drive. It's not. I have it set to 0 for gps only. The 60 mins is just a backup. I expect it to update as I drive like its suppose to. Like it always has.

  9. #1148
    Mudder GUNNY29's Avatar
    Join Date
    Aug 2010
    Posts
    5,431
    Thanks
    4,571
    Thanked 15,586 Times in 4,086 Posts

    Double check to make sure sig change is on and it is also turned on in the location services part in settings.app
    Click My Sig For my auros Mods

  10. #1149
    My iPhone is a Part of Me idle0095's Avatar
    Join Date
    Apr 2008
    Posts
    513
    Thanks
    25
    Thanked 136 Times in 98 Posts

    Quote Originally Posted by GUNNY29 View Post
    Double check to make sure sig change is on and it is also turned on in the location services part in settings.app
    It is.

  11. #1150
    The BatGirl MamaJaay's Avatar
    Join Date
    Mar 2012
    Location
    @TheMamaJaay
    Posts
    5,177
    Thanks
    4,220
    Thanked 16,682 Times in 4,004 Posts

    Quote Originally Posted by idle0095 View Post
    It is.
    Turn sig change off, then on again, then reboot your phone. Always does the trick for me

  12. #1151
    My iPhone is a Part of Me idle0095's Avatar
    Join Date
    Apr 2008
    Posts
    513
    Thanks
    25
    Thanked 136 Times in 98 Posts

    Quote Originally Posted by MamaJaay View Post
    Turn sig change off, then on again, then reboot your phone. Always does the trick for me
    Thanks.

  13. #1152
    Green Apple
    Join Date
    Jan 2012
    Posts
    56
    Thanks
    29
    Thanked 231 Times in 36 Posts

    Quote Originally Posted by idle0095 View Post
    The widget should update as I drive. It's not. I have it set to 0 for gps only. The 60 mins is just a backup. I expect it to update as I drive like its suppose to. Like it always has.
    It should update as you drive but then it depends upon your signal. It uses the device’s cellular radio to determine the user’s location and report changes in that location.

    For more info read Location Awareness Programming Guide

  14. The Following 3 Users Say Thank You to crazyvivek For This Useful Post:

    Dirtstep (04-02-2012), King_O_Hill (04-02-2012), stratnik (04-02-2012)

  15. #1153
    My iPhone is a Part of Me
    Join Date
    Aug 2009
    Posts
    666
    Thanks
    325
    Thanked 2,140 Times in 490 Posts

    Use your iPhone Safari browser to open this page, GPS data and start walking.
    It should show any GPS location change, even if you move a couple of meters.
    Refreshes every 10 seconds.
    It is an old, but now reworked, simple first step of an GPS based theme, which did not work on the Lockscreen, as crazyvivek found out and then created the MyLocation App. It also does not work as a Widget.html. The funny thing is that it works as a LockBackground.html/Widget.html on the iPhone when opened with iFile's web viewer.
    This is a very very basic script, which works without the need of any "outside" add-on, but just not as a lockscreen or widget.
    Last edited by rasputin007; 04-02-2012 at 03:13 AM.

  16. The Following 7 Users Say Thank You to rasputin007 For This Useful Post:

    chg128 (04-03-2012), elilab (04-09-2012), Ian Nicoll (04-02-2012), King_O_Hill (04-02-2012), lostinthemes (04-02-2012), stratnik (04-02-2012), The_Durben (04-02-2012)

  17. #1154
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in Philippines.
    Posts
    4,913
    Thanks
    7,533
    Thanked 19,051 Times in 3,878 Posts

    Quote Originally Posted by idle0095 View Post
    The widget should update as I drive. It's not. I have it set to 0 for gps only. The 60 mins is just a backup. I expect it to update as I drive like its suppose to. Like it always has.
    Quote Originally Posted by MamaJaay View Post
    Turn sig change off, then on again, then reboot your phone. Always does the trick for me
    For weeks now I have been playing with the GPS on widgets and have been trying different methods of refreshing the "UpdateLocation" function (only checks for new coordinates) and have come to one conclusion, every widget I have tried seems to stick now and again, I thought it was because of the widgets having some issue (hence why I was trying different refresh methods) but this is not the case.

    Turning off and on "Sig.Change" updates the "location.txt" file with your current coordinates and then all the widgets I have update within the 20 seconds set for the "UpdateLocation" function - So... the widgets are fine, it seems it's the "My Location" app thats sticking periodically and not updating the text file. Not a big deal but it is a little annoying.

    @ crazy, any chance you could double check the "My Location" app for any errors? Thanks M8.
    Last edited by Ian Nicoll; 04-03-2012 at 03:56 AM.

    "If it's not broken, I'll fix it till it is"

  18. The Following 4 Users Say Thank You to Ian Nicoll For This Useful Post:

    chg128 (04-03-2012), Dirtstep (04-02-2012), stratnik (04-02-2012), The_Durben (04-02-2012)

  19. #1155
    Dalmatinac stratnik's Avatar
    Join Date
    Dec 2010
    Posts
    1,076
    Thanks
    5,880
    Thanked 4,157 Times in 835 Posts

    Quote Originally Posted by Ian Nicoll View Post
    For weeks now I have been playing with the GPS on widgets and have been trying different methods of refreshing the "UpdateLocation" function (only checks for new coordinates) and have come to one conclusion, every widget I have tried seems to stick now and again, I thought it was because of the widgets having some issue (hence why I was trying different refresh methods) but this is not the case.

    Turning off and on "Sig.Change" updates the "location.txt" file with your current coordinates and then all the widgets I have update within the 20 seconds set for the "UpdateLocation" function - So... the widgets are fine, it seems it's the "My Location" app thats sticking periodically and not updating the text file. Not a big deal but it is a little annoying.
    Sometimes when location get stuck, I turn the "GPS on" to update a new location.

  20. #1156
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in Philippines.
    Posts
    4,913
    Thanks
    7,533
    Thanked 19,051 Times in 3,878 Posts

    Quote Originally Posted by stratnik View Post
    Sometimes when location get stuck, I turn the "GPS on" to update a new location.
    lol... Yeah M8, I also turn them all on and off... lol.. just to be sure.

    But I'm not complaining, this sure beats having to change our location code manually, I'm just too much a perfectionist and would love to have it working 100%.
    Last edited by Ian Nicoll; 04-02-2012 at 07:14 PM.

    "If it's not broken, I'll fix it till it is"

  21. The Following User Says Thank You to Ian Nicoll For This Useful Post:

    stratnik (04-03-2012)

  22. #1157
    Dalmatinac stratnik's Avatar
    Join Date
    Dec 2010
    Posts
    1,076
    Thanks
    5,880
    Thanked 4,157 Times in 835 Posts

    The last 150 km can not update the GPS weather
    or notification center weather
    or native weather app (only local weather, the rest is working properly).

  23. #1158
    Modder & Coder Ian Nicoll's Avatar
    Join Date
    Oct 2008
    Location
    From Scotland, live in Philippines.
    Posts
    4,913
    Thanks
    7,533
    Thanked 19,051 Times in 3,878 Posts

    Quote Originally Posted by stratnik View Post
    The last 150 km can not update the GPS weather
    or notification center weather
    or native weather app (only local weather, the rest is working properly).
    Silly question's, but was Sig.Change on? Was GPS set to "true" or "var = 0;" (depending on which you have)
    Does your notification center weather or native weather say "Unknown"?
    If you have the special code in your widget reverting to locale code for Unknown conditions it might have been showing that weather.
    Did you try the Sig.Change on & off during the 150Km?
    What is your update interval set at? I would have thought it would have updated with that before 150Km!
    Sorry to here your having so much trouble M8.
    What do you mean the rest?

    "If it's not broken, I'll fix it till it is"

  24. #1159
    My iPhone is a Part of Me
    Join Date
    Aug 2009
    Posts
    666
    Thanks
    325
    Thanked 2,140 Times in 490 Posts

    I found that MyLocation can be rather inaccurate with my location. When I am at home/garden then MyLocation can place me from the neighbours house, in the middle of a field , simply miles away to the exact pinpoint spot where I am. But I have "thin" coverage (no 3G, no EDGE!).
    That is one problem, inaccurate position.
    Another is the location name, but that is Yahoo Weather's fault as they provide the service and the location name, that can be easily changed by using Google Maps to fetch the location information. Yahoo Weather does not know my village, only the next village and that's the name I see on the screen, but when using Google Map I get my village name.
    This is problem two, wrong location name.
    I knew from my initial research into GPS based weather that just a few lines of javascript will give you the GPS location in a html page. see my previous post, no need for anything else, BUT as crazyvivek also got stuck was that that code does not work on the lockscreen or as a widget, hence his creation of the MyLocation app.
    I have used the above code in my GPS Theme and it works a treat, but only in iFile's web browser. My suspicion is that this is a Winterboard bug, which does not allow LockBackground.html pages access to the GPS chip. I have contacted Saurik, but had no response so far. I don't know if it is Winterboard's fault, it might not be, but it has exactly the same symptoms of scrolling problems in LockBackground.html pages. In the above javascript there is a error function that displays "Failed" if you, for example, don't allow Safari the right to use your location. But on the lockscreen you get nothing , no GPS coordinates and no error message.
    If this is a Winterboard bug and it could be squashed, then there could be some progress in solving my problem one.
    Have to wait and see what Saurik is saying.

  25. The Following 4 Users Say Thank You to rasputin007 For This Useful Post:

    Ian Nicoll (04-03-2012), lostinthemes (04-03-2012), stratnik (04-03-2012), The_Durben (04-03-2012)

  26. #1160
    Dalmatinac stratnik's Avatar
    Join Date
    Dec 2010
    Posts
    1,076
    Thanks
    5,880
    Thanked 4,157 Times in 835 Posts

    Quote Originally Posted by Ian Nicoll View Post
    Silly question's, but was Sig.Change on? Was GPS set to "true" or "var = 0;" (depending on which you have)
    Does your notification center weather or native weather say "Unknown"?
    If you have the special code in your widget reverting to locale code for Unknown conditions it might have been showing that weather.
    Did you try the Sig.Change on & off during the 150Km?
    What is your update interval set at? I would have thought it would have updated with that before 150Km!
    Sorry to here your having so much trouble M8.
    What do you mean the rest?

    I got it after more than 200 km.
    I mean normal weather widget with woeid and in the weather app manually selected cities.
    I do not know why but now works, thank you for your concern Ian.

  27. The Following User Says Thank You to stratnik For This Useful Post:

    Ian Nicoll (04-03-2012)

LinkBacks (?)

  1. 04-12-2013, 02:27 PM
  2. 03-15-2013, 10:09 AM
  3. 08-11-2012, 12:06 AM
  4. 03-03-2012, 12:38 PM

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts