+ Reply
Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Orange UK carrier logo possible fix

is a discussion within the

iPhone 4|4S New Skins / Themes Launches

forums, a part of the

New Skins / Themes Launches

section;
For anyone having problems with this logo I've found a fix, for me anyway. After days pulling my hair out, replacing every orange carrier image with my custom ones etc
...
  1. #1
    What's Jailbreak?
    Join Date
    Jul 2011
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Orange UK carrier logo possible fix
    For anyone having problems with this logo I've found a fix, for me anyway. After days pulling my hair out, replacing every orange carrier image with my custom ones etc etc I luckily stumbled accross this.

    First make sure you have a both shortcut links /var/mobile/Library/Carrier Bundle.bundle and Operator Bundle.bundle which point to /System/Library/Carrier Bundles/Iphone/23433. I had to make the Carrier Bundle.bundle one through Ifile but its easily done. If you have these links and they point to elsewhere then you may have an icpp installed, which I dont know how to fix.

    Make sure you have your mod named correctly in /Library/Themes/Your Theme/Bundles/com.apple.Orange_uk (case specific) and you have images named the following and case specific:
    Default_CARRIER_Orange-UK.png
    [email protected]
    FSO_CARRIER_Orange-UK.png
    [email protected]

    Next, and this is what fixed it for me, install FakeCarrier through cydia. This does not work with Make It Mine so if you have that reset it. Name you carrier in FakeCarrier to Orange UK and voila, your image should now appear; well mine did. The logo does not show up when you open facebook or cydia for some reason, but everything else its fine.

  2. #2
    Livin the iPhone Life
    Join Date
    Jul 2010
    Location
    Wirral UK
    Posts
    1,329
    Thanks
    20,431
    Thanked 1,814 Times in 812 Posts

    I tried this mate but still having problems Im on orange UK iphone4 4.3.3 Could you help me any Thanks

  3. #3
    What's Jailbreak?
    Join Date
    Jul 2011
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by wirral59 View Post
    I tried this mate but still having problems Im on orange UK iphone4 4.3.3 Could you help me any Thanks
    All I can say is the above. Double check your file names, every letter in the names and folders must be named exactly as above. You can post your addon and I can check them for you see if it works on mine. Fake carrier sometimes glitches when you mod a theme that's in use. Try renaming carrier and if it doesn't change hit reset carrier and respring, then name it Orange UK (case specific). Also if you have 2 themes active that change carrier settings they will cancel each other out. Also go into ifile and open up /var/mobile/library is there a folder named operator bundle.bundle? If so hit the arrow on it and see where the link points and let me know

  4. #4
    What's Jailbreak?
    Join Date
    May 2011
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    name your images Default_CARRIER_Orange.png (without the "-UK")
    and you don't have to change the carrier name

  5. #5
    What's Jailbreak?
    Join Date
    Jul 2011
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by 50toto50 View Post
    name your images Default_CARRIER_Orange.png (without the "-UK")
    and you don't have to change the carrier name
    And place them in the Orange_UK.bundle folder? Tried it and it doesn't work. The .plist file in oranges bundle folder the carrier name it uses to point to your custom image is "Orange UK" which is why you need to use fake carrier. And the image it points to also has the UK bit on the end.

  6. #6
    What's Jailbreak?
    Join Date
    May 2011
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    You right that wirk only for french Orange

  7. #7
    iPhone? More like MyPhone gpvecchi's Avatar
    Join Date
    Jan 2010
    Posts
    129
    Thanks
    3
    Thanked 19 Times in 18 Posts

    I can't get logos working on iOS5 final, any idea, please?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts