Page 19 of 130 FirstFirst ... 91718192021 29 69 119 ... LastLast
Results 361 to 380 of 2599

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Creating Themes With Dreamboard

  1. #361
    Theme Creator TheWarlu's Avatar
    Join Date
    Mar 2010
    Location
    Current.plist
    Posts
    337
    Thanks
    203
    Thanked 116 Times in 68 Posts

    We cant be like Wynd, we don't have +3000 thanks yet :-p

    Honestly, follow the instruction from PK link and aside from a possible ldib issue you should be good.

    Ask any questions, I'll share as much knowledge as possible. Once i'm done with the DB wiki, it could be a good idea to add this info to it
    Don't be afraid of the plist... and never giveup...

  2. #362
    My iPhone is a Part of Me scarflaire's Avatar
    Join Date
    Mar 2011
    Location
    Toronto
    Posts
    713
    Thanks
    352
    Thanked 378 Times in 193 Posts

    Awesome, time to do more reading

  3. #363
    Can someone help me with this?
    I want a scroll view on the second page of my theme, and when i type the scrolling code, and then respiring. Instead of enable scrolling, it disappeared the icons that I want to scroll. Any help?

  4. #364
    Theme Creator TheWarlu's Avatar
    Join Date
    Mar 2010
    Location
    Current.plist
    Posts
    337
    Thanks
    203
    Thanked 116 Times in 68 Posts

    Quote Originally Posted by kuanyu View Post
    Can someone help me with this?
    I want a scroll view on the second page of my theme, and when i type the scrolling code, and then respiring. Instead of enable scrolling, it disappeared the icons that I want to scroll. Any help?
    Kuanyu,

    it can either be a question of layer order or if everything goes blank it's some error in your code.

    I would try to minimize your code to see at what point the issues shows (like 1 scrollview, 1 icon) and/or post your code example
    Don't be afraid of the plist... and never giveup...

  5. #365
    no, there's no error with my code's, no blank screen
    I did move the code up to the first place of the plist, so there's no possibility that something is covering the scroll view up. But anyways, my page 2's code without scroll view
    Check your pm for the code
    Last edited by kuanyu; 05-05-2011 at 10:58 AM.

  6. #366
    Theme Creator TheWarlu's Avatar
    Join Date
    Mar 2010
    Location
    Current.plist
    Posts
    337
    Thanks
    203
    Thanked 116 Times in 68 Posts

    And you add your ScrollView around this?

    So you are using a Subview to add these? If you do, all your X,Y coordinates are related to the ScrollView X,Y coordinate

    Ex: If scrollView is X=325 for Page2, then subview X = 0 to stay in page2.

  7. #367
    Thanks! just realize my Frame width is 320. So my icons are covered by the 2nd page, cause my second page's Frame Width is 640! Thanks a lot!

  8. #368
    Theme Creator TheWarlu's Avatar
    Join Date
    Mar 2010
    Location
    Current.plist
    Posts
    337
    Thanks
    203
    Thanked 116 Times in 68 Posts

    Glad to see you found the issue.
    PList can become so big/full sometime, it's easy to miss something like this.
    Don't be afraid of the plist... and never giveup...

  9. #369
    iPhone? More like MyPhone
    Join Date
    Aug 2009
    Location
    Glen Allen, VA
    Posts
    271
    Thanks
    7
    Thanked 127 Times in 65 Posts

    Quote Originally Posted by TheWarlu View Post
    Glad to see you found the issue.
    PList can become so big/full sometime, it's easy to miss something like this.
    I'm on 10k plus lines of code...

  10. #370
    Theme Creator TheWarlu's Avatar
    Join Date
    Mar 2010
    Location
    Current.plist
    Posts
    337
    Thanks
    203
    Thanked 116 Times in 68 Posts

    Quote Originally Posted by kingjust View Post
    I'm on 10k plus lines of code...
    I know the feeling.. My last was 10K+ too

    Although I used a trick that may help everyone (unless they are already doing it). Since it seems we can't put REM in the code (at least my editor removes them when I reload my plist), I added an Extra key
    <key>A-description</key>
    <string></string>

    At the beginning of all my routine to help me out in findings what I was looking for. used "A-" to make sure it was always the 1st entry in the list.
    Don't be afraid of the plist... and never giveup...

  11. #371
    iPhone? More like MyPhone
    Join Date
    Aug 2009
    Location
    Glen Allen, VA
    Posts
    271
    Thanks
    7
    Thanked 127 Times in 65 Posts

    <!-- 'insert ur comment here' -->

    This works perfectly fine, thank me later... Lolol, jk. My plist is littered every where with those lines of code so I can find specific points. I'll take a screen shot and post it when I get home.

  12. #372
    Theme Creator TheWarlu's Avatar
    Join Date
    Mar 2010
    Location
    Current.plist
    Posts
    337
    Thanks
    203
    Thanked 116 Times in 68 Posts

    Quote Originally Posted by kingjust View Post
    <!-- 'insert ur comment here' -->

    This works perfectly fine, thank me later... Lolol, jk. My plist is littered every where with those lines of code so I can find specific points. I'll take a screen shot and post it when I get home.
    No dice... :-(

    The PlistEditor on Windows seems to be removing them on Save/Open.

    I guess I may try to look for a different plist editor although this one warns you when you forgot a closing / which is nice sometime.
    Don't be afraid of the plist... and never giveup...

  13. #373
    iPhone? More like MyPhone
    Join Date
    Aug 2009
    Location
    Glen Allen, VA
    Posts
    271
    Thanks
    7
    Thanked 127 Times in 65 Posts

    Wow, that sucks... I'll send u a copy of the version I have. Maybe that will do the trick.

  14. #374
    Theme Creator TheWarlu's Avatar
    Join Date
    Mar 2010
    Location
    Current.plist
    Posts
    337
    Thanks
    203
    Thanked 116 Times in 68 Posts

    Quote Originally Posted by kingjust View Post
    Wow, that sucks... I'll send u a copy of the version I have. Maybe that will do the trick.
    That would be nice or tell me what software you use, maybe I can download it
    Don't be afraid of the plist... and never giveup...

  15. #375
    iPhone? More like MyPhone
    Join Date
    Aug 2009
    Location
    Glen Allen, VA
    Posts
    271
    Thanks
    7
    Thanked 127 Times in 65 Posts

    Default Screenshot


    Plist editor

    PlistEditor

  16. #376
    Theme Creator TheWarlu's Avatar
    Join Date
    Mar 2010
    Location
    Current.plist
    Posts
    337
    Thanks
    203
    Thanked 116 Times in 68 Posts

    I don't understand. I have the same software. Actually I had 1.0, so I just installed 1.0.2 (1.0.1) and it does the same thing.

    As soon as I save, close the editor, re-open it and reload. They are gone.
    I actually tested with Notepad++ and the comments don't seem to be save at all.

    Maybe it's because i'm on Win7x64?
    Don't be afraid of the plist... and never giveup...

  17. #377
    iPhone? More like MyPhone
    Join Date
    Aug 2009
    Location
    Glen Allen, VA
    Posts
    271
    Thanks
    7
    Thanked 127 Times in 65 Posts

    Can't be cuz i'm on it also. ????? Weird...

  18. #378
    Theme Creator TheWarlu's Avatar
    Join Date
    Mar 2010
    Location
    Current.plist
    Posts
    337
    Thanks
    203
    Thanked 116 Times in 68 Posts

    And if you save your Plist and openit with NotePad or WordPad, you still see them?

  19. #379
    iPhone? More like MyPhone
    Join Date
    Aug 2009
    Location
    Glen Allen, VA
    Posts
    271
    Thanks
    7
    Thanked 127 Times in 65 Posts

    Nope... but to combat that, I saved it to word and saved it. Opened it back up and voila, they were still there. I mean, it's going to be laborsome to copy back and forth, but I think keeping track of where **** is, well is a bit more important... especially with gobs of code. Hey, if you don't mind, check out my video in the themes/skins for ip4. It's called Tronforever (that name is going to change though). I need some critiques and joe shmoe users are not really leaving anything.

    So, MS Word (I have 2010) will save the <!-- --> entries.

    KJ

  20. #380
    i think it has to do with the encoding, i use the same software and it removes the comments, but if i make a comment in notepad++ the comment stays, i think i might just use that from now on..
    Last edited by PhanaticD; 05-06-2011 at 10:57 PM.

Page 19 of 130 FirstFirst ... 91718192021 29 69 119 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •