my ipad had been at 4.2.1 jailbroken and everything was fine.. upgraded to ios5.1.1 the other day because a couple of apps i wanted to install required ios 5 or above, now it will not activate.. i found a couple of tutorials on youtube but they were for getting beta copies of ios5 activated and didnt work. any help or guidance here would be appreciated..

thanks.