Yep! So it's either have SHSHs and downgrade to 4.3.3 to jb, or don't have SHSHs and stay stuck without a jb ...