Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: [WARNING] iPad 2 users DO NOT UPGRADE to iOS 5 (if you are waiting for jailbreak)

  1. #1
    Default [WARNING] iPad 2 users DO NOT UPGRADE to iOS 5 (if you are waiting for jailbreak)
    As I am sure we all know iOS 5 was officially announced today and has been made available to those with dev accounts to install on their devices.

    The following only applies to 3G iPad 2's (GSM/CDMA) wifi models are not affected
    According to MuscleNerd of the iPhone dev team even if you have your shsh files saved for iOS 4.3, 4.3.1, 4.3.2, 4.3.3 you will not be able to downgrade from iOS 5 back to previous firmware versions without a bootrom-level or iboot-level exploit which currently is not available/doesn't exist.

    This happens because there is a baseband update with iOS 5 and when you try to downgrade to 4.3.x you will get an error in iTunes because of not being able to downgrade the baseband. (wifi models don't have baseband thus aren't affected)

    There is no way of knowing when we will see a jailbreak for the iPad 2, but when we do it will probably be before the fall when iOS 5 drops so it will probably require iOS > 5 which you won't be able to roll back to.

    Source
    iClarified - Apple News - Most Devices Can Be Downgraded From iOS 5 If You Have Saved SHSH Blobs
    Last edited by thecrunked; 06-06-2011 at 09:39 PM.

  2. #2
    Livin the iPhone Life Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,265
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    He didn't reference WIFI models... hmmmm.

  3. #3
    Wifi doesn't have a baseband, therefore it cannot be updated. But aren't iPad 2s unlocked anyway? If they are unlocked an updated baseband shouldn't hurt anything anyway.

  4. #4
    Livin the iPhone Life Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,265
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Yeah something is weird... he should have tweeted some more info on the topic.

  5. #5
    Here's an update


    MuscleNerd @JaviMmSs the iPad2-wifi is fine (if you have 4.3.3 blobs) since it won't error out on the baseband step during downgrade
    about 1 hour ago*in reply to JaviMmSs


    MuscleNerd WARNING: iPad2-GSM and iPad2-CDMA owners must stay clear of all 5.0 betas to stay eligible for any potential 4.3.3 JB
    about 1 hour ago

    Looks like wifi users are ok but 3G iPad 2s are SOL

  6. #6
    if the wifi versions can downgrade then why wouldn't the the 3g versions be able to?

  7. #7
    Because the 3G version gets a baseband update when upgrading from 4.3.x to 5. Thus when you downgrade, iTunes gives you an error because you are not supposed to be in 4.3.x with that high of a baseband. Because the wifi version doesn't have a baseband, there is no errors.

  8. #8
    ahh, thanks for explaining that to me

    if your using an iPad 2 wifi (NOT 3G) then you should be able to downgrade because there is no baseband on the wifi only versions
    Last edited by brownan; 06-08-2011 at 09:47 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •