AAAAnd I feel stupid. Really stupid. I wanted to try out IOS 4.3. So like the little dumbass that I am, I looked for it online. And installed it, like I installed 4.2 GM before that. The problem is, and it's a relatively huge one, is that I didn't know that beta = unusable iDevice and GM = "public" = usable iDevice.

So it tells me that this device is not eligible for the beta and it doesn't give me access to the screen that let's me restore the device. My iPad is a brick.

I tried restoring it from DFU mode.. no such luck. The newest public version ( 4.2.1 I believe) downloaded, got verified by apple's servers, the iPad showed the progress bar, iTunes said it was currently restoring, but when the iPad needs to reboot to complete the installation, iTunes tells me there has been an error, and my iPad boots into recovery, wich I can't seem to be able to leave. . I just tried downgrading it. No such luck. Just keeps on coming back to recovery mode now. This sucks.

Any advice?

sorry if this is not the good subforum, please move if that's the case.