I tried to use the toggle. It worked to turn it on, but didn't turn it off. I click and it "works" but nothing happens. Have to turn it off manually in the actual settings. Anyone else or something I am doing wrong?