Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: TIP:Whatsapp on a jailbroken ipad?

  1. #1
    Cool TIP:Whatsapp on a jailbroken ipad?
    As you should notice latest versions of the WhatsApp is not supported on IPAD platform. After couple of tries, I managed to solve this issue. (The latest supported version of WhatsApp was 2.5.3 (the current is 2.5.12)

    But after installing 2.5.3 each time you open the app, it gives a warning about your version and want you to upgrade it to the latest one ( which is not supported). The solution is below:

    • Download 2.5.3 version ( from anywhere you want)
    • Intall it
    • Find the application folder with ifile (it should be smth. like
      file://localhost/var/mobile/Applications/3DE39430-7666-4EeE-B000-xxxxxxxxxxxx/WhatsApp.app/Info.plist)
      Edit info.plist
    • find the current version parameter and replace it with the latest version number.
    • download/use Fullforce from cydia for full screen WhatsApp on your Ipad.

    Enjoy the tip.

    a008mania

    Content of info.plist:

    <!doctype plist public "-//apple//dtd plist 1.0//en" "http://www.apple.com/dtds/propertylist-1.0.dtd">
    <plist version="1.0">
    <dict>
    **<key>cfbundledevelopmentregion</key>
    **<string>english</string>
    **<key>cfbundledisplayname</key>
    **<string>whatsapp</string>
    **<key>cfbundleexecutable</key>
    **<string>whatsapp</string>
    **<key>cfbundleidentifier</key>
    **<string>net.whatsapp.whatsapp</string>
    **<key>cfbundleinfodictionaryversion</key>
    **<string>6.0</string>
    **<key>cfbundlename</key>
    **<string>whatsapp</string>
    **<key>cfbundlepackagetype</key>
    **<string>appl</string>
    **<key>cfbundleresourcespecification</key>
    **<string>resourcerules.plist</string>
    **<key>cfbundlesignature</key>
    **<string>????</string>
    **<key>cfbundlesupportedplatforms</key>
    **<array>
    ** *<string>iphoneos</string>
    **</array>
    **<key>cfbundleversion</key>
    **<string>2.5.12</string>
    **<key>dtplatformname</key>
    **<string>iphoneos</string>
    **<key>dtsdkname</key>
    **<string>iphoneos3.1</string>
    **<key>lsrequiresiphoneos</key>
    **<true/>
    **<key>minimumosversion</key>
    **<string>3.0</string>
    **<key>nsmainnibfile</key>
    **<string>mainwindow</string>
    **<key>uirequireddevicecapabilities</key>
    **<array>
    ** *<string>wifi</string>
    **</array>
    **<key>uirequirespersistentwifi</key>
    **<true/>
    </dict>
    </plist>
    Last edited by a008mania; 01-19-2011 at 05:48 AM.

  2. #2
    This does not work anymore any new methods? Only 2.5.3 or earlier version will not reject it as iPad or iPod but when you try to register it naturally tells you to update to latest version even after editing info.plist to latest version.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •