Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 screen is flickering + video

  1. #1
    Default iPhone 4 screen is flickering + video
    Hello,
    I have my iphone 4 screen flickering when i go into photos or camera and sometime on the main screen too
    *** you can see on the video i uploaded


    now, i've checked with a new screen and it is the screen which is the cause of this issue
    if i replace the screen all is good
    my question is, if any of you have ever encountered this and maybe it is a known/femiliar issue and there is a way to fix this screen and not having to purchase a new one

    any suggestions? is it possiable to fix it? maybe its something related to the resistors on the cable?

    video on youtube
    IMG 0506 - YouTube

    Regards,
    Mosh
    Last edited by moshikoy; 08-16-2013 at 02:35 PM.

  2. #2
    You cleaned the screen with some bad alchool?
    Is this the first time when you opened the iphone?

  3. #3
    hello and thank you for your replay
    i haven't used alcohol
    this phone worked perfectly untill few days ago, nothing special happened (at least not something i've noticed)
    suddwnly it turned to be like that

  4. #4
    Look at the ribbon cable on my old 3gs was same thinf when i pull it off from my pocket it was "white screen" after i opened it i found a little cut at the bottom of the ribbon, check all the canle and flex it easly in both directions.

  5. #5
    iPhone? More like MyPhone
    Join Date
    Nov 2010
    Location
    Indianapolis
    Posts
    293
    Thanks
    4
    Thanked 15 Times in 14 Posts

    I've encountered this A LOT. It's not all the time but I've ran into at least 10 times in the past 4 years. I've ran into it with iPhone and iPod screens. Just the other day I ran into a flickering LCD off of a OEM iPhone 5 screen replacement.

    Typically it is a bad screen. You can try unplugging the battery and screen.. then reconnecting the screen and then battery. This has only helped me once. Anymore if this happens I caulk it up as a bad screen and send it back for a RMA.

    EDIT: Well, I just now watched the video.. and that was NOT the flickering I get. Something is definitely not right.. probably is a bad screen though. lol
    iRepair Indy

  6. #6
    My iPhone is a Part of Me iRevival's Avatar
    Join Date
    Feb 2011
    Location
    Ohio
    Posts
    942
    Thanks
    14
    Thanked 54 Times in 51 Posts

    I actually have a GSM iPhone 4 in my shop that does this all the time, not just in specific apps. I thought it was the screen at first and replaced it. A week later it did the same thing. I always assumed it was a board issue. It's done it to 4 different screens. Sometimes the screens work on other phones afterwards and sometimes it kills the LCD. I'm going to guess that you'll see the issue again. I think it's a problem with the connector on the board but I'm not sure. I've tried everything I can think of to fix the issue but nothing ever works in the long run. Haven't tried and board related fixes aside from cleaning it like it was a water damaged iPhone.
    Twitter: @irevivalrepairs | Instagram: @irevivalrepairs

    iPhone 4/4S Frame Swappers:
    Don't forget about that sim tray lever!
    iPhone 5 Frame Swappers:
    Don't forget about those screen clips!

  7. #7
    iPhone? More like MyPhone
    Join Date
    Nov 2010
    Location
    Indianapolis
    Posts
    293
    Thanks
    4
    Thanked 15 Times in 14 Posts

    Quote Originally Posted by iRevival View Post
    I actually have a GSM iPhone 4 in my shop that does this all the time, not just in specific apps. I thought it was the screen at first and replaced it. A week later it did the same thing. I always assumed it was a board issue. It's done it to 4 different screens. Sometimes the screens work on other phones afterwards and sometimes it kills the LCD. I'm going to guess that you'll see the issue again. I think it's a problem with the connector on the board but I'm not sure. I've tried everything I can think of to fix the issue but nothing ever works in the long run. Haven't tried and board related fixes aside from cleaning it like it was a water damaged iPhone.
    That's always fun.

    Try a different frame?
    iRepair Indy

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •