Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Baseband Flash

  1. #1
    Default Baseband Flash
    Can the iphone 4 gsm baseband be maually flashed?

    If so how?

    This phone is stuck in a loop that does not allow DFU mode and itunes update logs indicate a problem with updating the bb. I am thinking this is what is causing the phone to not go into dfu.

    Thanks,
    Bob

  2. #2
    Sug Luv Super Moderator 2k1's Avatar
    Join Date
    Jan 2011
    Location
    Hammond Louisiana
    Posts
    34,053
    Thanks
    1,815
    Thanked 7,065 Times in 4,206 Posts

    Is iTunes updated to latest version?

    Cause you can't downgrade baseband on iPhone 4 just 3gs

  3. #3
    yes I tunes is up to date, I had this phone a few days and it is stuck in USB auto power up and restore mode. No DFU can be achieved.

    I have no solid info on the phone other than it bricked upgrading to 6.1.0.13. I am not positive but I think the BB is hosed. I can get DFU un-tethered but once I plub in the USB it auto powers up/ reboots into restore mode.

  4. #4
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,954
    Thanks
    76
    Thanked 2,758 Times in 2,647 Posts

    No, you cannot manually flashed Iphone 4 BB without a restore and therefore cannot be easily corrupted.
    What happens when you restore to the latest ?

  5. #5
    The phone will not go restore on Itunes. It is unbroken, is stuck in restore mode but fails to restore during firmware restore with (-1) unknown error

  6. #6
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,954
    Thanks
    76
    Thanked 2,758 Times in 2,647 Posts

    -1 doesn't necessarily be bb corrupted. When I restored my iphone 5 and apple tv 2 , I errored at -1 too, but I managed to restore again successfully with my other computer.

    Note : Apple TV doesn't have a baseband chip.

  7. #7
    From what I can tell -1 error is a hardware issue but since I went through the ITunes logs, the same errors in the log keep appearing related to the BB. I am ready to call it quits unless I can find a way to eliminate the No DFU mode issue.

    I am assuming Apple Mobile Device 6.1.0.13 indicates IOS 6.1?

    When connecting the phone to the USB, the phone automatically powers up and goes into recovery mode with no chance to start DFU Mode. I have tried holding the home button and plugging the phone in...no luck, I have tried every combination of buttons and connections and software but always stuck in recovery.

    3) I have tried tinyumbrella results in nothing happening except rebooting the phone and the phone goes back into recovery mode
    4) tried redsnow but the phone will not go into DFU Mode no matter which method out of about 3 methods of Power and home button combinations and time
    5) tried snowbreeze but the phone will not enter DFU mode
    6) all anti virus and firewall protection disabled and tried all of the above
    7) edited the hosts file and tried all of the above
    8) removed the battery and tried all of the above
    9) tried different USB port and all of the above
    10) tried different computer and all of the above
    11) tried different ispw files

    None of any of the above methods will get the phone out of the auto power up and recovery mode.

    I also checked the update logs. Not knowing exactly how to interpret them, it seems the restore process is indicating that there are some missing plist files and bbupdater problems. These are not all the questionable lines indicating errors but these are the ones I thought are most relevant to my problems.

    1) manifest dict
    2) bbfw item: world.fls
    3) bbfw item: options.plist
    4) devicemap.txt
    5) device_map.plist
    6) basehandlerupdaterstatus: command accepted: NO
    7) ramrod firmware update: failed
    8) ramrod error domain code: 1004
    9) CF Error bbupdater code: 2 null
    10) unrecognized key Bootrags
    11) bbupdater-ping failed
    12) kbbureturnbadchecksum(12/2) invalid bbupdater
    13) unable to convert ramrod error 1004

    I am not sure what this all means but it appears that the baseband is hosed for one thing or the updater is the wrong bbupdate

    How can I determine which baseband version is installed if I cannot get into the phone?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •