+ Reply
Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Flash doesn't work

is a discussion within the

Hardware

forums, a part of the

iPhone Modding

section;
Since I took my iPhone apart to replace the home button and front screen assembly the flash hasn't worked on the camera. I've taken it out and put it back
...
  1. #1
    What's Jailbreak?
    Join Date
    Aug 2008
    Posts
    6
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Default Flash doesn't work
    Since I took my iPhone apart to replace the home button and front screen assembly the flash hasn't worked on the camera. I've taken it out and put it back again a few times but it just doesn't work. The camera works fine it's just the flash that doesn't work.

    Any ideas what could be causing it not to work? I know when you take it out there is a little piece that sticks out to the side of the flash, is this supposed to plug in to anywhere? The way I've put it back in it just sits underneath the digitizer cable, if it's meant to plug in somewhere it might explain why it's not working.

    Thanks

  2. #2
    mvn
    mvn is offline
    iPhone? More like MyPhone mvn's Avatar
    Join Date
    Dec 2011
    Location
    New York
    Posts
    119
    Thanks
    2
    Thanked 11 Times in 11 Posts

    That little piece is not supposed to be plugged in anywhere but if you have accidentally bent it, you might of damaged the LED. I would recommend to buy a new camera from a reputable store, should have everything fixed up. The cable is supposed to sit underneath the digitizer and LCD cable, so that was done right.
    Apple Technician - Modder

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts