+ Reply
Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4S Touch Not Working, Even With New Digitizer

is a discussion within the

Hardware

forums, a part of the

iPhone Modding

section;
Any fixes for this? Aside from replacing the logic board?
...
  1. #1
    Green Apple
    Join Date
    Feb 2009
    Posts
    94
    Thanks
    1
    Thanked 7 Times in 3 Posts

    Default iPhone 4S Touch Not Working, Even With New Digitizer
    Any fixes for this? Aside from replacing the logic board?

  2. #2
    My iPhone is a Part of Me iRevival's Avatar
    Join Date
    Feb 2011
    Location
    Ohio
    Posts
    942
    Thanks
    14
    Thanked 54 Times in 51 Posts

    What happened to it that it stopped working? I'm assuming you've already tried a hard reset. I'd try another screen and don't forget to make sure all of your connections are good. Also try a restore before you do anything drastic like trying to replace the logic board. You might as well just buy another 4S instead. Easier to come by and not much more expensive.
    Twitter: @irevivalrepairs | Instagram: @irevivalrepairs

    iPhone 4/4S Frame Swappers:
    Don't forget about that sim tray lever!
    iPhone 5 Frame Swappers:
    Don't forget about those screen clips!

  3. #3
    Green Apple
    Join Date
    Feb 2009
    Posts
    94
    Thanks
    1
    Thanked 7 Times in 3 Posts

    Connections are good.

    Connected another 4S Front Assembly with the logic board cover off... same problem.

    Did a fresh restore, same issue.

    Any other solutions?

  4. #4
    Green Apple
    Join Date
    Sep 2009
    Posts
    36
    Thanks
    0
    Thanked 3 Times in 2 Posts

    Like the other poster said, what happened to make it stop working? Dropped? Water damaged? Etc?

  5. #5
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,906
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Yeah it's a hardware issue, a restore won't fix it. If all your ribbons are connected properly, there must be damage elsewhere in the device.

  6. #6
    Green Apple
    Join Date
    Feb 2009
    Posts
    94
    Thanks
    1
    Thanked 7 Times in 3 Posts

    Quote Originally Posted by i.Annie View Post
    Yeah it's a hardware issue, a restore won't fix it. If all your ribbons are connected properly, there must be damage elsewhere in the device.
    Thought so :/

    Anybody know what component is responsible for touch? Would the replacement be similar to a water damage backlight fix?

    Phone was dropped, water sensors are white.

  7. #7
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,906
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    The digitizer. I don't remember which ribbon is on it though to connect to the board. Whatever that ribbon if not connected properly will cause the touch function to not work. If the phone was dropped, something might have come loose. Something might have broken off. I mean it's hard to tell exactly, since you're saying everything on the screen is connected properly.

    You might try and contact Cowboy. He's pretty good with hardware troubleshoot.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts