+ Reply
Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: After reinstalling original front assembly, backlight won't work correctly on LCD

is a discussion within the

Hardware

forums, a part of the

iPhone Modding

section;
Title explains it. I took off my front assembly to put it on my friends 3Gs so she could check her texts. Now, both of our LCDs aren't working. That
...
  1. #1
    iPhone? More like MyPhone jiniej's Avatar
    Join Date
    Mar 2008
    Location
    New York
    Posts
    212
    Thanks
    19
    Thanked 12 Times in 5 Posts

    Default After reinstalling original front assembly, backlight won't work correctly on LCD
    Title explains it. I took off my front assembly to put it on my friends 3Gs so she could check her texts. Now, both of our LCDs aren't working. That is: As soon as you activate the LCD (whether it be wake it from sleep or restart/power on) the backlight will go on for a split second (at what looks to be full power) then turn off completely, so the LCD is still displaying pixels but the backlight is off so the image is extremely faint. To me, it looks like a software issue, but I have tried every possible thing I could think of to fix it software wise, to no avail. What did I do???? I look like a complete tool now that I messed up both our phones...
    "foreign corporations > swedish law"

  2. #2
    iPhoneaholic
    Join Date
    Feb 2008
    Posts
    439
    Thanks
    8
    Thanked 35 Times in 33 Posts

    Were the phones on when you did this? If so, you may have blown the coil. Search Google for 3gs coil and you should get several relevant hits. You should be able to check it with a multimeter if you have one, it should have continuity through it.
    If the coil is still good and you have continuity all the way from the flex connector to the coil, then it's possible if you weren't careful with the flex cable, you may have damaged it internally and need a new LCD.

    Have you also tried rebooting by holding down power and home for 10-seconds? Or trying a restore?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts