+ Reply
Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 microphone not working after changing charge port.

is a discussion within the

Hardware

forums, a part of the

iPhone Modding

section;
I replaced the charge port on an iphone 4 because the charge port was corroded. Installed new charge port and the charger is working and docking properly, however the microphone
...
  1. #1
    What's Jailbreak?
    Join Date
    May 2011
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default iPhone 4 microphone not working after changing charge port.
    I replaced the charge port on an iphone 4 because the charge port was corroded. Installed new charge port and the charger is working and docking properly, however the microphone would not work. I can make calls while on speaker, but otherwise they cannot hear me. Pulled the charge connector out of another phone and tested and the phone works like it is supposed to. So i thought I must have got a defective dock connector (included microphone.) When the new dock connector came in I have the same results, microphone is not working. Any thoughts on this would be deeply appreciated. (note: i did use a static strap when handling the dock connector)

  2. #2
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,071
    Thanks
    675
    Thanked 1,357 Times in 1,074 Posts

    Did you try a restore? Sometimes that is needed.

  3. #3
    What's Jailbreak?
    Join Date
    May 2011
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I will try that and let you know. Thanks.

  4. #4
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,071
    Thanks
    675
    Thanked 1,357 Times in 1,074 Posts

    No problem. Hope it works out.

  5. #5
    What's Jailbreak?
    Join Date
    May 2011
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Well I did a restore and the microphone still does not work. Anyone have any ideas. They are sending me a new part, but I am not sure that is the solution...

  6. #6
    Green Apple
    Join Date
    Apr 2011
    Posts
    39
    Thanks
    0
    Thanked 3 Times in 3 Posts

    It sounds like you may have just gotten a defective unit.

  7. #7
    Green Apple
    Join Date
    Dec 2009
    Location
    Detroit, Michigan
    Posts
    75
    Thanks
    1
    Thanked 3 Times in 3 Posts

    I have this same problem , no body just couldn't hear me one day ,but I can hear them , any help? I was thinking of ordering new doconector my self , with more parts what ever it takes to fix ,need help please

  8. #8
    What's Jailbreak?
    Join Date
    May 2011
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Ok so after getting 2 bad parts in I finally have fixed it. Installed my third dock connector and this time it worked. May be looking for a new supplier for this part. Any suggestions?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts