Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: lost WIFI after replacing battery - anyone know why?

  1. #1
    Default lost WIFI after replacing battery - anyone know why?
    Replaced the battery successfully, ensured the little sharp flange was touching the raceway/antenna silver border on the phone but I still don't have WIFI. After looking up some google searches, the wifi antenna is under the docking/speaker assembly. I didn't touch that part when I replaced the battery.

    running a JB 4.2.1 tethered 3GS - Help me, captain!

  2. #2

  3. #3
    What's Jailbreak?
    Join Date
    Mar 2011
    Location
    Illinois
    Posts
    19
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by mrbcc View Post
    Replaced the battery successfully, ensured the little sharp flange was touching the raceway/antenna silver border on the phone but I still don't have WIFI. After looking up some google searches, the wifi antenna is under the docking/speaker assembly. I didn't touch that part when I replaced the battery.

    running a JB 4.2.1 tethered 3GS - Help me, captain!
    The top left portion of the motherboard is where the wifi flex cable plugs in. You would have had to remove this in order to replace the battery. Make sure that it is number one, grounded with the screw holding it against the vibrate switch, and two, the circle connector is firmly plugged into the motherboard. If both of those are done, then it might be a bad wifi IC (Very Difficult to replace). Also ensure all of your connections are secure. The wifi "antenna" is actually behind black tape on the case of the phone. It can be pulled out and replaced. It's also possible that you have torn the flex connector. That is an easy fix, but might take a bit of patience to do. Let me know if this helps. I would have posted a picture of the connector for the wifi, but I'm at work and most of the websites containing the pictures were blacklisted. :/

  4. #4
    Awesome, thanks for the post! If you end up finding a photo, please post as well. I am going to attempt this inspection tonight. I hope it's not the IC

  5. #5
    What's Jailbreak?
    Join Date
    Mar 2011
    Location
    Illinois
    Posts
    19
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by mrbcc View Post
    Awesome, thanks for the post! If you end up finding a photo, please post as well. I am going to attempt this inspection tonight. I hope it's not the IC
    I have uploaded a picture and hopefully going to link to it appropriately on here. Check your connections on the parts that I circled in red. Make sure that the golden part that comes off of the motherboard is in contact with the bezel going around the outside of the iPhone. Make sure this is true as well with the same part on the dock connector...


  6. #6
    Unfortunately I think I'm out of luck. I couldn't seem to find anything wrong with the connections. Would breaks in the lines show up easily or would it be a fine line?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •